Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: NAS drive and movies

  1. #1
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,664

    Default NAS drive and movies

    I have a NAS drive (Buffalo Linkstation) attached to my network.
    In Opensuse 11.3 when wanting to watch a move it would launch right away.

    I'm not sure what I have done with samba iin 11.4 but whenever I try to launch a move it copies the entire move to my computer before launching.
    What setting have I missed here where it would launch right off.

    If I access my NAS drive in dolphin using ftp protocol instead of samba the move launches right off.

    Here is a copy of my smb.conf if it is of any help.

    Code:
    [global]
    	workgroup = farcusnet
    	netbios name = ThinkPad
    	passdb backend = tdbsam
    	name resolve order = bcast host lmhosts wins
    	server string =
    	printing = cups
    	printcap name = cups
    	printcap cache time = 750
    	cups options = raw
    	map to guest = Bad User
    	usershare allow guests = Yes
    	usershare max shares = 100
    	usershare owner only = false
    	local master = yes
    	preferred master = yes
    	os level = 65
    	use client driver = yes
    	include = /etc/samba/dhcp.conf
    
    [homes]
    	comment = Home Directories
    	valid users = %S, %D%w%S
    	browseable = No
    	read only = No
    	inherit acls = Yes
    
    # [profiles]
    # comment = Network Profiles Service
    # path = %H
    # read only = No
    # store dos attributes = No
    # create mask = 0600
    # directory mask = 0700
    
    [users]
    	comment = All users
    	path = /home
    	read only = No
    	inherit acls = Yes
    	veto files = /aquota.user/groups/shares/
    [groups]
    	comment = All groups
    	path = /home/groups
    	read only = No
    	inherit acls = Yes
    [printers]
    	comment = All Printers
    	path = /var/tmp
    	printable = Yes
    	create mask = 0600
    	browseable = No
    [print$]
    	comment = Printer Drivers
    	path = /var/lib/samba/drivers
    	write list = @ntadmin root
    	force group = ntadmin
    	create mask = 0664
    	directory mask = 0775
    
    ## Share disabled by YaST
    # [netlogon]

  2. #2
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: NAS drive and movies

    I would use a cifs mount (like a windows mapped drive) so it appeared that the movie files resided in your filesystem.
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  3. #3
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,664

    Default Re: NAS drive and movies

    thanks

    I have tried the tutorial on your website to use a cifs mount and it seems to work ok.

    I am mounting using the command

    Code:
    mount -t cifs -o guest //192.168.1.30/share /media/LinkStation
    What I can't work out is the command to unmount.

    Although this works well - I don't really understand how I was able to play the files without caching them in the local computer in 11.3 but not 11.4

    One other question . . .
    copying files using the ftp protocol to a local computer seems to happen at twice the speed of using samba.
    Using ftp they transfer at about 9Mb and using Samaba about 3Mb.
    Is this normal?
    ftp and samba are both used within Dolphin.

  4. #4
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,664

    Default Re: NAS drive and movies

    on further investigation it appears there is some kind of problem that is more deep rooted than caching media files before playing.

    In many applications - if I try to open a file on the network (whether a file on the NAS drive or another PC) I am getting the message "can only select local files"

    In the case of media files I get this message in smplayer - but not in kaffeine.
    I did not get this message in smplayer in opensuse 11.3.

    I know that this is a common message to receive in Openoffice and there is not really an immediate solution for it but I had not seen this in other applications.

    Anybody have any idea on what has changed and a possible solution?

  5. #5

    Default Re: NAS drive and movies

    I have a similar problem. I posted it under apps but no replies. I used dolphin to connect to it as a widoze network drive and everything works fine except if I try and play a movi on it with kaffeine. Kaffeine just comes up with

    Cannot find input plugin for MRL "smb://,,,,,,,,,,,,,,,,etc.....................avi".

    Looking about on the web there are comments that kaff needs xine-smb to play files over the network. No opensuse source for this but I did find an rpm for mandriva. If I try and install that it wants xine-plugins. Also seems that I would have to copy xine-smb to the required place. xine-plugins isn't available on opensuse repo's either. Only xine with plugins. Odd thing is that I thought that these were for browsers and wonder if breaking the xine-plugins would work but then where would I place xine-smb.

    Leaves me shaking my head as playing things off the network isn't an uncommon thing to want to do.

    One good aspect of this is that getting kde to connect to the nas was nice and easy. Configuring the d-link 325 without going near the installation cd was easy too. It has a full web interface so I just had to assign it a static ip via my router.

    -
    Leap 42.2 KDE 5.26
    3.6gig Xeon, 64bit SATA Raid home - Linux Raid 1
    All software on a flash drive, SATA swap & Temp files,

  6. #6
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,664

    Default Re: NAS drive and movies

    hmmmmm . . . yeah, I am a little different to you.
    I have no problem with xine/kaffeine. This is one of the few applications that can load from the nas drive

  7. #7

    Default Re: NAS drive and movies

    I should add as it may help others I can play mp3's, load pdf's and doc's etc without any problem.

    -
    Leap 42.2 KDE 5.26
    3.6gig Xeon, 64bit SATA Raid home - Linux Raid 1
    All software on a flash drive, SATA swap & Temp files,

  8. #8
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,664

    Default Re: NAS drive and movies

    digging a little deeper the problem may be specific to mplayere / smplayer as other media applications can play without problem and without caching.
    Interestingly mplayer and smplayer want to cache the file locally yet kmplayer will play without caching while using the same version of mplayer for playback. So it seems there is some kind of problem with the way mplayer (and its gtk interface) and smplayer behave with samba shares.

  9. #9

    Default Re: NAS drive and movies

    Don't know if you have looked at my samba slow post but I suspect it's a kde problem as it looks like the "can only select local files" is from kde. It may relate to this
    https://bugs.kde.org/253547
    which would explain why you didn't have this problem with an earlier release. Trouble is that vlc.desktop now has the correct incantations. It's also looks like kaffiene doesn't really expect to have to use a input plugin to receive these streams (ie data flows, most often a file as far as an app is concerned - not streaming video). From the few progs that I have tested there is clearly something amiss with how linux or more likely kde and it's back ends handle these streams. It should be transparent to an application. That way changes don't usually screw things up. Ranting 'cause I'm a software engineer. That sort of problem annoys me.

    As far as my d-link dn-325 nas goes both samba and windoze are happy with it so I'm sure the problem doesn't lie there.

    -
    Leap 42.2 KDE 5.26
    3.6gig Xeon, 64bit SATA Raid home - Linux Raid 1
    All software on a flash drive, SATA swap & Temp files,

  10. #10
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,664

    Default Re: NAS drive and movies

    Quote Originally Posted by ajohnw View Post
    Don't know if you have looked at my samba slow post but I suspect it's a kde problem as it looks like the "can only select local files" is from kde. It may relate to this
    https://bugs.kde.org/253547
    which would explain why you didn't have this problem with an earlier release. Trouble is that vlc.desktop now has the correct incantations. It's also looks like kaffiene doesn't really expect to have to use a input plugin to receive these streams (ie data flows, most often a file as far as an app is concerned - not streaming video). From the few progs that I have tested there is clearly something amiss with how linux or more likely kde and it's back ends handle these streams. It should be transparent to an application. That way changes don't usually screw things up. Ranting 'cause I'm a software engineer. That sort of problem annoys me.

    As far as my d-link dn-325 nas goes both samba and windoze are happy with it so I'm sure the problem doesn't lie there.

    -
    Thanks for the link to the bug report.

    It seems since KDE 4.5 non KDE4 native apps need the line
    Code:
    categories=qt;KDE
    in their .desktop file

    Adding the line fixed my problem right up.
    Also explains why I did not see the problem in OpenSuse 11.3 as that used an earlier version of KDE.

    Thanks again.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •