Results 1 to 8 of 8

Thread: Howto disable background images at boot

  1. #1
    Join Date
    Dec 2008
    Location
    Slovenia
    Posts
    63

    Default Howto disable background images at boot

    Please help me with this one...

    I have managet to customize my logon screen the way i want it,

    1.

    Problem is i do not wish to have background imege at bootsplash screen (still want to receive option how to boot just simple text);

    2.

    And later when system is loading modules and starting i just want to have simple black background on my screen, with nice text (verbose) telling me what is done.

    This is my dream


    If u help me with this one i would have apreciate it sooooo much.

    Running 11.3 x64 opensuseSUSE


    greetings!!!
    Stipi69

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,728

    Default Re: Howto disable background images at boot

    You are talking about two splash screens, the GRUB one and the Linux boot one.

    The first one is configured in /boot/grub/menu.lst with the gfxmenu line. I did not test, but see what happens when you remove this line. (First make a copy of menu.lst of course).

    The second is a Kernel parameter and is also in /boot/grub/menu.lst. You will find for each Linux entry a Kernel parameter splash=silent. Change it to splash=0.
    Henk van Velden

  3. #3

    Default Re: Howto disable background images at boot

    Quote Originally Posted by hcvv View Post
    The first one is configured in /boot/grub/menu.lst with the gfxmenu line. I did not test, but see what happens when you remove this line. (First make a copy of menu.lst of course).
    Yout get the Grub menu in text mode.

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,728

    Default Re: Howto disable background images at boot

    Quote Originally Posted by please_try_again View Post
    Yout get the Grub menu in text mode.
    And that is what the OP wants if I understand correct.
    Henk van Velden

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Howto disable background images at boot

    On 2011-05-20 19:36, stipi69 wrote:
    > And later when system is loading modules and starting i just want to
    > have simple black background on my screen, with nice text (verbose)
    > telling me what is done.


    Kernel boot option splash=verbose, grub menu.lst file.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,728

    Default Re: Howto disable background images at boot

    Thank you, I think verbose is a better one then 0.
    Henk van Velden

  7. #7
    Join Date
    Dec 2008
    Location
    Slovenia
    Posts
    63

    Default Re: Howto disable background images at boot

    Thanks for the help everyone!

    @ hcvv:

    your solution is the best for my problem.... beautiful black with text, like i want it... indeed you have to change to 0 in every line containing "splash="


    manny thanks, works like a charm!
    Stipi69

  8. #8
    Join Date
    Jul 2011
    Location
    Central Kentucky, USA
    Posts
    1

    Default Re: Howto disable background images at boot

    SuSE Linux boots with a graphical grub menu and splash screen. This can be disruptive to administrators supporting the servers through the RSA/IMM/ILO connection as the graphics can load very slowly .
    Disable all boot graphics:

    1. Change VGA mode to normal and remove the splash screen.
    edit /boot/grub/menu.lst
    change the kernel parameters:
    vga=0x314 to vga=normal
    splash=silent to splash=0

    2. Remove the graphical grub bootloader menu.
    comment or remove grub parameter, also in /boot/grub/menu.lst:
    gfxmenu (hd0,1)/boot/message
    becomes
    #gfxmenu (hd0,1)/boot/message

    3. Have the server boot to runlevel 3 by default:
    edit /etc/inittab
    # The default runlevel is defined here
    id:5:initdefault:

    change to
    id:3:initdefault:

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •