Results 1 to 4 of 4

Thread: Error mounting NFS shares ato boot time

  1. #1

    Default Error mounting NFS shares ato boot time

    Hi!

    I'm using Opensuse 11.4 updated from 11.3, update from 11.2 updated from.....

    I'm mounting at boot time (in fstab) some shares from an opensuse 11.2 server. Mounting worked fine in 11.2, 11.3 and also in 11.4 but suddenly (maybe an automatic update?) It stopped working.... sometimes.

    Sometimes they are mounted properly but sometimes they aren't.
    When mount fails I get a log error: "rpc.statd is not runninf but is required for remote locking. Either use '-o nolock' to keep locks local or start statd"

    If I run manually (as root) mount -a the shares mount properly always, so I thought it was a problem of timing (the service starting late) so I tried to get a script to run after the network initialitation, the script does: "mount -a". But it doesn't work either.

    Any help?

    Thanks in advance.
    regards

  2. #2

    Default Re: Error mounting NFS shares ato boot time

    fperal wrote:
    > I'm using Opensuse 11.4 updated from 11.3, update from 11.2 updated
    > from.....
    >
    > I'm mounting at boot time (in fstab) some shares from an opensuse 11.2
    > server. Mounting worked fine in 11.2, 11.3 and also in 11.4 but
    > suddenly (maybe an automatic update?) It stopped working.... sometimes.


    > Any help?


    Sounds like you may need the _netdev option in fstab

  3. #3

    Default Re: Error mounting NFS shares ato boot time

    I tested it but it didn't work either.
    I've noticed a curious behaviour (even with _netdev or without it), some times the system mounts all shares at boot time sometimes the system mounts none of them, but sometimes it mounts just some of them.

    regards

  4. #4

    Default Re: Error mounting NFS shares ato boot time

    It's a problem of timing.
    I've added an script, which runs at the end of the boot procces, the script is:

    mount -a
    sleep 20s
    mount -a
    sleep 1m
    mount -a
    sleep 1m
    mount -a


    Yep, it's a very ugly quick fix!! but now it mounts all of the shared filesystems. So the problem is you need to wait some time before mounting network filesystem.
    I'll continue searching

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •