Results 1 to 7 of 7

Thread: How do I set vlc as the default video player?

  1. #1

    Default How do I set vlc as the default video player?

    Heya,

    I just reinstalled my laptop with OpenSUSE 11.4, 64-bit and I'm using gnome 3.0, and it looks great. I can't figure out how to change the default video player to vlc though...

    I've tried going to 'Applications' --> 'System Tools' --> 'System Settings' --> 'System info'

    Here I can choose default programs, however vlc does not appear in the drop-down menu for videos. I do have vlc installed. I can choose to play videos with it when I right-click video files. But I'd like vlc to be the default so that I can just double click the video file and vlc plays it.

    It is a little bit confusing as totem is set as the default video player in the above-mentioned window, but when I double click a video file banshee starts...

    Daqar
    Acer TravelMate 7730G Intel C2D P8400, 4GB memory, OpenSUSE 12.3 w. KDE 64bit. 4 year of linux experience, 19 years of Windows experience.

  2. #2
    Join Date
    Aug 2010
    Location
    Aveiro, Portugal
    Posts
    313

    Default Re: How do I set vlc as the default video player?

    Try running on a console with your normal user:
    Code:
    gnome-default-applications-properties

  3. #3
    Join Date
    Dec 2010
    Location
    Ankara, Turkey
    Posts
    250

    Default Re: How do I set vlc as the default video player?

    Quote Originally Posted by Daqar View Post

    Here I can choose default programs, however vlc does not appear in the drop-down menu for videos.
    I don't use gnome 3 but, do you see browse option somewhere near, Maybe you can browse and select vlc player.
    The only problem with troubleshooting is that sometimes trouble shoots back.
    My blog (in Turkish): http://yasar.serveblog.net

  4. #4

    Default Re: How do I set vlc as the default video player?

    Quote Originally Posted by ketheriel View Post
    Try running on a console with your normal user:
    Code:
    gnome-default-applications-properties
    Using that I get the following message:

    Code:
    jacob@linux-z740:~> gnome-default-applications-properties
    If 'gnome-default-applications-properties' is not a typo you can use command-not-found to lookup the package that contains it, like this:
        cnf gnome-default-applications-properties
    jacob@linux-z740:~>
    There is no browse option in that window I mentioned. I just rechecked it...

    Daqar
    Acer TravelMate 7730G Intel C2D P8400, 4GB memory, OpenSUSE 12.3 w. KDE 64bit. 4 year of linux experience, 19 years of Windows experience.

  5. #5
    Join Date
    Aug 2010
    Location
    Aveiro, Portugal
    Posts
    313

    Default Re: How do I set vlc as the default video player?

    Quote Originally Posted by Daqar View Post
    Using that I get the following message:

    Code:
    jacob@linux-z740:~> gnome-default-applications-properties
    If 'gnome-default-applications-properties' is not a typo you can use command-not-found to lookup the package that contains it, like this:
        cnf gnome-default-applications-properties
    jacob@linux-z740:~>
    There is no browse option in that window I mentioned. I just rechecked it...

    Daqar
    I'm logged into something else (Unity), but I will take a look within the hour and let you know.

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: How do I set vlc as the default video player?

    Right click the multimedia file > Properties > Opens With
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7
    Join Date
    Aug 2010
    Location
    Aveiro, Portugal
    Posts
    313

    Default Re: How do I set vlc as the default video player?

    According to the developers of VLC: How to make VLC the default player - VideoLAN Wiki

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •