Results 1 to 5 of 5

Thread: No login screen

  1. #1

    Default No login screen

    Hello All,

    I just did a fresh install of 11.4 and I LOVE IT!!! One of the little issues I am having though, is that there is no login screen. No matter what settings I change it still auto-logs me in.

    I am using GRUB and the Boot Loader Location has both "Boot from MBR" and "Boot from Root Partition". Is this right? I would think that I should just boot from the MBR.

    Anyone know how to resolve this?

    Thanks,

    Craigbert

  2. #2
    Join Date
    Jul 2009
    Location
    Montreal, Québec
    Posts
    833

    Default Re : No login screen

    Hi,

    Go into yast->system->etc/sysconfig editor (something like this)->desktop->display manager and check the key DISPLAYMANAGER_AUTOLOGIN and make sure the input field is empy.

  3. #3

    Default Re: No login screen

    Thanks! That worked wonderfully well!

    Now, how do I customize the login screen?

    When I change the theme in the Personal settings it makes no difference to the login screen.

    Thoughts?

    Craigbert

  4. #4
    Join Date
    Aug 2008
    Location
    Winnipeg, Canada
    Posts
    203

    Default Re: No login screen

    Quote Originally Posted by craigbert View Post
    Thanks! That worked wonderfully well!

    Now, how do I customize the login screen?

    When I change the theme in the Personal settings it makes no difference to the login screen.

    Thoughts?

    Craigbert
    Here is a link that will work changing the Theme for KDE.

    Cheers!

  5. #5

    Default Re: No login screen

    I had a similar problem: 11.4 boot fine in X (initdefault=5) but in text mode (initdefaul=3) first some text is showed and then the video mode is switched to an incompatible mode, because the horizontal frequency is set to 86kHz, which it is not supported by my monitor (Faltron 775FT), and no more text is showed in the console. "Blind" login and startx works, entering in graphic mode and works fine.

    I tried various parameters in the VGA-mode field do Boot loader in Yast (f.ex. vga=0x317, etc.) combining many resolution-refresh setting, but nothing worked.

    Then, in the Yast boot loader, I leave the VGA-mode setting in "unspecified" and in the options
    (Optional Kernel line parrameter) field I wrote:

    video=1024x768@60

    and the problem was eliminated.

    Then I tested in this way several mode-refresh parameters and always they worked.

    I apologize for the ugly English.

    This problem only happen with 11.4, but the 11.2 always worked fine in the same desktop.

    Carlos

    >>>> uname -a
    Linux fofo 2.6.37.6-0.5-desktop #1 SMP PREEMPT 2011-04-25 21:48:33 +0200 x86_64 x86_64 x86_64 GNU/Linux

    >>>> lspci
    00:00.0 Host bridge: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller (rev 02)
    00:02.0 VGA compatible controller: Intel Corporation 82G33/G31 Express Integrated Graphics Controller (rev 02)

    >>>> cat /boot/grub/menu.lst
    # Modified by YaST2. Last modification on Sat May 21 16:34:30 BRT 2011
    # THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader
    # Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader

    default 10
    timeout 8
    ##YaST - generic_mbr
    ##YaST - activate

    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title Desktop -- openSUSE 11.4 - 2.6.37.6-0.5
    rootnoverify (hd0,1)
    kernel /vmlinuz-2.6.37.6-0.5-desktop root=/dev/disk/by-id/ata-ST31500341AS_9VS1WFA0-part7 video=1280x1024@60
    initrd /initrd-2.6.37.6-0.5-desktop
    [...]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •