Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Wrong filename case when inserting a camera memory card.

  1. #1
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Wrong filename case when inserting a camera memory card.



    In short: the files in 11.2 of the memory card from my camera were lower
    case, and in 11.4 they are upper case. Thus, F-spot uploads all the photos
    again, and I get two copies of each, one low case (old), another upper case
    (new), without the comments or rotations that I had made.

    How can I make the system automount it again in lower case?

    I knew the proper options to do this manually in fstab, but not via udev or
    whatever it uses.

    Code:
    Messages log:
    
    >
    > May 19 19:39:10 minas-tirith kernel: [ 3510.269125] usb 1-1: new high speed USB device using ehci_hcd and address 3
    > May 19 19:39:10 minas-tirith kernel: [ 3510.395733] usb 1-1: New USB device found, idVendor=0bda, idProduct=0159
    > May 19 19:39:10 minas-tirith kernel: [ 3510.395739] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    > May 19 19:39:10 minas-tirith kernel: [ 3510.395743] usb 1-1: Product: USB2.0-CRW
    > May 19 19:39:10 minas-tirith kernel: [ 3510.395746] usb 1-1: Manufacturer: Generic
    > May 19 19:39:10 minas-tirith kernel: [ 3510.395749] usb 1-1: SerialNumber: 20071114173400000
    > May 19 19:39:10 minas-tirith kernel: [ 3510.401165] scsi7 : usb-storage 1-1:1.0
    > May 19 19:39:11 minas-tirith mtp-probe: checking bus 1, device 3: "/sys/devices/pci0000:00/0000:00:1a.7/usb1/1-1"
    > May 19 19:39:11 minas-tirith mtp-probe: bus: 1, device: 3 was not an MTP device
    > May 19 19:39:11 minas-tirith kernel: [ 3511.403550] scsi 7:0:0:0: Direct-Access     Generic- Multi-Card       1.00 PQ: 0 ANSI: 0 CCS
    > May 19 19:39:11 minas-tirith kernel: [ 3511.403893] sd 7:0:0:0: Attached scsi generic sg2 type 0
    > May 19 19:39:12 minas-tirith kernel: [ 3511.940120] sd 7:0:0:0: [sdb] 7698432 512-byte logical blocks: (3.94 GB/3.67 GiB)
    > May 19 19:39:12 minas-tirith kernel: [ 3511.940995] sd 7:0:0:0: [sdb] Write Protect is off
    > May 19 19:39:12 minas-tirith kernel: [ 3511.941001] sd 7:0:0:0: [sdb] Mode Sense: 03 00 00 00
    > May 19 19:39:12 minas-tirith kernel: [ 3511.941027] sd 7:0:0:0: [sdb] Assuming drive cache: write through
    > May 19 19:39:12 minas-tirith kernel: [ 3511.945618] sd 7:0:0:0: [sdb] Assuming drive cache: write through
    > May 19 19:39:12 minas-tirith kernel: [ 3511.947135]  sdb: sdb1
    > May 19 19:39:12 minas-tirith kernel: [ 3511.949612] sd 7:0:0:0: [sdb] Assuming drive cache: write through
    > May 19 19:39:12 minas-tirith kernel: [ 3511.949627] sd 7:0:0:0: [sdb] Attached SCSI removable disk
    
    Mounted as:
    
    > minas-tirith:~ # mount | grep sdb
    > /dev/sdb1 on /media/AEA9-05F6 type vfat (rw,nosuid,nodev,relatime,uid=1000,gid=100,fmask=0022,dmask=0077,codepage=cp437,iocharset=iso8859-1,shortname=mixed,showexec,utf8,flush,errors=remount-ro,uhelper=udisks)

    Can I somehow force it to be mounted lowercase as before, or do I have to
    accept this change?


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Wrong filename case when inserting a camera memory card.

    On 2011-05-19 20:03, Carlos E. R. wrote:

    Ping!

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  3. #3
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Wrong filename case when inserting a camera memory card.

    On 05/20/2011 02:33 PM, Carlos E. R. wrote:
    > Ping!


    wish i could help, but all i can actually do is guess you need a little
    higher level of technical knowledge than you are highly likely to find
    here, before you next wanna ping!

    so, i'd suggest:

    post to alt.os.linux.suse
    post to an openSUSE mail list
    ask on the IRC channel
    etc

    --
    dd CAVEAT: http://is.gd/bpoMD
    [NNTP via openSUSE 11.4 [2.6.37.6-0.5] + KDE 4.6.0 + Thunderbird 3.1.10]
    Dual booting with Sluggish Loser7 on Acer Aspire One D255

  4. #4
    Join Date
    Aug 2008
    Location
    Behind the 8 ball
    Posts
    116

    Default Re: Wrong filename case when inserting a camera memory card.

    I did some googling, this may be an issue with vfat.

    Some people suggest mounting with the following options
    Code:
    shortname=lower
    posix=1
    Good luck,
    Hiatt

  5. #5
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Wrong filename case when inserting a camera memory card.

    jthiatt08 wrote:
    > Some people suggest mounting with the following options
    >
    > Code:
    > --------------------
    >
    > shortname=lower
    > posix=1
    >
    > --------------------
    >
    >

    I think this is what Carlos already knows and this does not help for udev.
    The point is how to tell udev (which is used by gnome and kde for that
    desktop environment automount feature or however it is called) to do the
    same. I did not find out so far. With fstab it is obviously no problem, with
    udev rules I seem also to be completely unable to find out how to do the
    same.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Wrong filename case when inserting a camera memory card.

    On 2011-05-20 15:36, jthiatt08 wrote:
    >
    > I did some googling, this may be an issue with vfat.


    Yes, indeed, vfat mount has options to convert all files to uppercase when
    mounting in linux. I know that.


    > Some people suggest mounting with the following options
    >
    > Code:
    > --------------------
    >
    > shortname=lower
    > posix=1
    >
    > --------------------


    It is automounted by Gnome, thus the options are beyond my reach.

    I may have to indeed, mount it manually always to bypass this bug.


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Wrong filename case when inserting a camera memory card.

    On 2011-05-20 15:08, DenverD wrote:
    > On 05/20/2011 02:33 PM, Carlos E. R. wrote:
    >> Ping!

    >
    > wish i could help, but all i can actually do is guess you need a little
    > higher level of technical knowledge than you are highly likely to find
    > here, before you next wanna ping!
    >
    > so, i'd suggest:
    >
    > post to alt.os.linux.suse
    > post to an openSUSE mail list
    > ask on the IRC channel
    > etc


    No, this is something that the good folks at openSUSE/Gnome have done. They
    default to mount vfat with the options that convert all names to upper
    case, while on previous version they did not - thus breaking things.


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  8. #8
    Join Date
    Aug 2008
    Location
    Behind the 8 ball
    Posts
    116

    Default Re: Wrong filename case when inserting a camera memory card.

    Sorry, I guess I'm not much help here.

  9. #9
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,683
    Blog Entries
    4

    Default Re: Wrong filename case when inserting a camera memory card.

    It seems it's hardcoded in DeviceKit and the developers get flamed here:

    Rant: Arrogant Developers - Kirsle.net

    I'm fortunately I didn't hit this because I download directly from camera using USB from digikam rather than deal with flash cards.

  10. #10
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Wrong filename case when inserting a camera memory card.

    On 2011-05-20 15:50, Carlos E. R. wrote:

    > No, this is something that the good folks at openSUSE/Gnome have done. They
    > default to mount vfat with the options that convert all names to upper
    > case, while on previous version they did not - thus breaking things.


    I'm guessing that it is 11.2 which was wrong and converted to lowercase. I
    have to check two things later and I will comment on that.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •