Results 1 to 6 of 6

Thread: lmsensors: settings gone after reboot

  1. #1
    Join Date
    Jun 2009
    Location
    Berlin
    Posts
    158

    Default lmsensors: settings gone after reboot

    hi all,

    i just setup the sensors to use with conky. I do this by issuing the following:
    Code:
    sensors-detect
    and
    Code:
    chkconfig -l lm_sensors
    lm_sensors                0:off  1:off  2:on   3:on   4:off  5:on   6:off
    reveals that the daemon is setup to start in the particular runlevel.

    however after rebooting the system, the settings are gone and executing

    Code:
    sensors
    shows only incorrect values.

    my investigation has pointed me to the the problem that sensors is useing /etc/sensors3.conf and not /etc/sysconfig/lm_sensors as it should be.

    any suggestions to that?

  2. #2
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: lmsensors: settings gone after reboot

    It uses both files, but can you give an example what the wrong output looks
    like, to get an idea.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  3. #3
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: lmsensors: settings gone after reboot

    l1zard wrote:

    > however after rebooting the system, the settings are gone and
    > executing
    >

    Sorry, pressed send too early. What do you mean by that, which settings
    exactly are gone and from which configuration file?

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  4. #4
    Join Date
    Jun 2009
    Location
    Berlin
    Posts
    158

    Default Re: lmsensors: settings gone after reboot

    actually this problem also apears when i restart the lm_senosrs with

    Code:
    service lm_sensors restart
    After executing sensors-detect i get a sensors output like this:
    Code:
    Core0 Temp0 23 °C
    Core0 Temp1 27 °C
    
    Core1 Temp0 24 °C
    Core1 Temp1 26 °C
    When i restart the sensors daemaon i get a lot of stuff including deivces indicating alarms which i do not own.

    i also investigated the problem and put some logfiles:

    tail -f /var/log/messages during sensors-detect
    Code:
    May 20 16:40:02 Alucard kernel: [131521.153128] w83627ehf: Found W83627EHG chip at 0x290
    May 20 16:43:13 Alucard kernel: [131711.829362] i2c /dev entries driver
    lsmod | sort before executing sensors-detect:
    Code:
    Module                  Size  Used by
    ata_generic             3015  0 
    button                  5497  0 
    cbc                     2665  4 
    cdrom                  38437  1 sr_mod
    cpufreq_conservative    10080  0 
    cpufreq_powersave        930  0 
    cpufreq_userspace       2631  0 
    crc16                   1419  1 ext4
    dm_crypt               12912  4 
    dm_mod                 76266  22 dm_crypt,dm_snapshot
    dm_snapshot            34002  0 
    edd                     8752  0 
    ext4                  373665  4 
    fan                     2575  0 
    fat                    52552  1 vfat
    forcedeth              53976  0 
    fuse                   72011  3 
    hwmon_vid               2410  1 w83627ehf
    i2c_nforce2             5927  0 
    ip6_tables             13404  4 ip6t_LOG,ip6table_raw,ip6table_mangle,ip6table_filter
    ip6t_LOG                7940  5 
    ip6t_REJECT             4192  3 
    ip6table_filter         1375  1 
    ip6table_mangle         1636  0 
    ip6table_raw            1203  1 
    ip_tables              13128  2 iptable_raw,iptable_filter
    ipt_LOG                 7845  5 
    ipt_REJECT              2200  3 
    iptable_filter          1466  1 
    iptable_raw             1294  1 
    jbd2                   78939  1 ext4
    joydev                  9578  0 
    k8temp                  3360  0 
    linear                  4242  0 
    loop                   16396  0 
    mperf                   1271  1 powernow_k8
    nf_conntrack           75967  5 nf_conntrack_ipv6,xt_NOTRACK,nf_conntrack_netbios_ns,nf_conntrack_ipv4,xt_conntrack
    nf_conntrack_ipv4       8584  3 
    nf_conntrack_ipv6       8286  3 
    nf_conntrack_netbios_ns     1366  0 
    nf_defrag_ipv4          1281  1 nf_conntrack_ipv4
    nf_defrag_ipv6          9434  1 nf_conntrack_ipv6
    nls_cp437               4999  2 
    nls_iso8859_1           3329  2 
    nvidia               9769840  40 
    parport                34550  2 ppdev,parport_pc
    parport_pc             33763  0 
    pata_amd                9422  1 
    pcspkr                  1662  0 
    powernow_k8            18979  1 
    ppdev                   7883  0 
    processor              36507  1 powernow_k8
    quota_tree              8596  1 quota_v2
    quota_v2                4338  2 
    sata_nv                20771  2 
    serio_raw               4378  0 
    sg                     28446  0 
    sha256_generic          9607  8 
    snd                    67246  14 snd_pcm_oss,snd_mixer_oss,snd_seq,snd_seq_device,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
    snd_hda_codec          95891  2 snd_hda_codec_realtek,snd_hda_intel
    snd_hda_codec_realtek   274527  1 
    snd_hda_intel          25104  2 
    snd_hwdep               6198  1 snd_hda_codec
    snd_mixer_oss          17521  1 snd_pcm_oss
    snd_page_alloc          8121  2 snd_hda_intel,snd_pcm
    snd_pcm                88841  3 snd_pcm_oss,snd_hda_intel,snd_hda_codec
    snd_pcm_oss            48271  0 
    snd_seq                57777  0 
    snd_seq_device          6678  1 snd_seq
    snd_timer              22055  2 snd_seq,snd_pcm
    soundcore               7270  1 snd
    sr_mod                 15048  0 
    thermal                13154  0 
    thermal_sys            14790  3 fan,processor,thermal
    vfat                   10644  2 
    w83627ehf              21920  0 
    x_tables               18727  16 ip6t_LOG,xt_tcpudp,xt_pkttype,ipt_LOG,xt_limit,ip6t_REJECT,ip6table_raw,xt_NOTRACK,ipt_REJECT,iptable_raw,iptable_filter,ip6table_mangle,ip_tables,xt_conntrack,ip6table_filter,ip6_tables
    xt_NOTRACK               864  4 
    xt_conntrack            2480  6 
    xt_limit                1753  10 
    xt_pkttype               960  3 
    xt_tcpudp               3052  2
    logfile after i executed sensors-detect:
    Code:
    odule                  Size  Used by
    ata_generic             3015  0 
    button                  5497  0 
    cbc                     2665  4 
    cdrom                  38437  1 sr_mod
    cpufreq_conservative    10080  0 
    cpufreq_powersave        930  0 
    cpufreq_userspace       2631  0 
    crc16                   1419  1 ext4
    dm_crypt               12912  4 
    dm_mod                 76266  22 dm_crypt,dm_snapshot
    dm_snapshot            34002  0 
    edd                     8752  0 
    ext4                  373665  4 
    fan                     2575  0 
    fat                    52552  1 vfat
    forcedeth              53976  0 
    fuse                   72011  3 
    i2c_nforce2             5927  0 
    ip6_tables             13404  4 ip6t_LOG,ip6table_raw,ip6table_mangle,ip6table_filter
    ip6t_LOG                7940  5 
    ip6t_REJECT             4192  3 
    ip6table_filter         1375  1 
    ip6table_mangle         1636  0 
    ip6table_raw            1203  1 
    ip_tables              13128  2 iptable_raw,iptable_filter
    ipt_LOG                 7845  5 
    ipt_REJECT              2200  3 
    iptable_filter          1466  1 
    iptable_raw             1294  1 
    jbd2                   78939  1 ext4
    joydev                  9578  0 
    k8temp                  3360  0 
    linear                  4242  0 
    loop                   16396  0 
    mperf                   1271  1 powernow_k8
    nf_conntrack           75967  5 nf_conntrack_ipv6,xt_NOTRACK,nf_conntrack_netbios_ns,nf_conntrack_ipv4,xt_conntrack
    nf_conntrack_ipv4       8584  3 
    nf_conntrack_ipv6       8286  3 
    nf_conntrack_netbios_ns     1366  0 
    nf_defrag_ipv4          1281  1 nf_conntrack_ipv4
    nf_defrag_ipv6          9434  1 nf_conntrack_ipv6
    nls_cp437               4999  2 
    nls_iso8859_1           3329  2 
    nvidia               9769840  40 
    parport                34550  2 ppdev,parport_pc
    parport_pc             33763  0 
    pata_amd                9422  1 
    pcspkr                  1662  0 
    powernow_k8            18979  1 
    ppdev                   7883  0 
    processor              36507  1 powernow_k8
    quota_tree              8596  1 quota_v2
    quota_v2                4338  2 
    sata_nv                20771  2 
    serio_raw               4378  0 
    sg                     28446  0 
    sha256_generic          9607  8 
    snd                    67246  14 snd_pcm_oss,snd_mixer_oss,snd_seq,snd_seq_device,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
    snd_hda_codec          95891  2 snd_hda_codec_realtek,snd_hda_intel
    snd_hda_codec_realtek   274527  1 
    snd_hda_intel          25104  2 
    snd_hwdep               6198  1 snd_hda_codec
    snd_mixer_oss          17521  1 snd_pcm_oss
    snd_page_alloc          8121  2 snd_hda_intel,snd_pcm
    snd_pcm                88841  3 snd_pcm_oss,snd_hda_intel,snd_hda_codec
    snd_pcm_oss            48271  0 
    snd_seq                57777  0 
    snd_seq_device          6678  1 snd_seq
    snd_timer              22055  2 snd_seq,snd_pcm
    soundcore               7270  1 snd
    sr_mod                 15048  0 
    thermal                13154  0 
    thermal_sys            14790  3 fan,processor,thermal
    vfat                   10644  2 
    x_tables               18727  16 ip6t_LOG,xt_tcpudp,xt_pkttype,ipt_LOG,xt_limit,ip6t_REJECT,ip6table_raw,xt_NOTRACK,ipt_REJECT,iptable_raw,iptable_filter,ip6table_mangle,ip_tables,xt_conntrack,ip6table_filter,ip6_tables
    xt_NOTRACK               864  4 
    xt_conntrack            2480  6 
    xt_limit                1753  10 
    xt_pkttype               960  3 
    xt_tcpudp               3052  2
    diff between logfile_before logfile_after:
    Code:
    19d18
    < hwmon_vid               2410  1 w83627ehf
    77d75
    < w83627ehf              21920  0
    this looks to me like sensors-detect unloads modules while the daemon loads them again. My suspicion gets hardened by the fact that the init script does in fact load modules.

    My /etc/sysconfig/lm_sensors file looks like this:
    Code:
    # Generated by sensors-detect on Fri May 20 02:27:35 2011
    ## Path: Hardware/Sensors
    ## Description:         Defines the modules to used
    ## Type:                string
    ## ServiceRestart:      lm_sensors
    ## Default:             ""
    #
    # This file is sourced by /etc/init.d/lm_sensors and defines the modules to
    # be loaded/unloaded.
    #
    # The format of this file is a shell script that simply defines variables:
    # HWMON_MODULES for hardware monitoring driver modules, and optionally
    # BUS_MODULES for any required bus driver module (for example for I2C or SPI).
    
    HWMON_MODULES="w83627ehf"
    
    # For compatibility reasons, modules are also listed individually as variables
    #    MODULE_0, MODULE_1, MODULE_2, etc.
    # You should use BUS_MODULES and HWMON_MODULES instead if possible.
    
    MODULE_0=w83627ehf
    changing the /etc/sensors3.conf seems to have no effect add all. even if i pipe

    Code:
    :> /etc/sensors3.conf
    the effect stays the same.

  5. #5
    Join Date
    Nov 2009
    Location
    ND, USA
    Posts
    1,131

    Default Re: lmsensors: settings gone after reboot

    On Thu May 19 2011 12:36 pm, l1zard wrote:

    >
    > hi all,
    >
    > i just setup the sensors to use with conky. I do this by issuing the
    > following:
    >
    > Code:
    > --------------------
    >
    > sensors-detect
    >
    > --------------------
    >
    >
    > and
    >
    > Code:
    > --------------------
    >
    > chkconfig -l lm_sensors
    > lm_sensors 0ff 1ff 2n 3n 4ff 5n 6ff
    >
    > --------------------
    >
    >
    > reveals that the daemon is setup to start in the particular runlevel.
    >
    > however after rebooting the system, the settings are gone and
    > executing
    >
    >
    > Code:
    > --------------------
    >
    > sensors
    >
    > --------------------
    >
    >
    > shows only incorrect values.
    >
    > my investigation has pointed me to the the problem that sensors is
    > useing /etc/sensors3.conf and not /etc/sysconfig/lm_sensors as it should
    > be.
    >
    > any suggestions to that?
    >
    >

    l1zard;

    From man sensors.conf

    The system-wide libsensors(3) configuration file. /etc/sensors3.conf is tried
    first, and if it doesn't exist, /etc/sensors.conf is used instead.
    If you look at the contents of /etc/sensors3.conf you will find a link for
    more board specific files.
    http://www.lm-sensors.org/wiki/Configurations

    I found that I originally needed to edit the contents of sensors3.conf to get
    the correct values, but it looks like there is now a listing for my MB at the
    above site. (This machine started with 11.2 and was upgraded to 11.4.)


    --
    P. V.
    "We're all in this together, I'm pulling for you." Red Green

  6. #6
    Join Date
    Jun 2009
    Location
    Berlin
    Posts
    158

    Default Re: lmsensors: settings gone after reboot

    post didn't help
    anybody who know what this is all about.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •