Results 1 to 7 of 7

Thread: gedit3 не запускается

  1. #1

    Default gedit3 не запускается

    Установил gedit3 в 1-клик с software.opensuse.org/114/ru. После этого gedit перестал запускаться. В терминале пишет:

    Gtk-Message: Failed to load module "canberra-gtk-module"
    Gtk-Message: Failed to load module "gnomesegvhandler"

    GLib-GIO-ERROR **: Settings schema 'org.gnome.desktop.lockdown' is not installed

    aborting...
    Аварийный останов

    У кого нибудь вообще gedit3 запустился?

    У меня Suse 11.4 64bit

  2. #2
    Join Date
    Jun 2008
    Location
    CZE, Praha
    Posts
    694

    Default Re: gedit3 не запускается

    Я подозреваю, что ему нуже Gnome3
    I see only what I wanna see
    I be only who I wanna be
    My blanket covers me

  3. #3

    Thumbs up Re: gedit3 не запускается

    Нашел в зарубежных форумах: оказывается много-чего 3-й версии не запускается и пишет такие-же ошибки. Оказывается для работы нужно установить пакет gsettings-desktop-schemas. А вообще странно что при установке они не "потянулись" автоматом, я же ставил в 1-клик, а не из сырцов. Хотя, если запускать из консоли, то видно, что старые проблемы с модулями остались:
    Gtk-Message: Failed to load module "canberra-gtk-module"
    Gtk-Message: Failed to load module "gnomesegvhandler"

  4. #4
    Join Date
    Aug 2009
    Location
    Russia
    Posts
    2,247

    Default Re: gedit3 не запускается

    Code:
    rpm -qa | grep -i canberra
    libcanberra0-0.26-2.1.i586
    libcanberra-gtk0-0.26-2.1.i586
    libcanberra-gtk-module-common-0.28-1.1.i586
    libcanberra-gtk2-module-0.28-1.1.i586
    libcanberra-gtk3-0-0.28-1.1.i586
    libcanberra-gtk3-module-0.28-1.1.i586
    canberra-gtk-play-0.26-2.1.i586
    если что, все есть в репозитариях.

  5. #5

    Default Re: gedit3 не запускается

    У меня тоже самое:
    rpm -qa | grep -i canberra
    libcanberra0-32bit-0.26-2.1.x86_64
    libcanberra-gtk0-32bit-0.26-2.1.x86_64
    canberra-gtk-play-0.26-2.1.x86_64
    libcanberra-gtk-module-common-0.26-2.1.noarch
    libcanberra0-0.26-2.1.x86_64
    libcanberra-gtk0-0.26-2.1.x86_64
    libcanberra-gtk2-module-0.26-2.1.x86_64
    libcanberra-gtk2-module-32bit-0.26-2.1.x86_64

    а проблемы остались.

    Интересно, можно иметь у себя gedit3 и gedit2.XX одновременно. Пользоваться 2-й версией и "мучить" 3-ю????

  6. #6
    Join Date
    Aug 2009
    Location
    Russia
    Posts
    2,247

    Default Re: gedit3 не запускается

    половины аппликух под gtk3 еще просто нет.

    какую разницу вы видите между gedit.gtk3 и gedit.gtk2, кроме оформления, которое элементарно редактируются?

  7. #7
    Join Date
    Aug 2009
    Location
    Санкт-Петербург
    Posts
    1,037

    Default Re: gedit3 не запускается

    Quote Originally Posted by joneone View Post
    какую разницу вы видите между gedit.gtk3 и gedit.gtk2, кроме оформления, которое элементарно редактируются?
    Там поиск прикольнее сделан, с верху вываливается. и вроде подсветка при поиске по всему тексту, не помню было раньше или нет.
    Вообще конечно не ставя gnome 3 с gedit.gtk3 возится смысла нет.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •