Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Problem with PyQt/Qt in 11.2

  1. #1

    Default Problem with PyQt/Qt in 11.2

    I am trying to use puddletag on openSUSE 11.2 machine and I am informed that the problem I have may be due to the version of pyqt/qt I have being too old. (python-qt4 4.6.1-1.1.1) Please could I have some help to install a later version.
    Many thanks,
    Budgie2

  2. #2
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    2,919

    Default Απ: Problem with PyQt/Qt in 11.2

    Open your terminal and write
    Code:
    qt-creator
    Send the output here.

    Also try to install Cmake
    Code:
    su
    Code:
    # zypper install cmake libqt4-devel
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1070 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  3. #3

    Default Re: Απ: Problem with PyQt/Qt in 11.2

    Hi Stamos,
    Thanks for the reply. Results below:-

    Quote Originally Posted by stamostolias View Post
    Open your terminal and write
    Code:
    qt-creator
    Send the output here.

    No output just the following:-
    If 'qt-creator' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf qt-creator. Just in case there was a typo I tried qt -creator and qt - creator with same result. (Will try as su later)

    Also try to install Cmake
    Code:
    su
    Code:
    # zypper install cmake libqt4-devel
    This downloaded and installed 49 new packages but application still not working as required. What should I try next please?
    Regards,
    Budgie2

  4. #4
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    2,919

    Default Απ: Re: Απ: Problem with PyQt/Qt in 11.2

    Post the output of this
    Code:
    qt-creator
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1070 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  5. #5

    Default Re: Απ: Re: Απ: Problem with PyQt/Qt in 11.2

    Quote Originally Posted by stamostolias View Post
    Post the output of this
    Code:
    qt-creator
    As before, here is the output:-

    If 'qt-creator' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf qt-creator.

    That is all I get.
    Regards,
    Budgie2

  6. #6
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    2,919

    Default Απ: Re: Απ: Re: Απ: Problem with PyQt/Qt in 11.2

    Have you really installed qt-creator?
    Try now to run graphically.
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1070 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  7. #7
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    2,919

    Default Απ: Re: Απ: Re: Απ: Problem with PyQt/Qt in 11.2

    Quote Originally Posted by stamostolias View Post
    Have you really installed qt-creator?
    Try now to run graphically.
    I found something: Maybe qt-creator has stopped to support for openSUSE 11.2. https://build.opensuse.org/package/f...penSUSE%3A11.2

    Sorry but I can not find it.
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1070 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  8. #8
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: Απ: Re: Απ: Re: Απ: Problem with PyQt/Qt in 11.2

    @stamostolias: what's with installing all these spurious packages? This is no way to install a newer version of python-qt4, what were you thinking?

    @budgie2: There is no newer version of python-qt4 for openSUSE 11.2, which is no longer supported (reached end-of-life on May 12 this year). You could upgrade your whole distro to 11.4 and it would auto upgrade python-qt4 to 4.8.3-3.2. (a lot of effort though).
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  9. #9

    Default Re: Απ: Re: Απ: Re: Απ: Problem with PyQt/Qt in 11.2

    Quote Originally Posted by swerdna View Post
    @stamostolias: what's with installing all these spurious packages? This is no way to install a newer version of python-qt4, what were you thinking?

    @budgie2: There is no newer version of python-qt4 for openSUSE 11.2, which is no longer supported (reached end-of-life on May 12 this year). You could upgrade your whole distro to 11.4 and it would auto upgrade python-qt4 to 4.8.3-3.2. (a lot of effort though).
    Hi stamostolios, well yes I do have qt-creator installed according to yast software management but the command is not recognised in console. I have no idea how I could run it graphically.

    Hi Swerdna, thanks for the heads up on end of life but I started my trial of puddletag before 15 May this year. Surely they do not turn everything off on that date! On the other hand my experience with python configobj from packman suggests that work stops as soon as a newer version of openSUSE is extant because the version of configobj on packman dated from 2009.

    As for changing to openSUSE 11.4, a glance through this forum should tell me that things are far from OK just yet. Besides I really cannot work with 11.4 because I cannot get the display on older server to work as there is no easy user access to display parameters and I like to have all machines on same version. I believe it is possible to use 11.2 system display but I do not have time to do the migration at the moment.

    Thanks for the suggestions.
    Regards,
    Budgie2

  10. #10
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,859
    Blog Entries
    15

    Default Re: Απ: Re: Απ: Re: Απ: Problem with PyQt/Qt in 11.2

    Quote Originally Posted by Budgie2 View Post
    Surely they do not turn everything off on that date!
    Hi
    Yes they do..., once removed from the master mirror and transferred to discontinued. Once the mirrors sync any repositories will disappear. On OBS, they will turn off the search and at some point the repositories will disappear as well.

    [security-announce] openSUSE 11.2 has reached end of SUSE support - 11.2
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •