Results 1 to 10 of 10

Thread: Pointer lag

  1. #1
    Join Date
    May 2011
    Location
    The Netherlands
    Posts
    44

    Default Pointer lag

    Hi all,

    I recently switched to OpenSUSE and although it's working great on the whole, there is one thing that's really bugging me: I'm experiencing regular lags in mouse pointer movement. These lags are very brief (I'd say about 0.1 - 0.5 sec) but very annoying nonetheless. I can't really identify a pattern of occurrence in them, but let's say that I experience two of these lags per minute on average if I'm doing something that involves active pointer movement.

    I've been searching around at (this and other) forums as well as bug reports, and did not find anything that matched my problem. All lags I found were much more serious (i.e. system freeze for multiple+ seconds). So in a sense I'm lucky, but still if anyone could offer help to find out what's causing it, that would be very much appreciated

    I'm running a fully updated OpenSUSE 11.4, kernel 2.6.37.6-0.5-desktop with KDE 4.6.0.

    I already tried/ruled out the following:
    • Not related to CPU load
    • No error messages show in /var/log/messages whenever it happens
    • Proprietary Nvidia graphics drivers not (yet) installed
    • Also happens when Desktop Effects are disabled (although it seems as if disabling these reduces the problem) (But I could be imagining things.)


    Anyone have any ideas on where to go from here? Thanks in advance!

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Pointer lag

    Hi all,

    I recently switched to OpenSUSE and although it's working great on the whole, there is one thing that's really bugging me: I'm experiencing regular lags in mouse pointer movement. These lags are very brief (I'd say about 0.1 - 0.5 sec) but very annoying nonetheless. I can't really identify a pattern of occurrence in them, but let's say that I experience two of these lags per minute on average if I'm doing something that involves active pointer movement.

    I've been searching around at (this and other) forums as well as bug reports, and did not find anything that matched my problem. All lags I found were much more serious (i.e. system freeze for multiple+ seconds). So in a sense I'm lucky, but still if anyone could offer help to find out what's causing it, that would be very much appreciated

    I'm running a fully updated OpenSUSE 11.4, kernel 2.6.37.6-0.5-desktop with KDE 4.6.0.

    I already tried/ruled out the following:
    • Not related to CPU load
    • No error messages show in /var/log/messages whenever it happens
    • Proprietary Nvidia graphics drivers not (yet) installed
    • Also happens when Desktop Effects are disabled (although it seems as if disabling these reduces the problem) (But I could be imagining things.)


    Anyone have any ideas on where to go from here? Thanks in advance!
    So it is my opinion this is a hardware issue, brought on by a certain combination of software and one that can be fixed often by switching to 64 bit from 32 (requires a reload) or as simple as installing the proprietary nVIDIA video driver. I would certainly try this approach first. I normally install the video driver the hardware as described here:

    SDB:NVIDIA the hard way - openSUSE

    I even have a bash script file you can use to install the driver the hard way that you can find here:

    LNVHW - Load NVIDIA (driver the) Hard Way from runlevel 3

    I also suggest if that does not work that updating your kernel might be the next thing to try. The most recent kernel (2.6.39-fc7 at this writing) can be installed using the following repository. I am running this very kernel without any problems.

    Index of /repositories/Kernel:/HEAD/openSUSE_11.4

    Next, if you prefer the most recent stable kernel, I found the version located here to be kernel 2.6.38.6 also worth a try:

    Index of /repositories/Kernel:/stable/standard

    Finally, I even have a bash script you can use to load ANY kernel version you want. I would read through message #62 before you took any action loading a new kernel:

    S.A.K.C. - SUSE Automated Kernel Compiler - Version 2.00

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    May 2011
    Location
    The Netherlands
    Posts
    44

    Default Re: Pointer lag

    Quote Originally Posted by jdmcdaniel3 View Post
    So it is my opinion this is a hardware issue, brought on by a certain combination of software and one that can be fixed often by switching to 64 bit from 32 (requires a reload) or as simple as installing the proprietary nVIDIA video driver. I would certainly try this approach first. I normally install the video driver the hardware as described here:

    SDB:NVIDIA the hard way - openSUSE

    I even have a bash script file you can use to install the driver the hard way that you can find here:

    LNVHW - Load NVIDIA (driver the) Hard Way from runlevel 3

    I also suggest if that does not work that updating your kernel might be the next thing to try. The most recent kernel (2.6.39-fc7 at this writing) can be installed using the following repository. I am running this very kernel without any problems.

    Index of /repositories/Kernel:/HEAD/openSUSE_11.4

    Next, if you prefer the most recent stable kernel, I found the version located here to be kernel 2.6.38.6 also worth a try:

    Index of /repositories/Kernel:/stable/standard

    Finally, I even have a bash script you can use to load ANY kernel version you want. I would read through message #62 before you took any action loading a new kernel:

    S.A.K.C. - SUSE Automated Kernel Compiler - Version 2.00

    Thank You,
    I'm already using 64-bit and am going to try installing the Nvidia drivers soon. The instructions seem to be for 11.3 - do they also apply to 11.4? I'll keep you posted in this thread - for now: thanks!

    Edit: by the way, can I also just add the repository containing the nVidia driver and simply let software manager do all the work?
    URL: ftp://download.nvidia.com/opensuse/11.4/
    Linked from: http://opensuse-community.org/openSU...Additional.xml

  4. #4
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Default Re: Pointer lag

    I'm already using 64-bit and am going to try installing the Nvidia drivers soon. The instructions seem to be for 11.3 - do they also apply to 11.4? I'll keep you posted in this thread - for now: thanks!
    The installation of the driver is basically the same. I normally suggest you restart your computer and when in the Grub Menu.lst file, enter the number 3 as a kernel load option and then press the enter key on the openSUSE kernel version you are using. Your kernel will load, but not the desktop. After you log in as root, run the lnvhw script I posted above, select the nVIDIA driver version you wish to load (from the versions you have already downloaded) and after it loads, just restart and you are in business.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  5. #5
    Join Date
    May 2011
    Location
    The Netherlands
    Posts
    44

    Default Re: Pointer lag

    Installing the Nvidia drivers has fixed the problem - thanks for your help, jdmcdaniel3!

    I do however notice an icon appearing in the system tray every few minutes saying something about 'Getting information distribution upgrades'. It disappears really fast again, so I'm not sure what it is. Can't find any information about it either. I'm not sure whether it is related to installing the Nvidia drivers, but I've been noticing it ever since. Do you have any ideas as to what this might be, perhaps?

  6. #6
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Pointer lag

    Happy to hear the nVIDIA driver has fixed your problem. As for the icon tray, there is an Package Update utility, not part of nVIDIA that does come and go there. To update everything I normally just start YaST / Software / Software Management Select Package in the top Left, Then All Packages and finally Update if newer version Available. If there are any package conflicts, here is my generic blurb on that:

    To avoid package problems, the most important thing to do is to: **NEVER**
    ignore a dependency, even if YaST/zypper/updater gives you such an option!
    In general, never switch to an >inferior< architecture and the solution is
    most often to just switch Vendor to the >Packman< repository. So changing
    the vendor is OK, but >ignoring< dependencies is never a very good idea!
    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  7. #7
    Join Date
    May 2011
    Location
    The Netherlands
    Posts
    44

    Default Re: Pointer lag

    Thanks!

  8. #8
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,546

    Default Re: Pointer lag

    I am experiencing this same problem with mouse pointer lag.
    I am using Opensuse 11.4 64bit clean install.
    I initially installed 32 bit and had the same problem and changed to 64bit to see if fixed the problem.

    At first I installed the live CD and everything worked great.
    I then changed to the full DVD install.

    The problem seems random but sometimes can go on for a very long time.
    Have a lenovo laptop sl510 with intel GM45 onboard video

  9. #9
    Join Date
    May 2011
    Location
    The Netherlands
    Posts
    44

    Default Re: Pointer lag

    Does the problem persist when you disable Desktop Effects?

    If so, for me installing the proprietary graphics drivers (I have an Nvidia card) solved the problem. I'm not sure which driver is available for your card, so maybe someone else could help with this as I'm not an expert. (Although I'm getting more advanced every day, I'm probably still closer to a noob than to an expert, lol).

  10. #10
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,546

    Default Re: Pointer lag

    always have effects disabled as I'm not a big fan.
    Driver for intel gm45 comes compiled with the kernel.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •