Results 1 to 9 of 9

Thread: Zypper UP problem!!

  1. #1

    Unhappy Zypper UP problem!!

    After upgrade opensuse 11.3 to 11.4, i have this situation

    zypper up
    Loading repository data...
    Reading installed packages...

    The following package updates will NOT be installed:
    MozillaFirefox MozillaFirefox-branding-openSUSE NetworkManager-kde4-libs NetworkManager-openvpn-kde4 NetworkManager-pptp-kde4 NetworkManager-vpnc-kde4 aaa_base aaa_base-extras amarok ant
    ant-junit appframework asm2 automake bea-stax bea-stax-api beansbinding bluedevil bytelist choqok cobertura coreutils cryptsetup digikam digikam-lang dom4j excalibur
    excalibur-avalon-framework-api excalibur-avalon-framework-impl excalibur-avalon-logkit freemarker geronimo-el-1_0-api geronimo-j2ee-1_4-apis geronimo-jsp-2_0-api geronimo-servlet-2_4-api
    geronimo-specs-poms geronimo-stax-1_0-api git git-core git-cvs git-daemon git-email git-gui git-svn git-web gitk gstreamer-0_10 gstreamer-0_10-lang gstreamer-0_10-plugin-hal
    gstreamer-0_10-plugins-good gstreamer-0_10-plugins-good-lang gstreamer-0_10-plugins-ugly hamcrest isorelax jakarta-commons-beanutils jakarta-commons-collections jakarta-commons-digester
    jakarta-commons-fileupload jakarta-commons-logging jakarta-commons-net jakarta-commons-validator javahelp2 jaxen jcodings jdom jemmy jline jna joda-time joe jpackage-utils jsch junit junit4
    jvyamlb jython jzlib k3b k3b-lang kaffeine kernel-default kernel-desktop kernel-pae kernel-xen kipi-plugins kipi-plugins-acquireimage ksshaskpass ktorrent ktorrent-lang libbluedevil1
    libcryptsetup1 libgstreamer-0_10-0 libktorrent3 libktorrent3-lang libldb0 libopencv2_2 libsidplay1 libsmbclient0 libtag-extras1 libtalloc-devel libtalloc2 libtdb1 libtevent0 libvpx0
    libwavpack1 libwbclient0 libxine1 libxine1-gnome-vfs libxine1-pulse libxmmsclient-glib1 libxmmsclient6 libyajl1 libzypp linphone log4j lucene mjpegtools mozilla-js192 mozilla-js20
    mozilla-kde4-integration mozilla-xulrunner192 mozilla-xulrunner192-gnome mozilla-xulrunner20 mozilla-xulrunner20-gnome ndiswrapper ndiswrapper-kmp-default ndiswrapper-kmp-desktop
    ndiswrapper-kmp-pae net-tools netbeans netbeans-apisupport netbeans-ide netbeans-java netbeans-javaparser netbeans-platform netbeans-platform-harness netbeans-resolver
    netbeans-svnclientadapter nfsidmap objectweb-asm openssh openssh-askpass oro oxygen-gtk pico python-numpy python-satsolver python-xmms2 qdox relaxngDatatype rhino rpm samba samba-client
    satsolver-tools saxpath screen servletapi5 shared-desktop-ontologies skanlite struts swing-layout swingx taglib tar tar-lang timidity w3m ws-jaxme xalan-j2 xerces-j2 xerces-j2-xml-apis
    xerces-j2-xml-resolver xine-ui xmlbeans xmms2 xmms2-plugin-base xpp2 xpp3 xterm zypper

    zypper ref
    Repository 'http://download.opensuse.org/repositories/Emulators:/Wine/openSUSE_11.4/' is up to date.
    Repository 'http://download.opensuse.org/repositories/Java:/packages/openSUSE_11.4/' is up to date.
    Repository 'http://download.opensuse.org/repositories/KDE:/UpdatedApps/openSUSE_11.4/' is up to date.
    Repository 'http://download.opensuse.org/repositories/OpenOffice.org:/STABLE/openSUSE_11.4/' is up to date.
    Repository 'http://download.opensuse.org/repositories/mozilla/openSUSE_11.4/' is up to date.
    Repository 'http://download.opensuse.org/repositories/mozilla/openSUSE_11.4/' is up to date.
    Repository 'http://download.opensuse.org/repositories/mozilla/openSUSE_11.4/' is up to date.
    Repository 'http://download.opensuse.org/source/distribution/11.4/repo/non-oss/' is up to date.
    Repository 'http://download.opensuse.org/source/distribution/11.4/repo/oss/' is up to date.
    Repository 'http://download.videolan.org/pub/vlc/SuSE/11.4' is up to date.
    Repository 'http://jftp.medozas.de/openSUSE_11.4/' is up to date.
    Repository 'packman' is up to date.
    Repository 'packman-essentials' is up to date.
    Repository 'packman-multimedia' is up to date.
    Repository 'openSUSE-11.4 Non-OSS' is up to date.
    Repository 'openSUSE-11.4 OSS' is up to date.
    Repository 'openSUSE-11.4 Updates' is up to date.
    All repositories have been refreshed.

    How to fix that "The following package updates will NOT be installed"??????

  2. #2
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    1,711

    Default Απ: Zypper UP problem!!

    Could you try with Yast to refresh your repos?? Send the results here.
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15.3||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1080 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  3. #3

    Default Re: Απ: Zypper UP problem!!

    I refresh repos in Yast, but I cant see results there (in yast). In console results is same.

  4. #4
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    1,711

    Default Απ: Re: Απ: Zypper UP problem!!

    Quote Originally Posted by djole17 View Post
    I refresh repos in Yast, but I cant see results there (in yast). In console results is same.
    Maybe these programs have already installed to your pc. Try also Kapplet. Go to start menu-->system settings-->software manager-->software update. Try through here.
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15.3||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1080 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  5. #5

    Default Re: Απ: Re: Απ: Zypper UP problem!!

    If I do that, I get this error

    Download (curl) error for 'http://download.opensuse.org/repositories/Java:/packages/openSUSE_11.4/repodata/repomd.xml':
    Error code: Connection failed
    Error message: Couldn't resolve proxy 'HTTP_PROXY'
    Interent work fine, and if I delete this repos, then give me mistake for another repos.......

  6. #6
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: Απ: Re: Απ: Zypper UP problem!!

    Could you please post the output of

    Code:
    zypper lr -d
    ...for the output of 'zypper ref' suggests that you have several repos installed multiple times. Beside that I see some mismanagement referring the sources you use: using the Videolan-Repo with Packman is a classic - just do not use Videolan if you prefer stable multimedia-support, as their packages are not compatible to those of Packman. You also seem to have activated both the main Packman-repo *and* some of its sub-repositories, that is not needed as well.

  7. #7

    Default Re: Απ: Re: Απ: Zypper UP problem!!

    zypper lr -d



    zypper lr -d
    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    ---+---------------------------------------------------------------------------------+---------------------------------------------------------------------------------+---------+---------+----------+--------+---------------------------------------------------------------------------------+--------
    1 | google-talkplugin | google-talkplugin | No | Yes | 99 | rpm-md | http://dl.google.com/linux/talkplugin/rpm/stable/i386 |
    2 | Index of /repositories/Java:/packages/openSUSE_11.4 | Index of /repositories/Java:/packages/openSUSE_11.4 | Yes | Yes | 99 | rpm-md | Index of /repositories/Java:/packages/openSUSE_11.4 |
    3 | Index of /repositories/KDE:/UpdatedApps/openSUSE_11.4 | Index of /repositories/KDE:/UpdatedApps/openSUSE_11.4 | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/UpdatedApps/openSUSE_11.4 |
    4 | Index of /repositories/OpenOffice.org:/STABLE/openSUSE_11.4 | Index of /repositories/OpenOffice.org:/STABLE/openSUSE_11.4 | Yes | Yes | 99 | rpm-md | Index of /repositories/OpenOffice.org:/STABLE/openSUSE_11.4 |
    5 | http://download.opensuse.org/reposit...enSUSE_11.4/_2 | Index of /repositories/mozilla/openSUSE_11.4 | Yes | Yes | 99 | rpm-md | Index of /repositories/mozilla/openSUSE_11.4 |
    6 | Index of /distribution/11.3/repo/oss/suse | Index of /distribution/11.3/repo/oss/suse | No | Yes | 99 | rpm-md | Index of /distribution/11.3/repo/oss/suse |
    7 | Index of /source/distribution/11.4/repo/non-oss | Index of /source/distribution/11.4/repo/non-oss | Yes | Yes | 99 | yast2 | Index of /source/distribution/11.4/repo/non-oss |
    8 | Index of /source/distribution/11.4/repo/oss | Index of /source/distribution/11.4/repo/oss | Yes | Yes | 99 | yast2 | Index of /source/distribution/11.4/repo/oss |
    9 | Index of /pub/vlc/SuSE/11.4/ | Index of /pub/vlc/SuSE/11.4/ | Yes | Yes | 99 | rpm-md | Index of /pub/vlc/SuSE/11.4/ |
    10 | Index of /openSUSE_11.4 | Index of /openSUSE_11.4 | Yes | Yes | 99 | rpm-md | Index of /openSUSE_11.4 |
    11 | packman | packman | Yes | Yes | 99 | rpm-md | Index of /suse/openSUSE_11.4/ |
    12 | packman-essentials | packman-essentials | Yes | Yes | 99 | rpm-md | Index of /suse/openSUSE_11.4/Essentials/ |
    13 | packman-multimedia | packman-multimedia | Yes | Yes | 99 | rpm-md | Index of /suse/openSUSE_11.4/Multimedia/ |
    14 | repo-11.4-non-oss | openSUSE-11.4 Non-OSS | Yes | No | 99 | yast2 | Index of /distribution/11.4/repo/non-oss |
    15 | repo-11.4-oss | openSUSE-11.4 OSS | Yes | No | 99 | yast2 | Index of /distribution/11.4/repo/oss |
    16 | repo-11.4-update | openSUSE-11.4 Updates | Yes | Yes | 99 | rpm-md | Index of /update/11.4

  8. #8
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: Απ: Re: Απ: Zypper UP problem!!

    Next time, please post it in code-tags, kay?

    So what have we here?

    1. All priorities are the same (99). You should adjust that. For example I use 99 for the update repo (which is part of the basic repos together with oss and non-oss, so it offers many packages other sources offer as well), but give other repositories a higher prio (less than 99, the lower the value, the higher the prio)

    2. oss and non-oss are double entries

    3. Videolan is not compatible with Packman

    4. You use both the main Packman repo and two of its subrepos. If you want to use the entire Packman, just use the main repo.

    5. I am a bit sceptical about using the 'sources'- and the 'jengelh'-repo. Do you actually need them?

    Oh, by the way: the output ("The following package updates will NOT be installed") is quite normal when using 'zypper up'. Compare it to 'zypper dup' (and read 'man zypper' about it), I suppose then you'll understand.

  9. #9

    Default Re: Απ: Re: Απ: Zypper UP problem!!

    thanks, very mach for help

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •