Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: I cant install .rpm aplications.

  1. #1

    Arrow I cant install .rpm aplications.

    hallo i cant install skype exactly... this is the error


    Code:
    failed to install file: Empty destination in URI: hd:///?device=/dev/disk/by-id/usb-Kingston_DataTraveler_2.0_001372995DDDA9A0761C0019-0:0-part1
    I installed opensuse from a usb disck. how i can fix it?

    opensuse 11.4 and i tried to install the last version of skype

  2. #2
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    2,919

    Default Απ: I cant install .rpm aplications.

    Have you saved the *.rpm in a USB stick??

    Try to install skype from his webpage.
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1070 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  3. #3
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    2,919

    Default Απ: I cant install .rpm aplications.

    Also you can use your terminal to install applications and repos.
    Code:
    su
    To install programs
    Code:
    # zypper install <program>
    To install repositories
    Code:
    # zypper addrepo -f <URL of Repo>
    Code:
    # zypper refresh
    To remove programs
    Code:
    # zypper remove <program>
    To remove repos
    Code:
    # zypper removerepo <Repository>
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1070 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,127

    Default Re: I cant install .rpm aplications.

    Quote Originally Posted by vmkurz View Post
    hallo i cant install skype exactly... this is the error


    Code:
    failed to install file: Empty destination in URI: hd:///?device=/dev/disk/by-id/usb-Kingston_DataTraveler_2.0_001372995DDDA9A0761C0019-0:0-part1
    I installed opensuse from a usb disck. how i can fix it?

    opensuse 11.4 and i tried to install the last version of skype
    You showed what error you get, but you did not show what command you gave. How can we guess what you are doing while trying to install Skype?
    Henk van Velden

  5. #5
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    2,919

    Default Απ: Re: I cant install .rpm aplications.

    Quote Originally Posted by hcvv View Post
    You showed what error you get, but you did not show what command you gave. How can we guess what you are doing while trying to install Skype?
    As I thing maybe he download the skype for a pc then he saved this *.rpm to his USB stick. But then I loose him. Maybe the partition is corrupted.
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1070 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,127

    Default Re: Απ: Re: I cant install .rpm aplications.

    Quote Originally Posted by stamostolias View Post
    As I thing maybe he download the skype for a pc then he saved this *.rpm to his USB stick. But then I loose him. Maybe the partition is corrupted.
    It is not very interesting what you think/guess or what I think/guess. He needs to tell what he does in a way no guessing is possible.
    One can not give usefull answers to questions that are not well defined.
    Henk van Velden

  7. #7

    Default Re: Απ: Re: I cant install .rpm aplications.

    hi,, hi,,, sorry . ok. i did this exactly ..

    I installed My opensuse 11.04 from a usb .. not from a DVD..
    i tried to install skype ..
    download skype.rpm from skype.com ,have arround 21MB..
    right click and install but... ERROR.
    When i install a api for example.

    sudo zypper install libpng12-0 this is the error

    Empty destination in URI: hd:///?device=/dev/disk/by-id/usb-Kingston_DataTraveler_2.0_001372995DDDA9A0761C0019-0:0-part1

    Then 3 options ignore,cancel and try again.. if i select ignore the error appears again but the api work... that means. i can install it but why this error appears? and when i try to use a rpm i cant install it. just the error and nothing work.

    Empty destination in URI: hd:///?device=/dev/disk/by-id/usb-Kingston_DataTraveler_2.0_001372995DDDA9A0761C0019-0:0-part1

    i will try to install from the web directly. thanks guys.

  8. #8
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,127

    Default Re: Απ: Re: I cant install .rpm aplications.

    You are mixing things. For "normal" installation you use YaST > Software manager or zypper. In both cases you should have the appropriate repositories. There seem to be something wrong with your repos. Please post the output of
    Code:
    zypper lr -d
    And plaese do not post computer output bold (as you did above) but between CODE tags: Posting in Code Tags - A Guide.

    Installing Skype is a bit different. Please read this SDB:Skype - openSUSE and see if it helps you.
    Henk van Velden

  9. #9
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: I cant install .rpm aplications.

    Run yast -> software -> software repositories
    and disable in the list this usb repository, you should easily recognise it
    because it has the hd:///?device=/dev/disk/by-id/usb-
    Kingston_DataTraveler_2.0_001372995DDDA9A0761C0019-0:0-part1

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  10. #10

    Default Re: Απ: Re: I cant install .rpm aplications.

    ok thanks and sorry for the bold..
    ok this is the output of that comand
    Code:
    # | Alias                                     | Nombre                                                    | Activado | Actualizar | Prioridad | Tipo   | URI                                                                                            | Servicio
    --+-------------------------------------------+-----------------------------------------------------------+----------+------------+-----------+--------+------------------------------------------------------------------------------------------------+---------
    1 | Actualizaciones-para-openSUSE-11.4-11.4-0 | Actualizaciones para openSUSE 11.4 11.4-0                 | Si       | Si         |   99      | rpm-md | http://download.opensuse.org/update/11.4/                                                      |         
    2 | download.nvidia.com-opensuse              | nVidia Graphics Drivers                                   | Si       | Si         |   99      | rpm-md | ftp://download.nvidia.com/opensuse/11.4/                                                       |         
    3 | download.opensuse.org-webcam              | BuildService de openSUSE - Controladores para cámaras web | Si       | Si         |   99      | rpm-md | http://download.opensuse.org/repositories/drivers:/webcam/openSUSE_11.4/                       |         
    4 | openSUSE-11.4-11.4-0                      | openSUSE-11.4-11.4-0                                      | Si       | Si         |   99      | yast2  | hd:///?device=/dev/disk/by-id/usb-Kingston_DataTraveler_2.0_001372995DDDA9A0761C0019-0:0-part1 |         
    5 | repo-debug                                | openSUSE-11.4-Debug                                       | No       | Si         |   99      | NONE   | http://download.opensuse.org/debug/distribution/11.4/repo/oss/                                 |         
    6 | repo-debug-update                         | openSUSE-11.4-Update-Debug                                | No       | Si         |   99      | NONE   | http://download.opensuse.org/debug/update/11.4/                                                |         
    7 | repo-non-oss                              | openSUSE-11.4-Non-Oss                                     | Si       | Si         |   99      | yast2  | http://download.opensuse.org/distribution/11.4/repo/non-oss/                                   |         
    8 | repo-oss                                  | openSUSE-11.4-Oss                                         | Si       | Si         |   99      | yast2  | http://download.opensuse.org/distribution/11.4/repo/oss/                                       |         
    9 | repo-source                               | openSUSE-11.4-Source                                      | No       | Si         |   99      | NONE   | http://download.opensuse.org/source/distribution/11.4/repo/oss/
    i had problems with nVidia Graphics Drivers fixed lol


    i think the error is this

    Code:
    4 | openSUSE-11.4-11.4-0                      | openSUSE-11.4-11.4-0                                      | Si       | Si         |   99      | yast2  | hd:///?device=/dev/disk/by-id/usb-Kingston_DataTraveler_2.0_001372995DDDA9A0761C0019-0:0-part1 |
    i did this first
    Installing Skype is a bit different. Please read this SDB:Skype - openSUSE and see if it helps you.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •