Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: No Connection with Pantech UML290 for Verizon

  1. #1

    Default No Connection with Pantech UML290 for Verizon

    Hey Everybody,

    Ok, so this must be the most frustrating thing I have tried yet...

    I have tried every post on this site and Verizon's dealing with the UML290 Mobile Broadband USB Modem to get it configured with linux and have yet to have any luck in over a week of trying to get it to connect.

    I am currently running OpenSuSE 11.4, all software has most recent available updates,
    > uname -a
    Code:
     2.6.37.6-0.5-desktop #1 SMP PREEMPT 2011-04-25 21:48:33 +0200 i686 i686 i386 GNU/Linux
    I have tried setting up the UML290 using NetworkManager (Broadband Connection), also tried YaST > modems along with Qinternet to connect with no luck. Have tried using mynumber@vzw3g.com and also mynumber@vzw4g.com and neither have worked. Used #777 as "Number" and used "vzw" and "VZW" as passwords, still nothing.

    Outputs:
    NetworkManager - tail -f /var/log/NetworkManager
    Code:
    May 18 13:27:16 mmartin NetworkManager[7360]: <info> Activation (ttyACM0) Stage 1 of 5 (Device Prepare) scheduled...
    May 18 13:27:16 mmartin NetworkManager[7360]: <info> Activation (ttyACM0) Stage 1 of 5 (Device Prepare) started...
    May 18 13:27:16 mmartin NetworkManager[7360]: <info> (ttyACM0): device state change: 6 -> 4 (reason 0)
    May 18 13:27:16 mmartin NetworkManager[7360]: <info> Activation (ttyACM0) Stage 1 of 5 (Device Prepare) complete.
    May 18 13:27:16 mmartin NetworkManager[7360]: <warn> GSM connection failed: (32) No cause information available
    May 18 13:27:16 mmartin NetworkManager[7360]: <info> (ttyACM0): device state change: 4 -> 9 (reason 1)
    May 18 13:27:16 mmartin NetworkManager[7360]: <info> Marking connection 'Verizon 3G' invalid.
    May 18 13:27:16 mmartin NetworkManager[7360]: <warn> Activation (ttyACM0) failed.
    May 18 13:27:16 mmartin NetworkManager[7360]: <info> (ttyACM0): device state change: 9 -> 3 (reason 0)
    May 18 13:27:16 mmartin NetworkManager[7360]: <info> (ttyACM0): deactivating device (reason: 0).
    Log from Qinternet:
    Code:
    SuSE Meta pppd (smpppd-ifcfg), Version 1.60.46 on mmartin.local.
    Status is: disconnected
    trying to connect to smpppd
    connect to smpppd
    Status is: disconnected
    Status is: connecting
    pppd[0]: Plugin passwordfd.so loaded.
    pppd[0]: --> WvDial: Internet dialer version 1.60
    pppd[0]: --> Initializing modem.
    pppd[0]: --> Sending: ATZ
    pppd[0]: ATZ
    pppd[0]: OK
    pppd[0]: --> Sending: AT Q0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    pppd[0]: OK
    pppd[0]: --> Sending: ATM0
    pppd[0]: ATM0
    pppd[0]: OK
    pppd[0]: --> Sending: ATX3
    pppd[0]: ATX3
    pppd[0]: OK
    pppd[0]: --> Modem initialized.
    pppd[0]: --> Sending: ATDT#777
    pppd[0]: --> Waiting for carrier.
    pppd[0]: ATDT#777
    pppd[0]: NO CARRIER
    pppd[0]: --> No Carrier!  Trying again.
    pppd[0]: --> Sending: ATDT#777
    pppd[0]: --> Waiting for carrier.
    pppd[0]: ATDT#777
    pppd[0]: NO CARRIER
    pppd[0]: --> No Carrier!  Trying again.
    If anyone was able to get this working in OpenSuSE, please help....


    ***Had it working with Windows 7 VZAccess Manager, so I know it is a "working" device.***

    Thanks,
    Matt

  2. #2

    Default Re: No Connection with Pantech UML290 for Verizon

    so I looked at a few threads from Ubuntu; as there are many more posts there; I google-searched on

    Ubuntu Pantech UML290 Verizon
    I was really curious to read this post

    www.pagey.info: Using Pantech UML290 on Ubuntu Linux (10.10)

    as it sounded more like a GSM setup;

    it was explained more here;

    Urgent, need help with Ubuntu 10.10, 4G LTE and Pantech UML 290 - Verizon Wireless Community

    where one post said

    Again the "vzwinternet" APN SIM is GSM technology which is 4G ONLY so therefore it WILL ONLY WORK in a 4G coverage area. To connect using 3G use the traditional CDMA HA method which is yourphonenumber@vzw3g.com and password vzw using CDMA authentication and it should work. Make sure it's activated using Windows first.
    so I guess if we ask you if you think are in a 4G or a 3G area........

    I have done a screenshot of the verizon using the #777 number and I need advice on how to post it: suse don't allow it to come in as an attachment;

    I suspect you need the vzwinternet as an APN setting;

    as a fall-back, this post from pagey

    www.pagey.info: Using Pantech UML290 on Ubuntu Linux 11.04 (Natty Narwhal)

    talks about using wvdial;

    the guy who wrote wvdial can't believe folks still use it...........but it often works well......

  3. #3

    Default Re: No Connection with Pantech UML290 for Verizon

    Matt,
    I also answered your question in the other post, but here it is in this as well.

    I documented the steps it took to get it working. It is important to know whether you are in a 4g or 3g area. Also, if you are traveling and expect to switch between 3g or 4g there are a couple of extra steps. The instructions are here. Let me know if you need any additional help with them.

    idee


    Verizon is supposed to be working on a Linux version of the Access Manager, but it's not out yet. When (if) I see, it I will post it.

  4. #4

    Default Re: No Connection with Pantech UML290 for Verizon

    Hey pdc,

    Thanks for the reply.
    I have tried the link starting with "Urgent" before, along with tons of other forum's instructions on how to do this. I have not yet tried those other two though and will check them out sometime today. I have also tried using the myNumber@vzw3g.com and myNumber@vzw4g.com many many times while trying to get this working along with #777 as number and vzwinternet as APN.

    But I will check out those other two links as soon as I can, and will let you know what happens.

    Thanks again,
    Matt

  5. #5

    Default Re: No Connection with Pantech UML290 for Verizon

    Hey idee,

    Thanks again!! Sorry about double posting the same thing but after I posted in the other thread I thought I would be better off just starting a new one.

    I am pretty positive I am in a 3G area right now but who knows??? I will give it a shot as soon as I get this darn VM working on my machine...

    I remember seeing somewhere, and I actually found a pdf with instructions, on installing VZWAccess Manager on Linux using an RPM package. But could not find the rpm anywhere on the Internet... Then (from what I recall) I remember seeing something about Verizon had released a linux version but it is only for "Corporate" accounts, or something along those lines.

    Thanks again, and I'll get back to you as soon as I can,
    Matt

  6. #6

    Default Re: No Connection with Pantech UML290 for Verizon

    Hi Matt,
    You lost me with the "Urgent" links, but the most important part of this whole process is reconfiguring the modem with the UML290 configuration tool. See the article here, and then use the download link on that page to get the app. The instructions I posted included those steps and how to use it. Talking to Verizon (level 3 tech), they basically screwed up. There is not a software switch to change from 3g to 4g as of yet. The modem has to be configured (with that tool) to work in 3g areas. I live in a 3g area as well.

    I am using Qinternet for the connection. For me it works best. Also the #777 or *99# will work. Since I posted those instructions I have switched to the *99#. Just test around and use the one that fits you best. If you read that entire post you may pick up on some other issues you might want to be aware of. One major issue was an update problem. Have you verified the modem works lately on a windoze machine? There was a patch (which they pulled quickly) that toasted my modem. That was when I talked with the level 3 tech. The only fix was to return it to my local Verizon store and get a new one. Then I did all the steps documented in the other post and have been running ever since.

    There is a linux Verizon Access Manager out there, but not one that will support this modem. Not yet. I check the site periodically to see when it comes out. I checked last night, but still just the old one from mid 2010.

    hope this helps,
    idee

  7. #7

    Default Re: No Connection with Pantech UML290 for Verizon

    Hey idee,

    I'm about to give your instructions a shot (wish me luck!). To answer your question, yes it does work on my Windows 7 partition so I know the modem does work.
    The post I mentioned starting with "Urgent" was from pdc_2 a couple of replies up from yours.

    Thanks, I'll get back to you as soon as I finish.


    Thanks again,
    Matt

  8. #8

    Default Re: No Connection with Pantech UML290 for Verizon

    Hey idee,

    In your instructions, after I enter the provider info, click Ok > Next, does it matter what i put for username as in myNumber@vzw4g, if I'm in 3G area should I use @vzw3g.com???

    Also, when I was trying this before the last couple of days the light on the device would flash red then after a minute it would begin to flash blue. But now it is staying flashing red, does that mean anything?

    Thanks,
    Matt

  9. #9

    Default Re: No Connection with Pantech UML290 for Verizon

    Hey idee,

    SUCCESS!!!!!!

    Code:
    Status is: connecting
    pppd[0]: Plugin passwordfd.so loaded.
    pppd[0]: speed 480000000 not supported
    pppd[0]: --> WvDial: Internet dialer version 1.60
    pppd[0]: --> Initializing modem.
    pppd[0]: --> Sending: ATZ
    pppd[0]: OK
    pppd[0]: --> Sending: AT Q0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    pppd[0]: OK
    pppd[0]: --> Sending: ATM0
    pppd[0]: ATM0
    pppd[0]: OK
    pppd[0]: --> Sending: ATX3
    pppd[0]: ATX3
    pppd[0]: OK
    pppd[0]: --> Modem initialized.
    pppd[0]: --> Sending: ATDT#777
    pppd[0]: --> Waiting for carrier.
    pppd[0]: ATDT#777
    pppd[0]: CONNECT 3100000
    pppd[0]: --> Carrier detected.  Waiting for prompt.
    pppd[0]: --> Don't know what to do!  Starting pppd and hoping for the best.
    pppd[0]: Script /usr/bin/wvdial --chat --no-syslog --config /var/run/smpppd/chat-modem0.conf smpppd finished (pid 28185), status = 0x0
    pppd[0]: Serial connection established.
    pppd[0]: speed 480000000 not supported
    pppd[0]: Renamed interface ppp0 to modem0
    pppd[0]: Using interface modem0
    Status is: connecting
    pppd[0]: Connect: modem0 <--> /dev/ttyACM0
    pppd[0]: replacing old default route to eth0 [192.168.5.1]
    pppd[0]: local  IP address 75.206.237.198
    pppd[0]: remote IP address 66.174.112.64
    pppd[0]: primary   DNS address 66.174.95.44
    pppd[0]: secondary DNS address 66.174.92.14
    pppd[0]: Script /etc/ppp/ip-up finished (pid 28200), status = 0x0
    Status is: connected
    Don't worry about answering my previous question about the @vzw4g or @vzw3g (yes it does matter) as you know...
    So I did get it working, thanks you so much. As it turns out I am in a 4G area and the @vzw4g did make it work.

    Would it be ok and would it work, if I create a 2nd modem with all the same settings as the first and then just change the 4G stuff to 3G so I wouldn't have to go into the settings and "edit" the modem manually for which ever coverage area I am in??


    Again thanks for your help!! Great Job!



    Thanks,
    Matt

  10. #10

    Default Re: No Connection with Pantech UML290 for Verizon

    Matt,
    Great thought about two software configured modems in linux, but the problem is that the configuration is really changing the firmware on the device. That's the part that stinks. There is no current software configuration answer. As you found the @vzw4g is required, because it is a 4g device. Even though I am in a 3g location, I still must use the @vzw4g to connect.

    A couple of thoughts. If you are truly in an active 4g area, the modem should have worked with no changes. You may have slowed down the device to 3g and not needed to. A quick test would be to (leave all of your linux settings alone) re configure the device again, back to 4g. You may get a faster connection than you have today. If it doesn't work or is slower, just change it back.

    That configuration software should be set as follows:
    Code:
    The default 4g settings are:
    pref_mode - Automatic & HDR Service Configuration - eHRPD
    
    Change the settings to access 3g to:
    pref_mode - CDMA/HDR Only & HDR Service Configuration - Rev A
    Be aware that this software requires a save, even if you don't change anything. Otherwise it clears the settings. It's not dangerous or diffucult, just go slow and it works.

    idee

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •