Results 1 to 5 of 5

Thread: VNC server setup for 11.4

  1. #1
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    982

    Default VNC server setup for 11.4

    I am trying to bring up VNC, with mixed success.

    My server is a SuSE 11.4 with tightvnc and xorg-x11-Xvnc rpms installed
    The server is 11.4/KDE4.6.3/2.6.37.6-0.5-desktop

    For simplicity, lets say my client is a WinXP machine with Tightvnc installed.
    (I do have similar issues using another SuSE11.4 as client)

    I have been generally following Swerdna's Tutorial at TightVNC (VNC Xvnc) on openSUSE as Client or Server (Remote Desktop Connections)

    I can start a session from the server with
    Code:
    dbus-launch vncserver :6
    and connect to it form the WinXP machine using the tightvnc viewer or the java applet via Firefox. I chose :6 to keep it away from :1, :2, :3 which I knew were set up in xinit.d.

    I would prefer to have the server serve up a login greeter, so have edited the startup script in /etc/xinit.d/vnc (loaded on the system with the tightvnc RPM, I believe).
    It is as follows
    Code:
    # default: off I EDITED OUT THE OFF 
    # description: This serves out a VNC connection which starts at a KDM login
    #    prompt. This VNC connection has a resolution of 1600x1200, 16bit depth.
    service vnc3
    {
        type        = UNLISTED
        port        = 5903
        socket_type    = stream
        protocol    = tcp
        wait        = no
        user        = nobody
        server        = /usr/bin/Xvnc
        server_args    = -noreset -inetd -once -query localhost -geometry 1600x1200 -depth 16
    #    disable        = yes
    }
    # default: off I EDITED OUT THE OFF
    # description: This serves out the vncviewer Java applet for the VNC \
    #    server running on port 5902, (vnc port 3).
    service vnchttpd3
    {
        type        = UNLISTED
        port        = 5803
        socket_type    = stream
        protocol    = tcp
        wait        = no
        user        = nobody
        server        = /usr/bin/vnc_inetd_httpd
        server_args    = 1600 1200 5903
     #   disable        = yes
    }
    I then restarted xinit.d and the vnc3 service shows as running.

    From the WinXP client, I open the tightvnc viewer for :3 and I get the login greeter as expected. Entering my login name and password, the viewer closes. If I try same via the java applet web interface, it also closes with a message that the connection was reset by the server.

    Swerdna's tutorial on the topic does not speak to using the xinit.d startup method

    Any suggestions? Thanks

  2. #2
    Join Date
    Sep 2008
    Location
    St. Louis
    Posts
    91

    Default Re: VNC server setup for 11.4

    Do you really want to use dbus? Although I can't say I'm familiar with it (very noobish in some areas), but I haven't had a problem just running vncserver, then again that was on SuSE box...

  3. #3
    Will Honea NNTP User

    Default Re: VNC server setup for 11.4

    cmcgrath5035 wrote:

    >
    > I am trying to bring up VNC, with mixed success.
    >
    > My server is a SuSE 11.4 with tightvnc and xorg-x11-Xvnc rpms installed
    > The server is 11.4/KDE4.6.3/2.6.37.6-0.5-desktop
    >
    > For simplicity, lets say my client is a WinXP machine with Tightvnc
    > installed.
    > (I do have similar issues using another SuSE11.4 as client)
    >
    > I have been generally following Swerdna's Tutorial at 'TightVNC (VNC
    > Xvnc) on openSUSE as Client or Server (Remote Desktop Connections)'
    > (http://opensuse.swerdna.org/susetightvnc.html#xwindow.)
    >
    > I can start a session from the server with
    > Code:
    > --------------------
    > dbus-launch vncserver :6
    > --------------------
    > and connect to it form the WinXP machine using the tightvnc viewer or
    > the java applet via Firefox. I chose :6 to keep it away from :1, :2, :3
    > which I knew were set up in xinit.d.
    >
    > I would prefer to have the server serve up a login greeter, so have
    > edited the startup script in /etc/xinit.d/vnc (loaded on the system with
    > the tightvnc RPM, I believe).
    > It is as follows
    >
    > Code:
    > --------------------
    > # default: off I EDITED OUT THE OFF
    > # description: This serves out a VNC connection which starts at a KDM
    > # login
    > # prompt. This VNC connection has a resolution of 1600x1200, 16bit
    > # depth.
    > service vnc3
    > {
    > type = UNLISTED
    > port = 5903
    > socket_type = stream
    > protocol = tcp
    > wait = no
    > user = nobody
    > server = /usr/bin/Xvnc
    > server_args = -noreset -inetd -once -query localhost -geometry
    > 1600x1200 -depth 16
    > # disable = yes
    > }
    > # default: off I EDITED OUT THE OFF
    > # description: This serves out the vncviewer Java applet for the VNC \
    > # server running on port 5902, (vnc port 3).
    > service vnchttpd3
    > {
    > type = UNLISTED
    > port = 5803
    > socket_type = stream
    > protocol = tcp
    > wait = no
    > user = nobody
    > server = /usr/bin/vnc_inetd_httpd
    > server_args = 1600 1200 5903
    > # disable = yes
    > }
    >
    > --------------------
    > I then restarted xinit.d and the vnc3 service shows as running.
    >
    > From the WinXP client, I open the tightvnc viewer for :3 and I get the
    > login greeter as expected. Entering my login name and password, the
    > viewer closes. If I try same via the java applet web interface, it also
    > closes with a message that the connection was reset by the server.
    >
    > Swerdna's tutorial on the topic does not speak to using the xinit.d
    > startup method


    Sounds like you are trying to run Xvnc as root. Otherwise, running it from
    a user account will log the external user into that account only. I may be
    missing something, but I run my connections at the office by logging in via
    ssh as the user I want to connect as and start vncserver the same as you do
    (except I specify the geometry to get something that will scale to my
    monitor). I DO NOT allow root access or remote admin so :1, :2, and :3 are
    available. I can always su to root if I need root access but I do not want
    root exposed to the world. That also allows me to use port forwarding to
    select the machine I want to hit via the router which puts one more firewall
    in the stream.

    I hadn't thought of using xinit.d but then I'm not looking to make things
    that open - call me paranoid. I get access to all the accounts I need to
    with a small amount of manual effort.

    --
    Will Honea

  4. #4
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    982

    Default Re: VNC server setup for 11.4

    Thanks for the comments.

    dbus-vncserver is the recommended user space launch per Swerdna's tutorial (see reference above) for SuSE 11.x.

    The xinit.d setup(in /etc/xinit.d/vnc) comes pre-configured with the tightnvc RPM, three different dimension virtual displays, owned by user=nobody, that serve up the login greeter, so "standard" username/password takes over from there. As installed, all three virtual displays are disabled.
    From it's documentation, it is compatible with ssh port forward tunneling. I have tried accessing it with and with out the ssh tunnel. I get the login greeter, but the X session appears to crash on startup. The only debug messaging I have found says "connection reset by host".

    Understand paranoia. I am trying to make it work, then will decide whether or not to use it.
    Thanks for comments.

  5. #5
    Will Honea NNTP User

    Default Re: VNC server setup for 11.4

    cmcgrath5035 wrote:

    >
    > Thanks for the comments.
    >
    > dbus-vncserver is the recommended user space launch per Swerdna's
    > tutorial (see reference above) for SuSE 11.x.
    >
    > The xinit.d setup(in /etc/xinit.d/vnc) comes pre-configured with the
    > tightnvc RPM, three different dimension virtual displays, owned by
    > user=nobody, that serve up the login greeter, so "standard"
    > username/password takes over from there. As installed, all three virtual
    > displays are disabled.
    > From it's documentation, it is compatible with ssh port forward
    > tunneling. I have tried accessing it with and with out the ssh tunnel. I
    > get the login greeter, but the X session appears to crash on startup.
    > The only debug messaging I have found says "connection reset by host".
    >
    > Understand paranoia. I am trying to make it work, then will decide
    > whether or not to use it.
    > Thanks for comments.


    Please post back if you solve this - it sounds like a much better setup for
    my purposes than what I have now as it eliminates the ssh-launch-connect
    sequence I use now, expecially for the rest of the staff that might want to
    use it.

    As a suggestion, have you tried looking at the logs after a failed session?
    I had some problems that finally resolved when I used an ssh connection to
    check the system log immediately after the failure. Mine was a failure to
    find a tty it could use but that was my fat fingers in the setup.

    --
    Will Honea

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •