Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Cannot capture sound from Line In Input in openSUSE 11.4 (no Pulseadio)

  1. #1
    Join Date
    Jan 2009
    Location
    Pittsburgh, PA
    Posts
    39

    Default Cannot capture sound from Line In Input in openSUSE 11.4 (no Pulseadio)

    I have been searching for an answer through most of the recent posts about sound issues but have not been able to find a solution. I am currently unable to capture sound from the "Line" input on my sound card. I do have sound and is working correctly for all applications and I do have P/A disabled (I'm not a huge fan of the sound quality with P/A enabled). I have checked and re-checked many settings but to no avail have not been able to capture sound. I'm sure I may be missing something or have not done something in order for this to work. I was using openSUSE 11.4 on a different pc and had no problems, unfortunately this is a different pc with a different sound card which is on-board so I am not entirely familiar with it yet.

    It is a C-media CMI9880 which shows up as a Intel HDA (ICH6) and appears to be configured correctly.

    Thank you!
    openSUSE 12.1 (x86_64) KDE 4.7.2 (release 5) Kernel 3.1.10-1.16-desktop x86_64

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Cannot capture sound from Line In Input in openSUSE 11.4 (no Pulseadio)

    Quote Originally Posted by JeremiahMosser View Post
    .... I do have P/A disabled (I'm not a huge fan of the sound quality with P/A enabled). I have checked and re-checked many settings but to no avail have not been able to capture sound.
    ... I know many people share your view point. But having stated that, I confess I'm not a fan of helping where users have configurations that are not standard and thus the configuration they are using has not been tested much.

    Still, despite that reluctance on my part, in the spirit of trying to help, please provide the information requested to be provided as documented in our multimedia stickie: Welcome to multimedia sub-area The information needed is the information quoted in that link. Ensure you have your mixer configured EXACTLY the way you think it should be configured to record, BEFORE you run the diagnostic script in that link.

  3. #3
    Join Date
    Jan 2009
    Location
    Pittsburgh, PA
    Posts
    39

    Default Re: Cannot capture sound from Line In Input in openSUSE 11.4 (no Pulseadio)

    alsa-Info
    http://www.alsa-project.org/db/?f=24...c512cea5db8fdf

    alsa rpm
    alsa-utils-1.0.24.2-3.1.i586
    alsa-1.0.24.1-4.7.1.i586
    alsa-firmware-1.0.24.1-3.1.noarch
    alsa-oss-1.0.17-32.1.i586
    alsa-plugins-1.0.24-6.1.i586

    pulse rpm
    libpulse-mainloop-glib0-0.9.22-6.11.1.i586
    libpulse0-0.9.22-6.11.1.i586

    libasound2 rpm
    libasound2-1.0.24.1-4.7.1.i586

    uname
    Linux dimension 2.6.37.6-0.5-default #1 SMP 2011-04-25 21:48:33 +0200 i686 i686 i386 GNU/Linux

    cat /etc/modprobe.d/50-sound.conf
    options snd slots=snd-hda-intel
    options snd-hda-intel model=full_dig
    # u1Nb.CKdNuFQ+Jk4:82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller
    alias snd-card-0 snd-hda-intel
    alias sound-slot-0 snd-hda-intel
    openSUSE 12.1 (x86_64) KDE 4.7.2 (release 5) Kernel 3.1.10-1.16-desktop x86_64

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Cannot capture sound from Line In Input in openSUSE 11.4 (no Pulseadio)

    Quote Originally Posted by JeremiahMosser View Post
    ok, some comments on that later.

    First, lets look at the 50-sound.conf file:
    Quote Originally Posted by JeremiahMosser View Post
    cat /etc/modprobe.d/50-sound.conf
    Code:
    options snd slots=snd-hda-intel
    options snd-hda-intel model=full_dig
    # u1Nb.CKdNuFQ+Jk4:82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller
    alias snd-card-0 snd-hda-intel
    alias sound-slot-0 snd-hda-intel
    I don't know if it makes any difference, but it it were me, I would have applied the 'full_dig' model option in the 1st line (reverse 1st and 2nd line) this way:
    Code:
    options snd-hda-intel model=full_dig
    options snd slots=snd-hda-intel
    # u1Nb.CKdNuFQ+Jk4:82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller
    alias snd-card-0 snd-hda-intel
    alias sound-slot-0 snd-hda-intel
    Note you need to restart alsa after every change to the 50-sound.conf file.

    Reference the 50-sound.conf file, did you apply those 'alias' settings ?? Or were they done automatically ? Are they both necessary ? ???

    Reference the model option, I note from the HD-Audio-Models.txt file these are the options:
    Code:
    CMI9880
    =======
      minimal    3-jack in back
      min_fp    3-jack in back, 2-jack in front
      full        6-jack in back, 2-jack in front
      full_dig    6-jack in back, 2-jack in front, SPDIF I/O
      allout    5-jack in back, 2-jack in front, SPDIF out
      auto        auto-config reading BIOS (default)
    Did you only try 'full_dig' or did you try each of those, one at a time ?

    Now, reference the script output, it appears you have 2 sound record devices, ... an analog and digital : hw:0,0 and hw:0,1

    Code:
    ARECORD
    
    **** List of CAPTURE Hardware Devices ****
    card 0: Intel [HDA Intel], device 0: CMI9880 [CMI9880]
      Subdevices: 2/2
      Subdevice #0: subdevice #0
      Subdevice #1: subdevice #1
    card 0: Intel [HDA Intel], device 1: CMI9880 Digital [CMI9880 Digital]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    I assume you are NOT trying to record with a mic, but rather you have some other unspecified audio input you are trying to capture with your line in. Is that correct (that it is NOT a mic)?

    Reference your mixer, I note:
    Code:
    !!Amixer output
    !!-------------
    
    !!-------Mixer controls for card 0 [Intel]
    
    Card hw:0 'Intel'/'HDA Intel at 0xccbf4000 irq 42'
      Mixer name    : 'C-Media CMI9880'
    Simple mixer control 'IEC958',0
      Mono: Playback [on] Capture [on]
    Simple mixer control 'Capture',0
      Front Left: Capture 15 [50%] [22.50dB] [on]
      Front Right: Capture 15 [50%] [22.50dB] [on]
    Simple mixer control 'Capture',1
      Front Left: Capture 15 [50%] [22.50dB] [on]
      Front Right: Capture 15 [50%] [22.50dB] [on]
    Simple mixer control 'Input Source',0
      Items: 'Front Mic' 'Rear Mic' 'Line' 'CD'
      Item0: 'Line'
    Simple mixer control 'Input Source',1
      Items: 'Front Mic' 'Rear Mic' 'Line' 'CD'
      Item0: 'Line
    Why only try to capture at 50% ? What if the scale is not linear ? Why not try to capture at a higher setting, and then once established back off on the levels ?

  5. #5
    Join Date
    Jan 2009
    Location
    Pittsburgh, PA
    Posts
    39

    Default Re: Cannot capture sound from Line In Input in openSUSE 11.4 (no Pulseadio)

    I don't know if it makes any difference, but it it were me, I would have applied the 'full_dig' model option in the 1st line
    I have not changed the order of those yet, but I will definitely try that.

    Reference the 50-sound.conf file, did you apply those 'alias' settings ?? Or were they done automatically ? Are they both necessary ?
    Those settings were done automatically, but I did check with the HD-Audio-models.txt to make sure it had the right model at the very least.

    I assume you are NOT trying to record with a mic, but rather you have some other unspecified audio input you are trying to capture with your line in. Is that correct (that it is NOT a mic)?
    You are correct it is NOT a mic. It is audio out from a cable box. I have a tv tuner installed and have the audio from the cable box going directly to the sound card. I also do know that it is not the cable box though.

    Why only try to capture at 50% ?
    I did have them at 100% while trying to diagnose the issue, I just recently reduced them so as not to "blow the windows out" if I had managed to get it working.

    I will change the order of the 'alias' now and see if that may do something.

    Thank you!
    openSUSE 12.1 (x86_64) KDE 4.7.2 (release 5) Kernel 3.1.10-1.16-desktop x86_64

  6. #6
    Join Date
    Jan 2009
    Location
    Pittsburgh, PA
    Posts
    39

    Default Re: Cannot capture sound from Line In Input in openSUSE 11.4 (no Pulseadio)

    I switch the order of the 'alias' and restarted alsa, which did not work, so I also reboot my pc and still no line capture. I also raised the volume level to 100%.
    As far as the 'alias' being necessary, I honestly have no idea.
    openSUSE 12.1 (x86_64) KDE 4.7.2 (release 5) Kernel 3.1.10-1.16-desktop x86_64

  7. #7
    Join Date
    Jan 2009
    Location
    Pittsburgh, PA
    Posts
    39

    Default Re: Cannot capture sound from Line In Input in openSUSE 11.4 (no Pulseadio)

    I have also tried removing the 'alias' lines and restarting the alsa, but am still having no luck.
    openSUSE 12.1 (x86_64) KDE 4.7.2 (release 5) Kernel 3.1.10-1.16-desktop x86_64

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Cannot capture sound from Line In Input in openSUSE 11.4 (no Pulseadio)

    Quote Originally Posted by JeremiahMosser View Post
    I have also tried removing the 'alias' lines and restarting the alsa, but am still having no luck.
    Did you try different model options :
    Code:
    CMI9880
    =======
      minimal    3-jack in back
      min_fp    3-jack in back, 2-jack in front
      full        6-jack in back, 2-jack in front
      full_dig    6-jack in back, 2-jack in front, SPDIF I/O
      allout    5-jack in back, 2-jack in front, SPDIF out
      auto        auto-config reading BIOS (default)
    I know you are using full_dig, but did you try any of the other options?

    If that does not work, you could try updating alsa to some cutting edge rpms I could point you to.

  9. #9
    Join Date
    Jan 2009
    Location
    Pittsburgh, PA
    Posts
    39

    Default Re: Cannot capture sound from Line In Input in openSUSE 11.4 (no Pulseadio)

    I did try changing the model. I tried all of the models, none of which made a difference.
    openSUSE 12.1 (x86_64) KDE 4.7.2 (release 5) Kernel 3.1.10-1.16-desktop x86_64

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Cannot capture sound from Line In Input in openSUSE 11.4 (no Pulseadio)

    Quote Originally Posted by JeremiahMosser View Post
    I did try changing the model. I tried all of the models, none of which made a difference.
    You could try updating alsa to the latest version, although I am skeptical that is the problem. I assume you have NOT changed your alsa versions since your initial post. Thus update: alsa-utils, alsa, alsa-firmware, alsa-oss, alsa-plugins, libasound2 and also install alsa-driver-kmp-default. There is guidance here: SDB:Alsa-update - openSUSE

    Note - and DO NOT FORGET this, after you "think" you have updated the alsa versions, check the version numbers. If they are the same then you failed to update them and you need to try again. I've lost count of the number of users who told me they either updated their alsa version, or that there was no version update available, and the truth was they simply did not know how to properly use zypper nor YaST and they could not recognize/complete an update, even though there was an update needed and available.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •