Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: GStreamer broken after update

  1. #1

    Exclamation GStreamer broken after update

    Hello All!
    I'm using KDE and after some update GStreamer seems to be broken. Firstly it was unable to play sound at all, and I've got around this by changing Phonon preferred engine to Xine. But Clementine is still unable to play with error message:
    Clementine Error
    GStreamer could not create the element: volume. Please make sure that you have installed all necessary GStreamer plugins (e.g. OGG and MP3)
    I've already read this and this topic, but none of the things, proposed to try, worked for me.

  2. #2
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    1,711

    Default Απ: GStreamer broken after update

    Hello
    Are you sure that you have installed all codecs??
    Check it again
    Could I see your repos??
    Code:
    su
    Code:
    # zypper lr -d
    Also do you remember which update was
    Maybe You're missing the "volume" element - check you've installed it properly, try running "gst-inspect volume". It should come from /usr/lib/gstreamer-0.10/libgstvolume.so
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15.3||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1080 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  3. #3
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: GStreamer broken after update

    Quote Originally Posted by D_E View Post
    I'm using KDE and after some update GStreamer seems to be broken.
    You can find out what that update was, by inspecting the text file at /var/log/zypp/history.

  4. #4

    Default Re: Απ: GStreamer broken after update

    Quote Originally Posted by stamostolias View Post
    Maybe You're missing the "volume" element - check you've installed it properly, try running "gst-inspect volume". It should come from /usr/lib/gstreamer-0.10/libgstvolume.so
    Yes, there seems to be problem with it. Just re-installed one more time, still no luck.
    Code:
    GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstvolume.so': /usr/lib/gstreamer-0.10/libgstvolume.so: undefined symbol: orc_program_append_2

  5. #5
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    1,711

    Default Απ: Re: Απ: GStreamer broken after update

    Quote Originally Posted by D_E View Post
    Yes, there seems to be problem with it. Just re-installed one more time, still no luck.
    Code:
    GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstvolume.so': /usr/lib/gstreamer-0.10/libgstvolume.so: undefined symbol: orc_program_append_2
    You have openSUSE 11.3 or 11.4?? x86 or x86_64??
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15.3||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1080 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  6. #6

    Default Re: Απ: Re: Απ: GStreamer broken after update

    openSUSE 11.3 x86, KDE 4.6.0

  7. #7
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    1,711

    Default Απ: Re: Απ: Re: Απ: GStreamer broken after update

    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15.3||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1080 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  8. #8
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: Απ: Re: Απ: Re: Απ: GStreamer broken after update

    Stamos, why should he use an .rpm from pbone? I use Clementine as well and it still works here, so I suppose it's not a general gstreamer-bug.

  9. #9
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    1,711

    Default Απ: Re: Απ: Re: Απ: Re: Απ: GStreamer broken after update

    Quote Originally Posted by gropiuskalle View Post
    Stamos, why should he use an .rpm from pbone? I use Clementine as well and it still works here, so I suppose it's not a general gstreamer-bug.
    Maybe it is not a general gstreamer bug as you said, but i thing that he could fix his problem. Anyway because
    as I can see
    Code:
    GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstvolume.so': /usr/lib/gstreamer-0.10/libgstvolume.so: undefined symbol: orc_program_append_2
    that too libraries undefined. I thought that it will be better to install all plugins.
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15.3||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1080 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  10. #10

    Default Re: Απ: Re: Απ: Re: Απ: Re: Απ: GStreamer broken after update

    stamostolias, thanks for pointing me into the right direction!
    .rpm from pbone can't be installed due to error, but switching gstreamer-0_10-plugins-base, gstreamer-0_10-plugins-bad, and gstreamer-0_10-plugins-good from Packman to OSS repository solved the problem for now. Nevertheless it seems like source of potential troubles in the future as now gstreamer is partly installed from Packman (no proprietary codecs in OSS repository) and partly from OSS (as gstreamer-0_10-plugins-base from Packman have some undefined symbol)

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •