Results 1 to 5 of 5

Thread: wireless is not working

  1. #1

    Default wireless is not working

    I have MAC PRO 7.1 laptop running on Opensuse 11.4 final version in a 64-bit mode in a KDE desktop environment. My wireless is not working. Following is the output of the questions sought. Please help me fix it.

    Thanks in advance.


    nataraj@linux-0oz4:~> /sbin/lspci

    00:00.0 Host bridge: nVidia Corporation MCP89 HOST Bridge (rev a1)
    01:00.0 FireWire (IEEE 1394): Agere Systems FW643 PCI Express1394b Controller (PHY/Link) (rev 08)
    02:00.0 Network controller: Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller (rev 01)
    03:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5764M Gigabit Ethernet PCIe (rev 10)
    04:00.0 VGA compatible controller: nVidia Corporation Device 08a0 (rev a2)

    nataraj@linux-0oz4:~> dmesg | grep b43

    662:[ 1.639762] b43-pci-bridge 0000:02:00.0: PCI INT A -> Link[Z00J] -> GSI 22 (level, low) -> IRQ 22
    663:[ 1.639772] b43-pci-bridge 0000:02:00.0: setting latency timer to 64

    nataraj@linux-0oz4:~> /usr/sbin/iwconfig

    lo no wireless extensions.

    eth0 no wireless extensions.

    nataraj@linux-0oz4:~> sudo /usr/sbin/iwlist scan

    lo Interface doesn't support scanning.

    eth0 Interface doesn't support scanning.

  2. #2
    Join Date
    Nov 2009
    Location
    Uruguay
    Posts
    742

    Default Re: wireless is not working

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    Did yu install the broadcom-wl-kmp-<your_kernel_type> rpm from packman?

    - --
    VampirD

    Microsoft Windows is like air conditioning
    Stops working when you open a window.
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.15 (GNU/Linux)
    Comment: Using GnuPG with SUSE - http://enigmail.mozdev.org/

    iEYEARECAAYFAk3UCf8ACgkQJQ+0ABWtaVkSbwCfQkNmWZNSPcI+EmGuS9O4woQH
    Je4AoK4GfnORcyK1Nq8O8JQtRP389YHN
    =v/ml
    -----END PGP SIGNATURE-----

  3. #3

    Default Re: wireless is not working

    Yes, I did the following as I use the default kernel.

    zypper in broadcom-wl broadcom-wl-kmp-default

  4. #4

    Default Re: wireless is not working

    Further, I have also installed the following:

    zypper in b43-fwcutter
    sudo /usr/sbin/install_bcm43xx_firmware
    zypper in b43-firmware

    Even after this, /sbin/ifconfig does not list wlan0 entry.

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: wireless is not working

    On this page
    b43 - Linux Wireless

    It doesn't look good for either driver
    But 'wl' would require you follow this
    Install Broadcom Drivers from Packman
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •