Results 1 to 4 of 4

Thread: [wireless] need modules restart everytime

  1. #1

    Default [wireless] need modules restart everytime

    Everytime i turn on openSUSE I've to follow this procedure to get wireless work, or I can't see any wireless device, neither from iwconfig.

    OS: openSUSE 11.3
    wlan adapter: Broadcom 4312 14e4:4315

    Everytime i boot up openSUSE wlan isn't loaded fine.
    I've to do all this, everytime:
    Code:
    sudo rmmod ssb
    sudo rmmod wl
    sudo modprobe wl
    sudo iwconfig

  2. #2
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: [wireless] need modules restart everytime

    On 05/17/2011 02:06 PM, Buntolo wrote:
    >
    > Everytime i turn on openSUSE I've to follow this procedure to get
    > wireless work, or I can't see any wireless device, neither from
    > iwconfig.
    >
    > OS: openSUSE 11.3
    > wlan adapter: Broadcom 4312 14e4:4315
    >
    > Everytime i boot up openSUSE wlan isn't loaded fine.
    > I've to do all this, everytime:
    >
    > Code:
    > --------------------
    > sudo rmmod ssb
    > sudo rmmod wl
    > sudo modprobe wl
    > sudo iwconfig
    > --------------------


    As long as you are using wl, you need to blacklist ssb.

  3. #3

    Default Re: [wireless] need modules restart everytime

    Quote Originally Posted by lwfinger View Post
    On 05/17/2011 02:06 PM, Buntolo wrote:
    >
    > Everytime i turn on openSUSE I've to follow this procedure to get
    > wireless work, or I can't see any wireless device, neither from
    > iwconfig.
    >
    > OS: openSUSE 11.3
    > wlan adapter: Broadcom 4312 14e4:4315
    >
    > Everytime i boot up openSUSE wlan isn't loaded fine.
    > I've to do all this, everytime:
    >
    > Code:
    > --------------------
    > sudo rmmod ssb
    > sudo rmmod wl
    > sudo modprobe wl
    > sudo iwconfig
    > --------------------


    As long as you are using wl, you need to blacklist ssb.
    I've already done it.
    It was working until some kind of upgrade, after which I've looked in /etc/modprobe.d/50-blacklist.conf and ssb was there with b43.

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: [wireless] need modules restart everytime

    Make sure the update included the broadcom-wl-kmp-xxxx (kernel driver) package for your system.

    For example, if using the desktop kernel, then

    Code:
    rpm -qa |grep wl
    should return something like

    Code:
    broadcom-wl-5.100.82.38-7.pm.9.4.i586
    broadcom-wl-kmp-desktop-5.100.82.38_k2.6.34.8_0.2-7.pm.9.4.i586

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •