Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Application windows entirely black when another one already displayed

  1. #1
    Join Date
    Apr 2009
    Location
    France
    Posts
    34

    Question Application windows entirely black when another one already displayed

    Hello all.
    I am using OpenSuse 11.4 (64 bits) with KDE 4.6.0. My graphic card is nVidia Ge Force 6150 LE with the nVidia proprietary 2D driver (called "nVidia" on the system information page).
    A strange graphic behaviour occurs until a few days: when an application (eg Firefox) is already running and when I try to open another application (eg Thunderbird or Dolphin), the associated window is completely black except the upper bar mentionning the name of the application. It seems that this problem occurs only when an application is already running with its window displayed. It is necessary to close this application in order to run correctly another one. It is impossible to run correctly more than one application.
    Any idea please ?
    Thanks a lot for your answers.

  2. #2
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    1,918

    Default Re: Application windows entirely black when another one already displayed

    Quote Originally Posted by olyv View Post
    Hello all.
    I am using OpenSuse 11.4 (64 bits) with KDE 4.6.0. My graphic card is nVidia Ge Force 6150 LE with the nVidia proprietary 2D driver (called "nVidia" on the system information page).
    A strange graphic behaviour occurs until a few days: when an application (eg Firefox) is already running and when I try to open another application (eg Thunderbird or Dolphin), the associated window is completely black except the upper bar mentionning the name of the application. It seems that this problem occurs only when an application is already running with its window displayed. It is necessary to close this application in order to run correctly another one. It is impossible to run correctly more than one application.
    Any idea please ?
    Thanks a lot for your answers.
    Could You tell us how did You install your driver ?

    Have You read this already ?
    openSUSE Graphic Card Practical Theory Guide for Users

    Could You post the output of "/var/log/Xorg.0.log" here ?

    Best regards,
    Greg
    Best regards,
    Greg

  3. #3
    Join Date
    Apr 2009
    Location
    France
    Posts
    34

    Default Re: Application windows entirely black when another one already displayed

    Thanks for your rapid answer Greg !
    Yes, I know this users' guide about graphic cards, I have installed the free "nvidia" proprietary driver following the nVidia chapter of this tutorial: SDB:NVIDIA drivers - openSUSE
    I have done that just after update from OpenSuse 11.3 to 11.4 and it was OK until today, perhaps a recent system update is linked to this problem...
    Here is my "/var/log/Xorg.0.log" in 3 parts because it is too long:

    [ 17.250]
    X.Org X Server 1.9.3
    Release Date: 2010-12-13
    [ 17.267] X Protocol Version 11, Revision 0
    [ 17.267] Build Operating System: openSUSE SUSE LINUX
    [ 17.267] Current Operating System: Linux linux 2.6.37.6-0.5-desktop #1 SMP PREEMPT 2011-04-25 21:48:33 +0200 x86_64
    [ 17.267] Kernel command line: root=/dev/disk/by-id/ata-WDC_WD20EARS-00MVWB0_WD-WMAZA2934639-part1 resume=/dev/disk/by-id/ata-WDC_WD20EARS-00MVWB0_WD-WMAZA2934639-part2 splash=silent quiet vga=0x31a
    [ 17.267] Build Date: 22 February 2011 10:08:09PM
    [ 17.267]
    [ 17.267] Current version of pixman: 0.20.0
    [ 17.267] Before reporting problems, check X.Org Wiki - Home
    to make sure that you have the latest version.
    [ 17.267] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [ 17.267] (==) Log file: "/var/log/Xorg.0.log", Time: Tue May 17 10:57:56 2011
    [ 17.267] (==) Using config directory: "/etc/X11/xorg.conf.d"
    [ 17.271] (==) No Layout section. Using the first Screen section.
    [ 17.271] (**) |-->Screen "Default Screen" (0)
    [ 17.271] (**) | |-->Monitor "Default Monitor"
    [ 17.271] (**) | |-->Device "Default Device"
    [ 17.271] (==) Automatically adding devices
    [ 17.271] (==) Automatically enabling devices
    [ 17.271] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
    [ 17.271] Entry deleted from font path.
    [ 17.271] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
    [ 17.271] Entry deleted from font path.
    [ 17.271] (WW) The directory "/usr/share/fonts/misc/sgi" does not exist.
    [ 17.271] Entry deleted from font path.
    [ 17.271] (==) FontPath set to:
    /usr/share/fonts/misc:unscaled,
    /usr/share/fonts/Type1/,
    /usr/share/fonts/100dpi:unscaled,
    /usr/share/fonts/75dpi:unscaled,
    /usr/share/fonts/URW/,
    /usr/share/fonts/cyrillic:unscaled,
    /usr/share/fonts/truetype/
    [ 17.271] (==) ModulePath set to "/usr/lib64/xorg/modules/updates,/usr/lib64/xorg/modules"
    [ 17.271] (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
    [ 17.271] (II) Loader magic: 0x7dc040
    [ 17.271] (II) Module ABI versions:
    [ 17.271] X.Org ANSI C Emulation: 0.4
    [ 17.271] X.Org Video Driver: 8.0
    [ 17.271] X.Org XInput driver : 11.0
    [ 17.271] X.Org Server Extension : 4.0
    [ 17.277] (--) PCI:*(0:0:5:0) 10de:0241:103c:2a34 rev 162, Mem @ 0xfc000000/16777216, 0xe0000000/268435456, 0xfb000000/16777216, BIOS @ 0x????????/131072
    [ 17.277] (II) Open ACPI successful (/var/run/acpid.socket)
    [ 17.277] (II) LoadModule: "extmod"
    [ 17.292] (II) Loading /usr/lib64/xorg/modules/extensions/libextmod.so
    [ 17.293] (II) Module extmod: vendor="X.Org Foundation"
    [ 17.293] compiled for 1.9.3, module version = 1.0.0
    [ 17.293] Module class: X.Org Server Extension
    [ 17.293] ABI class: X.Org Server Extension, version 4.0
    [ 17.293] (II) Loading extension MIT-SCREEN-SAVER
    [ 17.293] (II) Loading extension XFree86-VidModeExtension
    [ 17.293] (II) Loading extension XFree86-DGA
    [ 17.293] (II) Loading extension DPMS
    [ 17.293] (II) Loading extension XVideo
    [ 17.293] (II) Loading extension XVideo-MotionCompensation
    [ 17.293] (II) Loading extension X-Resource
    [ 17.293] (II) LoadModule: "dbe"
    [ 17.293] (II) Loading /usr/lib64/xorg/modules/extensions/libdbe.so
    [ 17.293] (II) Module dbe: vendor="X.Org Foundation"
    [ 17.293] compiled for 1.9.3, module version = 1.0.0
    [ 17.293] Module class: X.Org Server Extension
    [ 17.293] ABI class: X.Org Server Extension, version 4.0
    [ 17.293] (II) Loading extension DOUBLE-BUFFER
    [ 17.293] (II) LoadModule: "glx"
    [ 17.293] (II) Loading /usr/lib64/xorg/modules/updates/extensions/libglx.so
    [ 17.316] (II) Module glx: vendor="NVIDIA Corporation"
    [ 17.316] compiled for 4.0.2, module version = 1.0.0
    [ 17.316] Module class: X.Org Server Extension
    [ 17.316] (II) NVIDIA GLX Module 270.41.06 Mon Apr 18 15:10:15 PDT 2011
    [ 17.316] (II) Loading extension GLX
    [ 17.316] (II) LoadModule: "record"
    [ 17.316] (II) Loading /usr/lib64/xorg/modules/extensions/librecord.so
    [ 17.317] (II) Module record: vendor="X.Org Foundation"
    [ 17.317] compiled for 1.9.3, module version = 1.13.0
    [ 17.317] Module class: X.Org Server Extension
    [ 17.317] ABI class: X.Org Server Extension, version 4.0
    [ 17.317] (II) Loading extension RECORD
    [ 17.317] (II) LoadModule: "dri"
    [ 17.317] (II) Loading /usr/lib64/xorg/modules/extensions/libdri.so
    [ 17.317] (II) Module dri: vendor="X.Org Foundation"
    [ 17.317] compiled for 1.9.3, module version = 1.0.0
    [ 17.317] ABI class: X.Org Server Extension, version 4.0
    [ 17.317] (II) Loading extension XFree86-DRI
    [ 17.318] (II) LoadModule: "dri2"
    [ 17.318] (II) Loading /usr/lib64/xorg/modules/extensions/libdri2.so
    [ 17.318] (II) Module dri2: vendor="X.Org Foundation"
    [ 17.318] compiled for 1.9.3, module version = 1.2.0
    [ 17.318] ABI class: X.Org Server Extension, version 4.0
    [ 17.318] (II) Loading extension DRI2
    [ 17.318] (==) Matched nvidia as autoconfigured driver 0
    [ 17.318] (==) Matched nouveau as autoconfigured driver 1
    [ 17.318] (==) Matched nv as autoconfigured driver 2
    [ 17.318] (==) Matched fbdev as autoconfigured driver 3
    [ 17.318] (==) Matched vesa as autoconfigured driver 4
    [ 17.318] (==) Assigned the driver to the xf86ConfigLayout
    [ 17.318] (II) LoadModule: "nvidia"
    [ 17.318] (II) Loading /usr/lib64/xorg/modules/updates/drivers/nvidia_drv.so
    [ 17.319] (II) Module nvidia: vendor="NVIDIA Corporation"
    [ 17.319] compiled for 4.0.2, module version = 1.0.0
    [ 17.319] Module class: X.Org Video Driver
    [ 17.320] (II) LoadModule: "nouveau"
    [ 17.321] (II) Loading /usr/lib64/xorg/modules/drivers/nouveau_drv.so
    [ 17.321] (II) Module nouveau: vendor="X.Org Foundation"
    [ 17.321] compiled for 1.9.3, module version = 0.0.16
    [ 17.321] Module class: X.Org Video Driver
    [ 17.321] ABI class: X.Org Video Driver, version 8.0
    [ 17.321] (II) LoadModule: "nv"
    [ 17.333] (II) Loading /usr/lib64/xorg/modules/drivers/nv_drv.so
    [ 17.333] (II) Module nv: vendor="X.Org Foundation"
    [ 17.333] compiled for 1.9.3, module version = 2.1.18
    [ 17.333] Module class: X.Org Video Driver
    [ 17.333] ABI class: X.Org Video Driver, version 8.0
    [ 17.333] (II) LoadModule: "fbdev"
    [ 17.335] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
    [ 17.335] (II) Module fbdev: vendor="X.Org Foundation"
    [ 17.335] compiled for 1.9.3, module version = 0.4.2
    [ 17.335] ABI class: X.Org Video Driver, version 8.0
    [ 17.335] (II) LoadModule: "vesa"
    [ 17.336] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
    [ 17.336] (II) Module vesa: vendor="X.Org Foundation"
    [ 17.336] compiled for 1.9.3, module version = 2.3.0
    [ 17.336] Module class: X.Org Video Driver
    [ 17.340] ABI class: X.Org Video Driver, version 8.0
    [ 17.341] (II) NVIDIA dlloader X Driver 270.41.06 Mon Apr 18 14:55:25 PDT 2011
    [ 17.341] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
    [ 17.341] (II) NOUVEAU driver
    [ 17.341] (II) NOUVEAU driver for NVIDIA chipset families :
    [ 17.341] RIVA TNT (NV04)
    [ 17.341] RIVA TNT2 (NV05)
    [ 17.341] GeForce 256 (NV10)
    [ 17.341] GeForce 2 (NV11, NV15)
    [ 17.341] GeForce 4MX (NV17, NV18)
    [ 17.341] GeForce 3 (NV20)
    [ 17.341] GeForce 4Ti (NV25, NV28)
    [ 17.341] GeForce FX (NV3x)
    [ 17.341] GeForce 6 (NV4x)
    [ 17.341] GeForce 7 (G7x)
    [ 17.341] GeForce 8 (G8x)
    ...

    Regards.

  4. #4
    Join Date
    Apr 2009
    Location
    France
    Posts
    34

    Default Re: Application windows entirely black when another one already displayed

    ...
    [ 17.341] (II) NV: driver for NVIDIA chipsets: RIVA 128, RIVA TNT, RIVA TNT2,
    Unknown TNT2, Vanta, RIVA TNT2 Ultra, RIVA TNT2 Model 64,
    Aladdin TNT2, GeForce 256, GeForce DDR, Quadro, GeForce2 MX/MX 400,
    GeForce2 MX 100/200, GeForce2 Go, Quadro2 MXR/EX/Go,
    GeForce2 Integrated GPU, GeForce2 GTS, GeForce2 Ti, GeForce2 Ultra,
    Quadro2 Pro, GeForce4 MX 460, GeForce4 MX 440, GeForce4 MX 420,
    GeForce4 MX 440-SE, GeForce4 440 Go, GeForce4 420 Go,
    GeForce4 420 Go 32M, GeForce4 460 Go, Quadro4 550 XGL,
    GeForce4 440 Go 64M, Quadro NVS, Quadro4 500 GoGL,
    GeForce4 410 Go 16M, GeForce4 MX 440 with AGP8X,
    GeForce4 MX 440SE with AGP8X, GeForce4 MX 420 with AGP8X,
    GeForce4 MX 4000, GeForce4 448 Go, GeForce4 488 Go, Quadro4 580 XGL,
    Quadro4 NVS 280 SD, Quadro4 380 XGL, Quadro NVS 50 PCI,
    GeForce4 448 Go, GeForce4 MX Integrated GPU, GeForce3,
    GeForce3 Ti 200, GeForce3 Ti 500, Quadro DCC, GeForce4 Ti 4600,
    GeForce4 Ti 4400, GeForce4 Ti 4200, Quadro4 900 XGL, Quadro4 750 XGL,
    Quadro4 700 XGL, GeForce4 Ti 4800, GeForce4 Ti 4200 with AGP8X,
    GeForce4 Ti 4800 SE, GeForce4 4200 Go, Quadro4 700 GoGL,
    Quadro4 980 XGL, Quadro4 780 XGL, GeForce FX 5800 Ultra,
    GeForce FX 5800, Quadro FX 2000, Quadro FX 1000,
    GeForce FX 5600 Ultra, GeForce FX 5600, GeForce FX 5600XT,
    GeForce FX Go5600, GeForce FX Go5650, Quadro FX Go700,
    GeForce FX 5200, GeForce FX 5200 Ultra, GeForce FX 5200,
    GeForce FX 5200LE, GeForce FX Go5200, GeForce FX Go5250,
    GeForce FX 5500, GeForce FX 5100, GeForce FX Go5200 32M/64M,
    Quadro NVS 55/280 PCI, Quadro FX 500/600 PCI,
    GeForce FX Go53xx Series, GeForce FX Go5100, GeForce FX 5900 Ultra,
    GeForce FX 5900, GeForce FX 5900XT, GeForce FX 5950 Ultra,
    GeForce FX 5900ZT, Quadro FX 3000, Quadro FX 700,
    GeForce FX 5700 Ultra, GeForce FX 5700, GeForce FX 5700LE,
    GeForce FX 5700VE, GeForce FX Go5700, GeForce FX Go5700,
    Quadro FX Go1000, Quadro FX 1100, GeForce 6800 Ultra, GeForce 6800,
    GeForce 6800 LE, GeForce 6800 XE, GeForce 6800 XT, GeForce 6800 GT,
    GeForce 6800 GT, GeForce 6800 GS, GeForce 6800 XT, Quadro FX 4000,
    GeForce 6800 GS, GeForce 6800, GeForce 6800 LE, GeForce 6800 XT,
    GeForce Go 6800, GeForce Go 6800 Ultra, Quadro FX Go1400,
    Quadro FX 3450/4000 SDI, Quadro FX 1400, GeForce 6600 GT,
    GeForce 6600, GeForce 6600 LE, GeForce 6600 VE, GeForce Go 6600,
    GeForce 6610 XL, GeForce Go 6600 TE/6200 TE, GeForce 6700 XL,
    GeForce Go 6600, GeForce Go 6600 GT, Quadro NVS 440, Quadro FX 550,
    Quadro FX 550, Quadro FX 540, GeForce 6200, GeForce 6500,
    GeForce 6200 TurboCache(TM), GeForce 6200SE TurboCache(TM),
    GeForce 6200 LE, GeForce Go 6200, Quadro NVS 285, GeForce Go 6400,
    GeForce Go 6200, GeForce Go 6400, GeForce 6250, GeForce 7100 GS,
    GeForce 6800, GeForce 6800 LE, GeForce 6800 GT, GeForce 6800 XT,
    GeForce 6200, GeForce 6200 A-LE, GeForce 7800 GTX, GeForce 7800 GTX,
    GeForce 7800 GT, GeForce 7800 GS, GeForce 7800 SLI, GeForce Go 7800,
    GeForce Go 7800 GTX, Quadro FX 4500, GeForce 7350 LE,
    GeForce 7300 LE, GeForce 7300 SE, GeForce Go 7200, GeForce Go 7300,
    GeForce Go 7400, GeForce Go 7400 GS, Quadro NVS 110M,
    Quadro NVS 120M, Quadro FX 350M, GeForce 7500 LE, Quadro FX 350,
    GeForce 7300 GS, GeForce 7650 GS, GeForce 7600 GT, GeForce 7600 GS,
    GeForce 7300 GT, GeForce 7600 LE, GeForce 7300 GT, GeForce Go 7700,
    GeForce Go 7600, GeForce Go 7600 GT, Quadro NVS 300M,
    GeForce Go 7900 SE, Quadro FX 550M, Quadro FX 560, GeForce 7900 GTX,
    GeForce 7900 GT, GeForce 7900 GS, GeForce 7950 GX2, GeForce 7950 GX2,
    GeForce 7950 GT, GeForce Go 7950 GTX, GeForce Go 7900 GS,
    GeForce Go 7900 GTX, Quadro FX 2500M, Quadro FX 1500M,
    Quadro FX 5500, Quadro FX 3500, Quadro FX 1500, Quadro FX 4500 X2,
    GeForce 6150, GeForce 6150 LE, GeForce 6100, GeForce Go 6150,
    Quadro NVS 210S / NVIDIA GeForce 6150LE, GeForce Go 6100,
    GeForce 6150SE, GeForce 6100 nForce 405, GeForce 6100 nForce 400,
    GeForce 6100 nForce 420, GeForce 7150M / nForce 630M,
    GeForce 7000M / nForce 610M, GeForce 7050 PV / nForce 630a,
    GeForce 7050 PV / nForce 630a, GeForce 7025 / nForce 630a,
    GeForce 8800 GTX, GeForce 8800 GTS, GeForce 8800 Ultra,
    Quadro FX 5600, Quadro FX 4600, GeForce 8600 GTS, GeForce 8600 GT,
    GeForce 8600 GT, GeForce 8600 GS, GeForce 8400 GS, GeForce 9500M GS,
    GeForce 8300 GS, GeForce 8600M GT, GeForce 9650M GS,
    GeForce 8700M GT, Quadro FX 370, Quadro NVS 320M, Quadro FX 570M,
    Quadro FX 1600M, Quadro FX 570, Quadro FX 1700, GeForce GT 330,
    GeForce 8400 SE, GeForce 8500 GT, GeForce 8400 GS, GeForce 8300 GS,
    GeForce 8400 GS, GeForce 8600M GS, GeForce 8400M GT,
    GeForce 8400M GS, GeForce 8400M G, Quadro NVS 140M, Quadro NVS 130M,
    Quadro NVS 135M, GeForce 9400 GT, Quadro FX 360M, GeForce 9300M G,
    Quadro NVS 290, GeForce GTX 295, GeForce GTX 280, GeForce GTX 260,
    GeForce GTX 285, GeForce GTX 275, GeForce GTX 260, GeForce GTX 295,
    Quadroplex 2200 D2, Quadroplex 2200 S4, Quadro CX, Quadro FX 5800,
    Quadro FX 4800, Quadro FX 3800, GeForce 8800 GTS 512,
    GeForce 9800 GT, GeForce 8800 GT, GeForce GT 230, GeForce 9800 GX2,
    GeForce 9800 GT, GeForce 8800 GS, GeForce GTS 240, GeForce 9800M GTX,
    GeForce 8800M GTS, GeForce GTX 280M, GeForce 9800M GT,
    GeForce 8800M GTX, GeForce 8800 GS, GeForce GTX 285M,
    GeForce 9600 GSO, GeForce 8800 GT, GeForce 9800 GTX/9800 GTX+,
    GeForce 9800 GTX+, GeForce 9800 GT, GeForce GTS 250,
    GeForce 9800M GTX, GeForce GTX 260M, Quadro FX 4700 X2,
    Quadro FX 3700, Quadro VX 200, Quadro FX 3600M, Quadro FX 2800M,
    Quadro FX 3700M, Quadro FX 3800M, GeForce 9600 GT, GeForce 9600 GS,
    GeForce 9600 GSO 512, GeForce GT 130, GeForce GT 140,
    GeForce 9800M GTS, GeForce 9700M GTS, GeForce 9800M GS,
    GeForce 9800M GTS, GeForce 9600 GT, GeForce 9600 GT,
    GeForce GTS 160M, GeForce GTS 150M, GeForce 9600 GSO,
    GeForce 9600 GT, Quadro FX 1800, Quadro FX 2700M, GeForce 9500 GT,
    GeForce 9400 GT, GeForce 9500 GT, GeForce 9500 GS, GeForce 9500 GS,
    GeForce GT 120, GeForce 9600M GT, GeForce 9600M GS, GeForce 9600M GT,
    GeForce 9700M GT, GeForce 9500M G, GeForce 9650M GT, GeForce G 110M,
    GeForce GT 130M, GeForce GT 120M, GeForce GT 220M, GeForce 9650 S,
    Quadro FX 380, Quadro FX 580, Quadro FX 1700M, GeForce 9400 GT,
    Quadro FX 770M, GeForce 9300 GE, GeForce 9300 GS, GeForce 8400,
    GeForce 8400 SE, GeForce 8400 GS, GeForce 9300M GS, GeForce G100,
    GeForce 9300 SE, GeForce 9200M GS, GeForce 9300M GS, Quadro NVS 150M,
    Quadro NVS 160M, GeForce G 105M, GeForce G 103M, GeForce G105M,
    Quadro NVS 420, Quadro FX 370 LP, Quadro NVS 450, Quadro FX 370M,
    Quadro NVS 295, GeForce 9100M G, GeForce 8200M G, GeForce 9200,
    GeForce 9100, GeForce 8300, GeForce 8200, nForce 730a, GeForce 9200,
    nForce 980a/780a SLI, nForce 750a SLI, GeForce 8100 / nForce 720a,
    GeForce 9400, GeForce 9400, GeForce 9400M G, GeForce 9400M,
    GeForce 9300, ION, GeForce 9400M G, GeForce 9400, nForce 760i SLI,
    GeForce 9400, GeForce 9300 / nForce 730i, GeForce 9200,
    GeForce 9100M G, GeForce 8200M G, GeForce 9400M, GeForce 9200,
    GeForce G102M, GeForce G102M, ION, ION, GeForce 9400, ION, ION LE,
    ION LE, GeForce GT 220, GeForce 315, GeForce 210, GeForce GT 230M,
    GeForce GT 330M, GeForce GT 230M, GeForce GT 330M, NVS 5100M,
    GeForce GT 320M, GeForce GT 240M, GeForce GT 325M, Quadro FX 880M,
    GeForce G210, GeForce 205, GeForce 310, ION, GeForce 210,
    GeForce 310, GeForce 315, GeForce G105M, GeForce G105M, NVS 2100M,
    NVS 3100M, GeForce 305M, ION, GeForce 310M, GeForce 305M,
    GeForce 310M, GeForce 305M, GeForce G210M, GeForce 310M,
    Quadro FX 380 LP, Quadro FX 380M, GeForce GT 330, GeForce GT 320,
    GeForce GT 240, GeForce GT 340, GeForce GT 330, GeForce GTS 260M,
    GeForce GTS 250M, GeForce 315, GeForce GT 335M, GeForce GTS 350M,
    GeForce GTS 360M, Quadro FX 1800M
    [ 17.345] (II) FBDEV: driver for framebuffer: fbdev
    [ 17.345] (II) VESA: driver for VESA chipsets: vesa
    [ 17.345] (++) using VT number 7

    [ 17.417] (II) Loading sub module "fb"
    [ 17.417] (II) LoadModule: "fb"
    [ 17.418] (II) Loading /usr/lib64/xorg/modules/libfb.so
    [ 17.418] (II) Module fb: vendor="X.Org Foundation"
    [ 17.418] compiled for 1.9.3, module version = 1.0.0
    [ 17.418] ABI class: X.Org ANSI C Emulation, version 0.4
    [ 17.418] (II) Loading sub module "wfb"
    [ 17.418] (II) LoadModule: "wfb"
    [ 17.420] (II) Loading /usr/lib64/xorg/modules/libwfb.so
    [ 17.421] (II) Module wfb: vendor="X.Org Foundation"
    [ 17.421] compiled for 1.9.3, module version = 1.0.0
    [ 17.421] ABI class: X.Org ANSI C Emulation, version 0.4
    [ 17.421] (II) Loading sub module "ramdac"
    [ 17.421] (II) LoadModule: "ramdac"
    [ 17.421] (II) Module "ramdac" already built-in
    ...

  5. #5
    Join Date
    Apr 2009
    Location
    France
    Posts
    34

    Default Re: Application windows entirely black when another one already displayed

    ...
    [ 17.421] (WW) Falling back to old probe method for fbdev
    [ 17.421] (II) Loading sub module "fbdevhw"
    [ 17.421] (II) LoadModule: "fbdevhw"
    [ 17.422] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
    [ 17.426] (II) Module fbdevhw: vendor="X.Org Foundation"
    [ 17.427] compiled for 1.9.3, module version = 0.0.2
    [ 17.427] ABI class: X.Org Video Driver, version 8.0
    [ 17.427] (WW) Falling back to old probe method for vesa
    [ 17.427] (II) NVIDIA(0): Creating default Display subsection in Screen section
    "Default Screen" for depth/fbbpp 24/32
    [ 17.427] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
    [ 17.427] (==) NVIDIA(0): RGB weight 888
    [ 17.427] (==) NVIDIA(0): Default visual is TrueColor
    [ 17.427] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
    [ 18.212] (II) NVIDIA(GPU-0): Display (HP Compaq FP1906 (CRT-0)) does not support NVIDIA 3D
    [ 18.212] (II) NVIDIA(GPU-0): Vision stereo.
    [ 18.213] (II) NVIDIA(0): NVIDIA GPU GeForce 6150 LE (C51) at PCI:0:5:0 (GPU-0)
    [ 18.213] (--) NVIDIA(0): Memory: 262144 kBytes
    [ 18.213] (--) NVIDIA(0): VideoBIOS: 05.51.28.39.24
    [ 18.213] (--) NVIDIA(0): Interlaced video modes are supported on this GPU
    [ 18.213] (--) NVIDIA(0): Connected display device(s) on GeForce 6150 LE at PCI:0:5:0
    [ 18.213] (--) NVIDIA(0): HP Compaq FP1906 (CRT-0)
    [ 18.213] (--) NVIDIA(0): HP Compaq FP1906 (CRT-0): 350.0 MHz maximum pixel clock
    [ 18.214] (II) NVIDIA(0): Assigned Display Device: CRT-0
    [ 18.214] (==) NVIDIA(0):
    [ 18.214] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
    [ 18.214] (==) NVIDIA(0): will be used as the requested mode.
    [ 18.214] (==) NVIDIA(0):
    [ 18.214] (II) NVIDIA(0): Validated modes:
    [ 18.214] (II) NVIDIA(0): "nvidia-auto-select"
    [ 18.214] (II) NVIDIA(0): Virtual screen size determined to be 1280 x 1024
    [ 18.215] (--) NVIDIA(0): DPI set to (85, 86); computed from "UseEdidDpi" X config
    [ 18.215] (--) NVIDIA(0): option
    [ 18.215] (II) UnloadModule: "nouveau"
    [ 18.215] (II) Unloading /usr/lib64/xorg/modules/drivers/nouveau_drv.so
    [ 18.215] (II) UnloadModule: "nv"
    [ 18.215] (II) Unloading /usr/lib64/xorg/modules/drivers/nv_drv.so
    [ 18.215] (II) UnloadModule: "fbdev"
    [ 18.215] (II) Unloading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
    [ 18.215] (II) UnloadModule: "fbdevhw"
    [ 18.215] (II) Unloading /usr/lib64/xorg/modules/libfbdevhw.so
    [ 18.215] (II) UnloadModule: "vesa"
    [ 18.215] (II) Unloading /usr/lib64/xorg/modules/drivers/vesa_drv.so
    [ 18.215] (--) Depth 24 pixmap format is 32 bpp
    [ 18.227] (II) NVIDIA(0): Setting mode "nvidia-auto-select"
    [ 18.367] (II) Loading extension NV-GLX
    [ 18.424] (==) NVIDIA(0): Disabling shared memory pixmaps
    [ 18.424] (==) NVIDIA(0): Backing store disabled
    [ 18.424] (==) NVIDIA(0): Silken mouse enabled
    [ 18.424] (==) NVIDIA(0): DPMS enabled
    [ 18.424] (II) Loading extension NV-CONTROL
    [ 18.425] (II) Loading extension XINERAMA
    [ 18.425] (II) Loading sub module "dri2"
    [ 18.425] (II) LoadModule: "dri2"
    [ 18.425] (II) Reloading /usr/lib64/xorg/modules/extensions/libdri2.so
    [ 18.425] (II) NVIDIA(0): [DRI2] Setup complete
    [ 18.425] (==) RandR enabled
    [ 18.425] (II) Initializing built-in extension Generic Event Extension
    [ 18.425] (II) Initializing built-in extension SHAPE
    [ 18.425] (II) Initializing built-in extension MIT-SHM
    [ 18.425] (II) Initializing built-in extension XInputExtension
    [ 18.425] (II) Initializing built-in extension XTEST
    [ 18.425] (II) Initializing built-in extension BIG-REQUESTS
    [ 18.425] (II) Initializing built-in extension SYNC
    [ 18.425] (II) Initializing built-in extension XKEYBOARD
    [ 18.425] (II) Initializing built-in extension XC-MISC
    [ 18.425] (II) Initializing built-in extension SECURITY
    [ 18.425] (II) Initializing built-in extension XINERAMA
    [ 18.425] (II) Initializing built-in extension XFIXES
    [ 18.425] (II) Initializing built-in extension RENDER
    [ 18.425] (II) Initializing built-in extension RANDR
    [ 18.425] (II) Initializing built-in extension COMPOSITE
    [ 18.425] (II) Initializing built-in extension DAMAGE
    [ 18.434] (II) Initializing extension GLX
    [ 18.533] (II) XKB: reuse xkmfile /var/lib/xkb/compiled/server-8AA988DD479FAABEC4FC3CCCF4CC29B4948840B4.xkm
    [ 18.561] (II) config/udev: Adding input device Power Button (/dev/input/event4)
    [ 18.561] (**) Power Button: Applying InputClass "evdev keyboard catchall"
    [ 18.561] (**) Power Button: Applying InputClass "LocalKeyboard"
    [ 18.561] (II) LoadModule: "evdev"
    [ 18.570] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
    [ 18.570] (II) Module evdev: vendor="X.Org Foundation"
    [ 18.570] compiled for 1.9.3, module version = 2.6.0
    [ 18.570] Module class: X.Org XInput Driver
    [ 18.571] ABI class: X.Org XInput driver, version 11.0
    [ 18.571] (**) Power Button: always reports core events
    [ 18.571] (**) Power Button: Device: "/dev/input/event4"
    [ 18.573] (--) Power Button: Found keys
    [ 18.573] (II) Power Button: Configuring as keyboard
    [ 18.573] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
    [ 18.573] (**) Option "xkb_rules" "evdev"
    [ 18.573] (**) Option "xkb_model" "evdev"
    [ 18.573] (**) Option "xkb_layout" "fr"
    [ 18.573] (**) Option "xkb_options" "caps:capslock"
    [ 18.575] (II) XKB: reuse xkmfile /var/lib/xkb/compiled/server-822DF7B88A28A4BB0CB09438B400DAD4CE5FB768.xkm
    [ 18.589] (II) config/udev: Adding input device Power Button (/dev/input/event3)
    [ 18.590] (**) Power Button: Applying InputClass "evdev keyboard catchall"
    [ 18.590] (**) Power Button: Applying InputClass "LocalKeyboard"
    [ 18.590] (**) Power Button: always reports core events
    [ 18.590] (**) Power Button: Device: "/dev/input/event3"
    [ 18.592] (--) Power Button: Found keys
    [ 18.592] (II) Power Button: Configuring as keyboard
    [ 18.592] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
    [ 18.592] (**) Option "xkb_rules" "evdev"
    [ 18.592] (**) Option "xkb_model" "evdev"
    [ 18.592] (**) Option "xkb_layout" "fr"
    [ 18.592] (**) Option "xkb_options" "caps:capslock"
    [ 18.595] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/event1)
    [ 18.595] (**) Logitech USB Receiver: Applying InputClass "evdev pointer catchall"
    [ 18.595] (**) Logitech USB Receiver: always reports core events
    [ 18.595] (**) Logitech USB Receiver: Device: "/dev/input/event1"
    [ 18.597] (--) Logitech USB Receiver: Found 20 mouse buttons
    [ 18.597] (--) Logitech USB Receiver: Found scroll wheel(s)
    [ 18.597] (--) Logitech USB Receiver: Found relative axes
    [ 18.597] (--) Logitech USB Receiver: Found x and y relative axes
    [ 18.597] (II) Logitech USB Receiver: Configuring as mouse
    [ 18.597] (II) Logitech USB Receiver: Adding scrollwheel support
    [ 18.597] (**) Logitech USB Receiver: YAxisMapping: buttons 4 and 5
    [ 18.597] (**) Logitech USB Receiver: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
    [ 18.597] (II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: MOUSE)
    [ 18.598] (**) Logitech USB Receiver: (accel) keeping acceleration scheme 1
    [ 18.598] (**) Logitech USB Receiver: (accel) acceleration profile 0
    [ 18.598] (**) Logitech USB Receiver: (accel) acceleration factor: 2.000
    [ 18.598] (**) Logitech USB Receiver: (accel) acceleration threshold: 4
    [ 18.598] (II) Logitech USB Receiver: initialized for relative axes.
    [ 18.598] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/mouse0)
    [ 18.598] (II) No input driver/identifier specified (ignoring)
    [ 18.599] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/event2)
    [ 18.599] (**) Logitech USB Receiver: Applying InputClass "evdev keyboard catchall"
    [ 18.599] (**) Logitech USB Receiver: Applying InputClass "LocalKeyboard"
    [ 18.599] (**) Logitech USB Receiver: always reports core events
    [ 18.599] (**) Logitech USB Receiver: Device: "/dev/input/event2"
    [ 18.601] (--) Logitech USB Receiver: Found 1 mouse buttons
    [ 18.601] (--) Logitech USB Receiver: Found scroll wheel(s)
    [ 18.601] (--) Logitech USB Receiver: Found relative axes
    [ 18.601] (--) Logitech USB Receiver: Found absolute axes
    [ 18.601] (--) Logitech USB Receiver: Found keys
    [ 18.601] (II) Logitech USB Receiver: Configuring as mouse
    [ 18.601] (II) Logitech USB Receiver: Configuring as keyboard
    [ 18.601] (II) Logitech USB Receiver: Adding scrollwheel support
    [ 18.601] (**) Logitech USB Receiver: YAxisMapping: buttons 4 and 5
    [ 18.601] (**) Logitech USB Receiver: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
    [ 18.601] (II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: KEYBOARD)
    [ 18.601] (**) Option "xkb_rules" "evdev"
    [ 18.601] (**) Option "xkb_model" "evdev"
    [ 18.601] (**) Option "xkb_layout" "fr"
    [ 18.601] (**) Option "xkb_options" "caps:capslock"
    [ 18.601] (EE) Logitech USB Receiver: failed to initialize for relative axes.
    [ 18.601] (II) Logitech USB Receiver: initialized for absolute axes.
    [ 18.618] (II) config/udev: Adding input device HDA NVidia Headphone (/dev/input/event6)
    [ 18.618] (II) No input driver/identifier specified (ignoring)
    [ 18.619] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event0)
    [ 18.619] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
    [ 18.619] (**) AT Translated Set 2 keyboard: Applying InputClass "LocalKeyboard"
    [ 18.619] (**) AT Translated Set 2 keyboard: always reports core events
    [ 18.619] (**) AT Translated Set 2 keyboard: Device: "/dev/input/event0"
    [ 18.626] (--) AT Translated Set 2 keyboard: Found keys
    [ 18.626] (II) AT Translated Set 2 keyboard: Configuring as keyboard
    [ 18.626] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
    [ 18.626] (**) Option "xkb_rules" "evdev"
    [ 18.626] (**) Option "xkb_model" "evdev"
    [ 18.626] (**) Option "xkb_layout" "fr"
    [ 18.626] (**) Option "xkb_options" "caps:capslock"
    [ 18.627] (II) config/udev: Adding input device PC Speaker (/dev/input/event5)
    [ 18.627] (II) No input driver/identifier specified (ignoring)
    [ 19.116] (II) XKB: reuse xkmfile /var/lib/xkb/compiled/server-C37DE65A5B365D52A52EC1F2CB656087341C7EF8.xkm
    [ 24.817] (II) XKB: reuse xkmfile /var/lib/xkb/compiled/server-EBE8DEE1E011915E62D9B51DBB4183AA603A9FC1.xkm
    [ 381.829] (II) XKB: reuse xkmfile /var/lib/xkb/compiled/server-EBE8DEE1E011915E62D9B51DBB4183AA603A9FC1.xkm
    [ 10278.411] (II) XKB: reuse xkmfile /var/lib/xkb/compiled/server-EBE8DEE1E011915E62D9B51DBB4183AA603A9FC1.xkm
    [ 10291.325] (II) XKB: reuse xkmfile /var/lib/xkb/compiled/server-EBE8DEE1E011915E62D9B51DBB4183AA603A9FC1.xkm
    [ 10301.292] (II) XKB: reuse xkmfile /var/lib/xkb/compiled/server-EBE8DEE1E011915E62D9B51DBB4183AA603A9FC1.xkm
    [ 10318.065] (II) XKB: reuse xkmfile /var/lib/xkb/compiled/server-EBE8DEE1E011915E62D9B51DBB4183AA603A9FC1.xkm
    [ 10334.264] (II) XKB: reuse xkmfile /var/lib/xkb/compiled/server-EBE8DEE1E011915E62D9B51DBB4183AA603A9FC1.xkm
    [ 10352.641] (II) XKB: reuse xkmfile /var/lib/xkb/compiled/server-EBE8DEE1E011915E62D9B51DBB4183AA603A9FC1.xkm

  6. #6
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    1,918

    Default Re: Application windows entirely black when another one already displayed

    Have You tried disabling the KMS ?
    openSUSE 11.4 Release Notes

    One more remark You can use :
    SUSE Paste

    To paste the whole log output there. Just remember to change "Delete After" to never. It's set to 1 Week by default.

    Best regards,
    Greg
    Best regards,
    Greg

  7. #7
    Join Date
    Apr 2009
    Location
    France
    Posts
    34

    Default Re: Application windows entirely black when another one already displayed

    OK for Suse paste, I did not know this functionnality...

    For disabling KMS, I have added "nomodeset" to my menu.lst as follows:

    # Modified by YaST2. Last modification on Tue May 10 11:33:51 CEST 2011
    # THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader
    # Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader

    default 0
    timeout 8
    ##YaST - generic_mbr
    gfxmenu (hd0,0)/boot/message
    ##YaST - activate

    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title Desktop -- openSUSE 11.4 - 2.6.37.6-0.5
    root (hd0,0)
    kernel /boot/vmlinuz-2.6.37.6-0.5-desktop root=/dev/disk/by-id/ata-WDC_WD20EARS-00MVWB0_WD-WMAZA2934639-part1 resume=/dev/disk/by-id/ata-WDC_WD20EARS-00MVWB0_WD-WMAZA2934639-part2 splash=silent quiet showopts vga=0x31a nomodeset
    initrd /boot/initrd-2.6.37.6-0.5-desktop

    ###Don't change this comment - YaST2 identifier: Original name: failsafe###
    title Failsafe -- openSUSE 11.4 - 2.6.37.6-0.5
    root (hd0,0)
    kernel /boot/vmlinuz-2.6.37.6-0.5-desktop root=/dev/disk/by-id/ata-WDC_WD20EARS-00MVWB0_WD-WMAZA2934639-part1 showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe vga=0x31a
    initrd /boot/initrd-2.6.37.6-0.5-desktop

    ###Don't change this comment - YaST2 identifier: Original name: floppy###
    title Disquette
    rootnoverify (fd0)
    chainloader +1

    but the same problem still occurs (even after reboot).

  8. #8
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    1,918

    Default Re: Application windows entirely black when another one already displayed

    Quote Originally Posted by olyv View Post
    OK for Suse paste, I did not know this functionnality...

    For disabling KMS, I have added "nomodeset" to my menu.lst as follows:

    # Modified by YaST2. Last modification on Tue May 10 11:33:51 CEST 2011
    # THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader
    # Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader

    default 0
    timeout 8
    ##YaST - generic_mbr
    gfxmenu (hd0,0)/boot/message
    ##YaST - activate

    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title Desktop -- openSUSE 11.4 - 2.6.37.6-0.5
    root (hd0,0)
    kernel /boot/vmlinuz-2.6.37.6-0.5-desktop root=/dev/disk/by-id/ata-WDC_WD20EARS-00MVWB0_WD-WMAZA2934639-part1 resume=/dev/disk/by-id/ata-WDC_WD20EARS-00MVWB0_WD-WMAZA2934639-part2 splash=silent quiet showopts vga=0x31a nomodeset
    initrd /boot/initrd-2.6.37.6-0.5-desktop

    ###Don't change this comment - YaST2 identifier: Original name: failsafe###
    title Failsafe -- openSUSE 11.4 - 2.6.37.6-0.5
    root (hd0,0)
    kernel /boot/vmlinuz-2.6.37.6-0.5-desktop root=/dev/disk/by-id/ata-WDC_WD20EARS-00MVWB0_WD-WMAZA2934639-part1 showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe vga=0x31a
    initrd /boot/initrd-2.6.37.6-0.5-desktop

    ###Don't change this comment - YaST2 identifier: Original name: floppy###
    title Disquette
    rootnoverify (fd0)
    chainloader +1

    but the same problem still occurs (even after reboot).
    And I assume You have tried this without the nomodset boot attribute as well ?

    Have You tried editing this file ?
    Code:
    /etc/X11/xorg.conf.d/50-device.conf
    and adding a line there that says :
    Code:
    Driver "nv"
    Best regards,
    Greg
    Best regards,
    Greg

  9. #9
    Join Date
    Apr 2009
    Location
    France
    Posts
    34

    Default Re: Application windows entirely black when another one already displayed

    Yes, I have tried with and without the "nomodeset" option: same behaviour.
    I have tried to add 'Driver "nv"' to my /etc/X11/xorg.conf.d/50-device.conf with the "nomodeset" option in menu.lst: the system does not restart after reboot...
    How can I uninstall the proprietary nvidia driver and go back to the "nv" driver (if it is what you want me to do) ? With Yast ?

  10. #10
    Will Honea NNTP User

    Default Re: Application windows entirely black when another one already displayed

    olyv wrote:

    >
    > Hello all.
    > I am using OpenSuse 11.4 (64 bits) with KDE 4.6.0. My graphic card is
    > nVidia Ge Force 6150 LE with the nVidia proprietary 2D driver (called
    > "nVidia" on the system information page).
    > A strange graphic behaviour occurs until a few days: when an
    > application (eg Firefox) is already running and when I try to open
    > another application (eg Thunderbird or Dolphin), the associated window
    > is completely black except the upper bar mentionning the name of the
    > application. It seems that this problem occurs only when an application
    > is already running with its window displayed. It is necessary to close
    > this application in order to run correctly another one. It is impossible
    > to run correctly more than one application.
    > Any idea please ?
    > Thanks a lot for your answers.


    I ran into this on a Compaq using the same Nvidia chipset. Disabling
    desktop effects seems to have fixed it for that case.

    --
    Will Honea

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •