Results 1 to 6 of 6

Thread: This kernel requires an x86_64 cpu, but only detected an i686 cpu ..!!!!

  1. #1

    Exclamation This kernel requires an x86_64 cpu, but only detected an i686 cpu ..!!!!

    I'm trying to install openSuse 11.4 64-bit in my VMWare Workstation 7.1 but it gives me this error : " This kernel requires an x86_64 cpu, but only detected an i686 cpu ...".

    I have a laptop with Windows 7 64-bit, 4Gb Ram, Intel P6200 2.13 GHz ... ect.
    I have enabled and disabled AT-x Virtualization in BIOS but its still the same problem.

  2. #2
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: This kernel requires an x86_64 cpu, but only detected an i686 cpu ..!!!!

    Your VMWare is not emulating a 64-bit processor that's all. It makes no difference what the real processor is, what matters is the emulation software. Maybe there's a way to configure VMWare to do that, or maybe not.

  3. #3
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: This kernel requires an x86_64 cpu, but only detected an i686 cpu ..!!!!

    Go to vmware.com and search for "Hardware and firmware requirements for 64-
    bit Guest Operating Systems", this will give you some articles from the
    knowledge base and you should check that your system meets the requirements.
    There is also a link to a tool in the first article which tests your cpu for
    compatibility.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  4. #4

    Default Re: This kernel requires an x86_64 cpu, but only detected an i686cpu ..!!!!

    Or just install 32-bit opensuse?

  5. #5
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: This kernel requires an x86_64 cpu, but only detected an i686 cpu ..!!!!

    Dave Howorth wrote:

    > Or just install 32-bit opensuse?

    That would have been my next suggestion too ;-)

    @krisidmisso: Did you check that you can install any other operating system
    which is 64bit in your vmware? And what is the point to install a 64bit
    openSUSE in the vmware on your machine, you only have 4GB in your host
    system and I doubt you will assign all your physical RAM to the guest system?
    So Dave's idea to use 32bit openSUSE is of course a good idea.

    With AT-x virtualization in BIOS do you mean VT instead of AT?
    With VT-x enabled it should work, if you want you can try if you can install
    the 64bit openSUSE on Virtual Box instead of vmware.
    Just download the windows installer for it

    http://download.virtualbox.org/virtu...-71778-Win.exe

    and give it a try. See if that works as an alternative if vmware does not work
    with your cpu for 64bit guests.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce 9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia ION | 3GB Ram

  6. #6

    Default Re: This kernel requires an x86_64 cpu, but only detected an i686 cpu ..!!!!

    Sorry for the "A"T-x mistake.Yes i meant VT-x. I tried VirtualBox after uninstalling VMWare but its the same problem. I think that even 2GB of ram should be enough to run openSUSE and open some apps that don't require much resources. Installing the 32bit system isn't a problem, its simple. I will search again for the CPU compatibility tool in VMware since i didn't find it the first time i searched. Thank you all for the quick replies. I hope to solve this problem

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •