Results 1 to 3 of 3

Thread: Can't enable wireless

  1. #1

    Default Can't enable wireless

    Hi , i'm comletely new to opensuse, but i used to use ubuntu before.
    I can't enable my wireless , sorry if my post is gonna to confuse you but i'm at a loss rightnow after 10 hours trying several linux distribution and configuring and getting familiar with opensuse. Everything was perfect fine but the last thing that's most important that i forgot is the wireless.
    Because in ubuntu mn can just install with one click , there is a thing so called checking all your hardware etc..

    So i tried to install madwifi and madwifi-kmp-default version r4136_k2.6.37.1_1.2-2.1 via YaST , even though my kernel linux 2.6.37.6-0.5-default (didn't find in Yast version that matched) and did 2 command
    sudo /sbin/modprobe ath_pci
    sudo /sbin/modprobe -l | grep ath
    Code:
    kernel/drivers/net/wireless/ath/ath5k/ath5k.ko
    kernel/drivers/net/wireless/ath/ath9k/ath9k.ko
    kernel/drivers/net/wireless/ath/ath9k/ath9k_hw.ko
    kernel/drivers/net/wireless/ath/ath9k/ath9k_common.ko
    kernel/drivers/net/wireless/ath/ath9k/ath9k_htc.ko
    kernel/drivers/net/wireless/ath/ar9170/ar9170usb.ko
    kernel/drivers/net/wireless/ath/carl9170/carl9170.ko
    kernel/drivers/net/wireless/ath/ath.ko
    kernel/drivers/md/multipath.ko
    kernel/drivers/md/dm-multipath.ko
    kernel/drivers/staging/ath6kl/ath6kl.ko
    kernel/drivers/bluetooth/ath3k.ko
    weak-updates/updates/ath/ath_pci.ko
    weak-updates/updates/ath_rate/onoe/ath_rate_onoe.ko
    weak-updates/updates/ath_rate/amrr/ath_rate_amrr.ko
    weak-updates/updates/ath_rate/minstrel/ath_rate_minstrel.ko
    weak-updates/updates/ath_rate/sample/ath_rate_sample.ko
    weak-updates/updates/ath_hal/ath_hal.ko
    Still nothing happened

    Here is some info
    sudo /sbin/lspci
    ...
    03:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

    sudo /usr/sbin/iwconfig
    Code:
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    wlan0     IEEE 802.11bgn  ESSID:off/any  
              Mode:Managed  Access Point: Not-Associated   Tx-Power=off   
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
    sudo /usr/sbin/iwlist scan
    Code:
    lo        Interface doesn't support scanning.
    
    eth0      Interface doesn't support scanning.
    
    wlan0     Interface doesn't support scanning : Network is down
    The last thing i was try is some random steps i read somewhere else
    $ sudo zypper in rfkill
    $ rfkill list
    $ sudo /usr/sbin/rfkill list
    Code:
    0: ideapad_wlan: Wireless LAN
    	Soft blocked: yes
    	Hard blocked: no
    1: ideapad_bluetooth: Bluetooth
    	Soft blocked: yes
    	Hard blocked: no
    2: ideapad_killsw: Wireless LAN
    	Soft blocked: yes
    	Hard blocked: no
    3: acer-wireless: Wireless LAN
    	Soft blocked: yes
    	Hard blocked: no
    4: phy0: Wireless LAN
    	Soft blocked: yes
    	Hard blocked: yes

  2. #2
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: Can't enable wireless

    On 05/16/2011 08:06 AM, Suseo wrote:
    >
    > Hi , i'm comletely new to opensuse, but i used to use ubuntu before.
    > I can't enable my wireless , sorry if my post is gonna to confuse you
    > but i'm at a loss rightnow after 10 hours trying several linux
    > distribution and configuring and getting familiar with opensuse.
    > Everything was perfect fine but the last thing that's most important
    > that i forgot is the wireless.
    > Because in ubuntu mn can just install with one click , there is a thing
    > so called checking all your hardware etc..
    >
    > So i tried to install madwifi and madwifi-kmp-default version
    > r4136_k2.6.37.1_1.2-2.1 via YaST , even though my kernel linux
    > 2.6.37.6-0.5-default (didn't find in Yast version that matched) and did
    > 2 command
    > sudo /sbin/modprobe ath_pci
    > sudo /sbin/modprobe -l | grep ath
    >
    > Code:
    > --------------------
    > kernel/drivers/net/wireless/ath/ath5k/ath5k.ko
    > kernel/drivers/net/wireless/ath/ath9k/ath9k.ko
    > kernel/drivers/net/wireless/ath/ath9k/ath9k_hw.ko
    > kernel/drivers/net/wireless/ath/ath9k/ath9k_common.ko
    > kernel/drivers/net/wireless/ath/ath9k/ath9k_htc.ko
    > kernel/drivers/net/wireless/ath/ar9170/ar9170usb.ko
    > kernel/drivers/net/wireless/ath/carl9170/carl9170.ko
    > kernel/drivers/net/wireless/ath/ath.ko
    > kernel/drivers/md/multipath.ko
    > kernel/drivers/md/dm-multipath.ko
    > kernel/drivers/staging/ath6kl/ath6kl.ko
    > kernel/drivers/bluetooth/ath3k.ko
    > weak-updates/updates/ath/ath_pci.ko
    > weak-updates/updates/ath_rate/onoe/ath_rate_onoe.ko
    > weak-updates/updates/ath_rate/amrr/ath_rate_amrr.ko
    > weak-updates/updates/ath_rate/minstrel/ath_rate_minstrel.ko
    > weak-updates/updates/ath_rate/sample/ath_rate_sample.ko
    > weak-updates/updates/ath_hal/ath_hal.ko
    > --------------------
    >
    >
    > Still nothing happened
    >
    > Here is some info
    > sudo /sbin/lspci
    > ..
    > 03:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless
    > Network Adapter (PCI-Express) (rev 01)
    >
    > sudo /usr/sbin/iwconfig
    >
    > Code:
    > --------------------
    > lo no wireless extensions.
    >
    > eth0 no wireless extensions.
    >
    > wlan0 IEEE 802.11bgn ESSIDff/any
    > Mode:Managed Access Point: Not-Associated Tx-Power=off
    > Retry long limit:7 RTS thrff Fragment thrff
    > Encryption keyff
    > Power Managementff
    > --------------------
    >
    > sudo /usr/sbin/iwlist scan
    >
    > Code:
    > --------------------
    > lo Interface doesn't support scanning.
    >
    > eth0 Interface doesn't support scanning.
    >
    > wlan0 Interface doesn't support scanning : Network is down
    >
    > --------------------
    >
    > The last thing i was try is some random steps i read somewhere else
    > $ sudo zypper in rfkill
    > $ rfkill list
    > $ sudo /usr/sbin/rfkill list
    >
    > Code:
    > --------------------
    > 0: ideapad_wlan: Wireless LAN
    > Soft blocked: yes
    > Hard blocked: no
    > 1: ideapad_bluetooth: Bluetooth
    > Soft blocked: yes
    > Hard blocked: no
    > 2: ideapad_killsw: Wireless LAN
    > Soft blocked: yes
    > Hard blocked: no
    > 3: acer-wireless: Wireless LAN
    > Soft blocked: yes
    > Hard blocked: no
    > 4: phy0: Wireless LAN
    > Soft blocked: yes
    > Hard blocked: yes


    The "Hard blocked: yes" indicates that your wireless switch is off. You need to
    know why.

  3. #3

    Default Re: Can't enable wireless

    rfkill all
    Code:
    0: acer-wireless: Wireless LAN
    	Soft blocked: yes
    	Hard blocked: no
    1: ideapad_wlan: Wireless LAN
    	Soft blocked: no
    	Hard blocked: no
    2: ideapad_bluetooth: Bluetooth
    	Soft blocked: yes
    	Hard blocked: no
    3: ideapad_killsw: Wireless LAN
    	Soft blocked: yes
    	Hard blocked: no
    4: phy0: Wireless LAN
    	Soft blocked: no
    	Hard blocked: no
    wireless light turned on ,
    enable wireless line didn't grey anymore , but when i click at this line to enable nothing happened.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •