Results 1 to 4 of 4

Thread: KVM VM stops instead of reboot

  1. #1

    Default KVM VM stops instead of reboot

    I am using opensuse 11.4, libvirtd 0.8.8, virt-manger 0.8.5.

    If I want to reboot a virtual machine (typing 'reboot -n' in the VMs console) the virtual machine stops insteads of reboot.

    The virtual machine is also opensuse 11.4
    Afterwards I have to click 'run' in virt-manager.

    Then the vm starts and remains running til the next reboot.

    If I try to reboot from comandline by typing 'virsh reboot <vmname>' I get the message

    error: Failed to reboot domain <vmname>
    error: this function is not supported by the connection driver: virDomainReboot
    What is wrong with my setup?

  2. #2

    Default AW: KVM VM stops instead of reboot

    Maybe this infos could be helpful. In my vm xml-file I've made the following settings:

    <on_poweroff>destroy</on_poweroff>
    <on_reboot>restart</on_reboot>
    <on_crash>restart</on_crash>

    When I start the vm via virt-manager I find the following entries in the vm log-file:

    2011-05-16 16:34:18.834: starting up
    LC_ALL=C PATH=/bin:/sbin:/usr/bin:/usr/sbin HOME=/ QEMU_AUDIO_DRV=none /usr/bin/qemu-kvm -S -M pc-0.14 -enable-kvm -m 2048 -smp 2,sockets=2,cores=1,threads=1 -name kv-test-opensuse11.4-clone -uuid a7f1d211-476b-d19a-fc72-b7fcbbf849ee -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/kv-test-opensuse11.4-clone.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime -no-reboot -boot c -drive file=/virtfs/test-opensuse-clone,if=none,id=drive-virtio-disk0,boot=on,format=raw -device virtio-blk-pci,bus=pci.0,addr=0x4,drive=drive-virtio-disk0,id=virtio-disk0 -drive file=/virtfs/openSUSE-11.4-NET-x86_64-clone.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -netdev tap,fd=21,id=hostnet0 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:00:be:f6:da,bus=pci.0,addr=0x3 -usb -vnc 127.0.0.1:0 -vga cirrus -incoming tcp:0.0.0.0:49153 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x5

    Could this be the conflict and how can I avoid it? I manage my vm with virt-manger.

    If I reboot my vm in virt-manager (clicking the reboot button) a correct reboot occurs.

  3. #3

    Default Re: AW: KVM VM stops instead of reboot

    That's it (see man qemu-kvm).

  4. #4

    Default Re: AW: KVM VM stops instead of reboot

    What about unchecking 'Force Poweroff' in virt-manager Feedback preferences? (just guessing).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •