How do I enable Wake on USB under openSUSE 11.4 (64 bits)?

The BIOS suspend mode is set to S3 and the BIOS option "Resume by USB (S3/S4)" is set to enabled.
The cat /proc/acpi/wakeup command gets me:
Code:
Device  S-state   Status   Sysfs node
SMB0      S4    *disabled  pci:0000:00:03.2
USB0      S4    *disabled  pci:0000:00:04.0
USB2      S4    *disabled  pci:0000:00:04.1
US15      S4    *disabled  pci:0000:00:06.0
US12      S4    *disabled  pci:0000:00:06.1
PBB0      S4    *disabled  pci:0000:00:09.0
HDAC      S4    *disabled  pci:0000:00:08.0
XVR0      S4    *disabled  pci:0000:00:0c.0
XVR1      S4    *disabled  
P0P5      S4    *disabled  
P0P7      S4    *disabled  pci:0000:00:16.0
P0P8      S4    *disabled  pci:0000:00:17.0
P0P9      S4    *disabled  pci:0000:00:18.0
NUCR      S4    *disabled  pci:0000:00:15.0
PWRB      S4    *enabled
I tried following some ubuntu guide but that didn't work. The sudo update-rc.d wake.sh defaults command doesn't work. From what I've understood the scripts just needs to be loaded on boot so I attempted to do that via YaST > System Services, it takes forever to load and when it finally does it can't enable the script.