Results 1 to 4 of 4

Thread: KDE desktop effects freeze the desktop ...

  1. #1
    Join Date
    Jun 2008
    Location
    Portugal
    Posts
    234

    Default KDE desktop effects freeze the desktop ...

    Hi,


    I have just installed 11.4 64 bits in a laptop and up dated to the latest versions on the standard repositories.
    I am using KDE 4.
    I have installed from the standard repositories all Nvidia drivers.
    My laptop uses a Nvidia Gforce 8200 M.

    My problem is that I have selected the flip switch effect for switching multiple windows.
    When I do that the laptop almost always freezes the desktop, actually first there is a strange freeze when the desktop window on the front (the one switched to) appears out of focus and the desktop is frozen and some parts missing ... (base bar example).
    After some seconds the image focus normally and a message pop-up informs that the effects have been disabled (they can be resume by alt+shift + F12).

    what is happening ?
    Is this a bug of KDE 4?


    Regards.

  2. #2
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    1,918

    Default Re: KDE desktop effects freeze the desktop ...

    Most liekly the graphics card driver bug or X server bug. You can check "/var/log/Xorg.0.log" for (EE) entries to see what might be wrong.

    Have You read this already ? :
    openSUSE Graphic Card Practical Theory Guide for Users

    If not please do read it as this will greatly clarify things. What might also help is installing the latest drivers from the nVidia site as the drivers in the repos usually are outdated. See the link above on how to do this.

    Best regards,
    Greg
    Best regards,
    Greg

  3. #3
    Join Date
    Jun 2008
    Location
    Portugal
    Posts
    234

    Default Re: KDE desktop effects freeze the desktop ...

    Hi,


    Quote Originally Posted by glistwan View Post
    Most liekly the graphics card driver bug or X server bug. You can check "/var/log/Xorg.0.log" for (EE) entries to see what might be wrong.

    Have You read this already ? :
    openSUSE Graphic Card Practical Theory Guide for Users

    If not please do read it as this will greatly clarify things. What might also help is installing the latest drivers from the nVidia site as the drivers in the repos usually are outdated. See the link above on how to do this.

    Best regards,
    Greg
    Thanks for your sugestion and I also believe the problem is the drivers.
    In the #suse freenode irc chat a fellow user pointed out that the Gforce 8200 M does cause a lot of problems, he suggested also to install the latest drivers, he actually uses a Beta version of the Nvidia drivers.
    Like me he is using kernel 2.6.37.6-0.5-desktop
    KDE 4.6.0
    and unlike me he uses Nvidia driver 270.41.03 (Beta)

    Anyway if more people would have the same problem we might pinpoint the problem.
    Last time I checked the X logs it did not show anything out of the usual ...
    Right now I have no access to the laptop but as soon as I can i will make a new tour over the logs ...

    Best regards.

  4. #4
    Join Date
    Jun 2008
    Location
    Portugal
    Posts
    234

    Default Re: KDE desktop effects freeze the desktop ...

    GO IT!!!

    I was just losing my temper all morning when I got the Problem "solved".
    It MUST be a software bug.
    I up-dated all Nvidia drivers to the latest version and the like ...
    But the solution is Simple:

    Just Enabled the FPS effect ... the windows shows on the monitor and then that's it !!!
    Fixed it !!!

    this is a good info for the folk with this same problem and it must be a bug ...


    Regards.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •