Results 1 to 8 of 8

Thread: why Num Lock key is disabled?

  1. #1
    Join Date
    May 2011
    Location
    EU
    Posts
    32

    Default why Num Lock key is disabled?

    11.4 KDE
    I have to enable the Num Lock key everytime I boot opensuse, any fix?

  2. #2

    Default Re: why Num Lock key is disabled?

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    If your system starts with it off then something needs to turn it on. My
    numlock is on when I get logged in which is probably what you're after. I
    think this is remembered by the system by default, and I found a setting
    in gconf-editor that looks promising by searching for 'numlock' within
    gconf-editor:

    /desktop/gnome/peripherals/keyboard/remember_numlock_state

    Not sure that is the setting, but it sounds right and it's enabled on my
    laptop.

    Good luck.





    On 05/13/2011 06:36 AM, gandaran wrote:
    >
    > 11.4 KDE
    > I have to enable the Num Lock key everytime I boot opensuse, any fix?
    >
    >

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.15 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

    iQIcBAEBAgAGBQJNzS0+AAoJEF+XTK08PnB5vLMP/iyCofZe3oAMXm154TRuk/AF
    4PrPK+cdZaKfYN2mhjh3o5wifFLSN0xSsc9+VLbeweSZz4H8nF/Jtizon+eUzHC7
    Hu6q07XkjULIVmCz/zxe1rYZw15EaiOCaTeZlspjZvVDuFXdmJnZSURGCSoSPfN5
    tlMpWheJujaRV5YJ9+bg/Mu6jGxgGNVirs+YQuTF9QMzLryiP/S22fDaf0jrnI25
    272YRN+NnMFcjAJ6e9hFvOnrN4DMafGsHMZUKQv3Lwxq69+IWywXlH2IhBbUS/uL
    WCDVXB7pMdYDpceNdd5MFL4jFH6LJBqkkb5e/i6umX+gQZPkl22Vlh2s6hoJtXCZ
    fmO7ZsdbtMHAmricAaowqvQn6I/n3PldcAXVddGVdBltrvpPHkuzCagaDfDQOXFP
    y3228+21oc6yitX7ZBBrCOFJ7iVyz5tRu5RLmyEGvReCMhlhH4zj8w4K60IVpjc/
    tTcQPAT5+ojetLk2CwoO452UCcYmQD7+hKzucTjSsFVAd7wFIYscLbls+9KNHRGM
    ztQSIeAcK3GDWjFTuyikKeejMR0zcvuKfl8vVKBXWSqLHXju8+oFWGbKCH0xNIdX
    1xAafE/ZyoVmylLwg76LIPF8kWkUCFU1uDKepiOI9P2m882Ss21hZoDAc2hMr/MW
    C3JixWX68NmQ2ppskY9j
    =uD1q
    -----END PGP SIGNATURE-----

  3. #3
    Join Date
    May 2011
    Location
    EU
    Posts
    32

    Default Re: why Num Lock key is disabled?

    I'm on KDE, so whats KDE equivalent of gnome gconf-editor?

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,684
    Blog Entries
    3

    Default Re: why Num Lock key is disabled?

    Personal Settings --> Input Devices --> Keyboard

    There's a numlock setting with choices between "Turn on", "Turn off" and "leave unchanged". I have it set at "leave unchanged" because the system BIOS already sets it on at boot. But if I were to turn it off with the numlock key, logout, then login again, it might start turned off with that setting.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  5. #5
    Join Date
    May 2011
    Location
    EU
    Posts
    32

    Default Re: why Num Lock key is disabled?

    Quote Originally Posted by nrickert View Post
    Personal Settings --> Input Devices --> Keyboard

    There's a numlock setting with choices between "Turn on", "Turn off" and "leave unchanged". I have it set at "leave unchanged" because the system BIOS already sets it on at boot. But if I were to turn it off with the numlock key, logout, then login again, it might start turned off with that setting.
    got it!
    thanks

  6. #6
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: why Num Lock key is disabled?

    Till gnome 2.x num lock worked fine on my desktop.But though i have set org.gnome.settings-daemon.peripherals.keyboard.remember-numlock-state to true/checked gnome 3.X is not able to do the job correctly.Kindly advise
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  7. #7
    Join Date
    Jun 2010
    Location
    Bedfordshire, United Kingdom
    Posts
    116

    Default Re: why Num Lock key is disabled?

    Hi,

    You can also set a general Linux Num Lock preference via YaST2 by navigating to /etc/sysconfig Editor|Hardware|Keyboard|KBD_NUMLOCK.

    Choose your preference there and it will be adopted at boot.

    Regards,
    Neil Darlow

  8. #8
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: why Num Lock key is disabled?

    Do we have a bug in GNOME3 here? Tried chaning values in /etc/sysconfigeditor, gconf-editor, no changes, NUMLOCK is still off after login.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •