Results 1 to 4 of 4

Thread: yelp fails to start: Could not initialize gecko!

  1. #1

    Default yelp fails to start: Could not initialize gecko!

    On 2 fresh updated 11.4 (32 and 64 bit).

    Code:
    # yelp
    Could not initialize gecko!
    
    # rpm -qa | grep mozilla
    mozilla-xulrunner20-gnome-2.0.1-0.2.2.i586
    mozilla-nss-devel-3.12.9-4.3.i586
    mozilla-nss-certs-3.12.9-4.3.i586
    mozilla-xulrunner20-2.0.1-0.2.2.i586
    mozilla-js20-2.0.1-0.2.2.i586
    mozilla-nss-3.12.9-4.3.i586
    mozilla-nspr-4.8.7-4.4.i586
    mozilla-nspr-devel-4.8.7-4.4.i586
    ca-certificates-mozilla-1.70-3.1.noarch
    mozilla-kde4-integration-0.6.3-3.1.i586
    Found this bug report:

    https://bugzilla.novell.com/show_bug.cgi?id=656953

    But don't know how to solve it.

    * I'm not using the mozilla repo.

  2. #2

    Default Re: yelp fails to start: Could not initialize gecko!

    A patch was submitted and accepted 4 days ago: https://build.opensuse.org/request/show/69983

    As I couldn't find the rpm (?), I branched the package (https://build.opensuse.org/package/s...ease_try_again), compiled it and published it in my repo. You'll tell me if it was right (or wrong). Anyway, yelp is working now.


  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: yelp fails to start: Could not initialize gecko!

    Good.
    But it means nothing to me I'm afraid
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4

    Default Re: yelp fails to start: Could not initialize gecko!

    Quote Originally Posted by caf4926 View Post
    Good.
    But it means nothing to me I'm afraid
    It means that yelp expects version 2.0 of xulrunner, while version 2.0.1 is installed and because of that could not launch firefox, with the consequence that the help browser for Gnome doesn't work. I don't know how long it will take for this package to move from update:test into update. The bug has been fixed but not published yet. Maybe it's just a matter of hours ... or days (?) ... or maybe nobody cares because the next version of yelp will be based on webkit.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •