Results 1 to 5 of 5

Thread: patch: gstreamer-0_10-plugin-hal-4496.noarch conflicts

  1. #1
    Join Date
    Dec 2008
    Location
    Italy
    Posts
    132

    Default patch: gstreamer-0_10-plugin-hal-4496.noarch conflicts

    OK so now VLC is back again in Packman repos, but ... now I've got this issue:

    Code:
    #### YaST2 conflicts list - generated 2011-05-13 07:58:10 ####
    
    patch:gstreamer-0_10-plugin-hal-4496.noarch conflicts with gstreamer-0_10-plugins-good-lang.noarch < 0.10.28-1.2.1 provided by gstreamer-0_10-plugins-good-lang-0.10.28-1.pm.40.3.noarch
    
        [ ] Following actions will be done:
    install gstreamer-0_10-plugins-good-lang-0.10.28-1.2.1.noarch (with vendor change)
      http://packman.links2linux.de  -->  openSUSE
    install gstreamer-0_10-plugins-good-0.10.28-1.2.1.i586 (with vendor change)
      http://packman.links2linux.de  -->  openSUSE
        [ ] do not install patch:gstreamer-0_10-plugin-hal-4496.noarch
    
    
    
    
    #### YaST2 conflicts list END ###
    Of course (as always) I had "switched system packages to the version in packman repository" and surely this is the origin of the issue.

    So the question is:
    is it safe to apply this patch through "vendor change", but immediately after redo "switch system packages to packman"?

    TNX in advance.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: patch: gstreamer-0_10-plugin-hal-4496.noarch conflicts

    Just ignore the patch and keep the packman version
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Dec 2008
    Location
    Italy
    Posts
    132

    Default Re: patch: gstreamer-0_10-plugin-hal-4496.noarch conflicts

    Good to know: thanks.
    But ... how to stop yast prompting to apply the patch all the time?
    (that's why I said "...immediately after redo switch system packages to packman").

    Maybe packman will fix this in a few days through a different version numbering schema?

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: patch: gstreamer-0_10-plugin-hal-4496.noarch conflicts

    Quote Originally Posted by acez View Post
    Good to know: thanks.
    But ... how to stop yast prompting to apply the patch all the time?
    (that's why I said "...immediately after redo switch system packages to packman").

    Maybe packman will fix this in a few days through a different version numbering schema?
    Well I don't use the updater applet, I have it set to Never.

    If, as it sounds you have, you have switched to packman already, as I have.
    Simply use:
    Code:
    zypper up
    It will install updates and patches, but not patches that break your switch rule.

    Just try:
    Code:
    zypper lu
    It should show no updates
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Dec 2008
    Location
    Italy
    Posts
    132

    Default Re: patch: gstreamer-0_10-plugin-hal-4496.noarch conflicts

    Yes, it's as you say.

    TNX

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •