Results 1 to 9 of 9

Thread: Avogadro 1.0.1 does not work with opensuse 11.4

  1. #1

    Default Avogadro 1.0.1 does not work with opensuse 11.4

    Hi folks,

    when trying to launch Avogadro 1.0.1_x.x on opensuse 11.4, I get:
    Code:
    The _C_API object in the sip python module is invalid.
    Could not initialize SIP API !
    terminate called after throwing an instance of 'boost::python::error_already_set'
    And the program does not launch!

    It is apparently not restricted to opensuse 11.4 but also to other recent Linux systems.
    On Avagodro's site, this problem is claimed to be solved in 1.0.2 (and 1.0.3 is now out), but I could not find anything else than 1.0.1_x.x versions for opensuse 11.4.
    Could someone be kind enough to make a new 1.0.3 package so that Avogadro works on opensuse 11.4?

  2. #2
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    2,919

    Default Απ: Avogadro 1.0.1 does not work with opensuse 11.4

    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1070 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  3. #3

    Default Re: Avogadro 1.0.1 does not work with opensuse 11.4

    Thanks for your answer Stamostolias.
    I should have mentioned that it was one of my sources when writing that "On Avagodro's site, this problem is claimed to be solved in 1.0.2 ".
    Unfortunatly this bug report does not say anything else than it should have been settled in 1.0.2.
    If you google the error message in my post, you will see that it was also the case for other recent distributions.
    (Pb of SIP with the move from Python 2.6 to Python 2.7 ?)

  4. #4
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    2,919

    Default Απ: Re: Avogadro 1.0.1 does not work with opensuse 11.4

    Quote Originally Posted by MD25 View Post
    Thanks for your answer Stamostolias.
    I should have mentioned that it was one of my sources when writing that "On Avagodro's site, this problem is claimed to be solved in 1.0.2 ".
    Unfortunatly this bug report does not say anything else than it should have been settled in 1.0.2.
    If you google the error message in my post, you will see that it was also the case for other recent distributions.
    (Pb of SIP with the move from Python 2.6 to Python 2.7 ?)
    Could you see which version of python do you have?
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1070 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  5. #5

    Default Re: Απ: Re: Avogadro 1.0.1 does not work with opensuse 11.4

    Quote Originally Posted by stamostolias View Post
    Could you see which version of python do you have?
    Python 2.7 (r27:82500, Aug 07 2010, 16:54:59) [GCC]

    I think the best way for me would be to recompile Avogadro 1.0.3 from source, but I do not have the time to do so at the moment.

  6. #6
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    2,919

    Default Απ: Re: Απ: Re: Avogadro 1.0.1 does not work with opensuse 11.4

    Try to install Ipython through yast. Maybe this is general.
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1070 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  7. #7

    Default Re: Απ: Re: Απ: Re: Avogadro 1.0.1 does not work with opensuse 11.4

    Ipython is already installed

  8. #8

    Default Re: Avogadro 1.0.1 does not work with opensuse 11.4

    Finally I decided to give a try to the compilation from source, ready to stop in case of any problem (I have had quite a lot for versions before the 1.0.0).
    This time it worked without any problem and after less than 10 mn I have had Avogadro 1.0.3 working
    (libeigen2-devel was already installed from obs://build.opensuse.org/KDE)

    => I encourage competent people to make a new package for Avogadro/opensuse 11.4.

    I tag the thread as solved

  9. #9
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    2,919

    Default Απ: Re: Avogadro 1.0.1 does not work with opensuse 11.4

    Because I am programmer I will try to connect the new python version with Avogadro.
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1070 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •