Results 1 to 8 of 8

Thread: flash player not working in fire fox 4.0.1

  1. #1

    Default flash player not working in fire fox 4.0.1

    hi all i need some help big time. I’m running open suse 11.4 with gnome desk top.the flash player in fire fox 4.0.1 is installed but i still can't get any you tube video’s to work or any video’s for that mater.i did in stall an add-on called flash -aid. and not sure what happen. so i uninstalled the add-on and un installed flash player a couple of times and reinstalled it.and i still have no way to see any video's at all. any help is appreciated .thanks in advance.

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: flash player not working in fire fox 4.0.1

    aburroughs92
    hi all i need some help big time. I’m running open suse 11.4 with gnome desk top.the flash player in fire fox 4.0.1 is installed but i still can't get any you tube video’s to work or any video’s for that mater.i did in stall an add-on called flash -aid. and not sure what happen. so i uninstalled the add-on and un installed flash player a couple of times and reinstalled it.and i still have no way to see any video's at all. any help is appreciated .thanks in advance.
    aburroughs92, look at message #84 in this thread to see if this might help you out:

    Firefox on openSUSE 11.4 plays film clips badly

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3

    Default Re: flash player not working in fire fox 4.0.1

    thanks jdmcdaniel3. i have tried this one before but i can't get the flashplayer.so in the right place.and when i go to do the command line for the 0ld i get nothing.is there any other way to do that in the command line? when i do the top line it works but when i go to use the other command line that is where i get in to trouble. thanks

  4. #4

    Default Re: flash player not working in fire fox 4.0.1

    sorry i just noticed that I’m missing a plug in.the wrapper one.could this be the problem? if so how do i get the plug -in? thanks for your help.and is the gnash video player plug -in any good? or is adobe better.thanks ...

  5. #5
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: flash player not working in fire fox 4.0.1

    Lets look at each step as one of them is failing you.

    1. Download old driver from: http://itsyourpc.org/bruce/files/libflashplayer.so (Thanks to brucecadieux)

    When I click on the above link, the file libflashplayer.so is copied to my /home/username/Downloads also refered to as ~/Downloads. You should be able to load up a file manager like Dolphin, look in the Downloads folder and see if it is there. You can use the following terminal command to see if it is there:

    Code:
    dir ~/Downloads/libflashplayer.so
    Please confirm that you have downloaded the proper file to the correct location.

    2. From Terminal run the command:
    Code:
    sudo zypper rm pullin-flash-player flash-player nspluginwrapper
    This command removes all older flash files from YaST. If you run this command successfully and don't put the file listed above in the right place, flash will not work at all. You can confirm that you unloaded flash by running:

    YaST / Software / Software Management and search on the term flash. If you find nothing loaded, then you have removed the old flash files. Please confirm that you have removed the flash files by looking through YaST as suggested above.

    3. Copy the new Flash File you downloaded to the proper location. Open up a terminal session and type the command:

    Code:
    sudo cp ~/Downloads/libflashplayer.so /usr/lib64/browser-plugins/
    You can confirm you have copied it to the correct location by running this terminal command:

    Code:
    dir /usr/lib64/browser-plugins/
    And Expect to see something like this:

    Code:
    total 10880
    lrwxrwxrwx 1 root root       28 Apr 30 21:28 javaplugin.so -> /etc/alternatives/javaplugin
    -rwxr-xr-x 1 root root 10606256 May 19 21:34 libflashplayer.so
    -rwxr-xr-x 1 root root   110848 Feb 19 18:27 libtotem-cone-plugin.so
    -rwxr-xr-x 1 root root   115584 Feb 19 18:27 libtotem-gmp-plugin.so
    -rwxr-xr-x 1 root root    77712 Feb 19 18:27 libtotem-mully-plugin.so
    -rwxr-xr-x 1 root root    90528 Feb 19 18:28 libtotem-narrowspace-plugin.so
    lrwxrwxrwx 1 root root       34 May 15 16:50 libvlcplugin.so -> ../mozilla/plugins/libvlcplugin.so
    -rwxr-xr-x 1 root root    48464 Feb 27 07:56 packagekit-plugin.so
    -rwxr-xr-x 1 root root    77016 Feb 21 21:22 skypebuttons.so
    Notice the file I have shown in bold (it is not normally shown in bold) that indicates the file has went to the right place. Please confirm you have copied the file to the correct location by showing your directory command just as I have done.

    Now, if all of these steps are correct, you should be able to run Firefox and go to:

    Tools / Addons / Plugins and see the entry that says:

    Shockwave Flash 10.3 d162

    If you can see that now there go to the following site, register for a new computer with nVIDIA if you can which only works if Flash is working:

    http://www.geforce.com/#/Community/R...DriverD_Banner

    I really can't imagine getting this procedure any clearer than this. Please tell me of your success now...

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  6. #6

    Default Re: flash player not working in fire fox 4.0.1

    OK that worked thank you so much. i will have to book mark this page or some thing just in case some thing else happens.thank you very,very much......i hope this post will help others.the only bad thing is the one page i really like to look at still has a very choppy picture.but when i look at it in full screen it is great...but if i look at it in the web page that is were it is choppy.makes no scene to me.but i did make a bug report to Mozilla about it. thank you again.

  7. #7
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: flash player not working in fire fox 4.0.1

    Quote Originally Posted by aburroughs92 View Post
    ...I’m running open suse 11.4 with gnome desk top...
    You didn't say if you are running 64bit or 32bit versions of 11.4. Either way, I run 32bit flash-player (flash-player-10.3.181.14-0.2.1.i586) on KDE and on Gnome without issues. Installing it should also install the necessary "nspluginwrapper" for 64bit 11.4.

  8. #8
    Join Date
    Nov 2009
    Location
    Pennsylvania, USA
    Posts
    405

    Default Re: flash player not working in fire fox 4.0.1

    Quote Originally Posted by aburroughs92 View Post
    OK that worked thank you so much. i will have to book mark this page or some thing just in case some thing else happens.thank you very,very much......i hope this post will help others.the only bad thing is the one page i really like to look at still has a very choppy picture.but when i look at it in full screen it is great...but if i look at it in the web page that is were it is choppy.makes no scene to me.but i did make a bug report to Mozilla about it. thank you again.
    Thanks for posting a link to the bug report, so others could review it, comment on it and/or vote on it.
    Desktop: AMD Athlon(tm) II X3 455 3.3 Ghz | 4 GB RAM | GeForce GT 630

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •