Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: GNOME 3 Fails to Work After Update - HELP Appreciated

  1. #1
    Join Date
    May 2011
    Location
    Derbyshire, United Kingdom
    Posts
    56

    Exclamation GNOME 3 Fails to Work After Update - HELP Appreciated

    Hi all,

    Please excuse my first post being a negative one, I appreciate all the work having gone into this latest release of OpenSUSE and the, up until now, great GNOME 3 implementation.

    I have updated GNOME 3 and it no longer works. Having suspected extensions the problem I have manually uninstalled all extensions via command line. This got me to log in instead of the problem screen.

    However, the desktop is entirely unresponsive, after log in it no longer responds to anything, although the mouse still tracks.

    Any help will be greatly appreciated.

  2. #2

    Default Re: GNOME 3 Fails to Work After Update - HELP Appreciated

    Stable repository... what a joke.

    You should try removing gnome-shell and then reinstalling it. It should ask to remove a bunch of things in the process.

  3. #3
    Join Date
    Dec 2008
    Location
    Montgomery, AL
    Posts
    64

    Default Re: GNOME 3 Fails to Work After Update - HELP Appreciated

    Someone on the opensuse-gnome mailing list had the same problem today ("oops! something has gone wrong."). Removing the xrandr indicator extension worked for him

    Code:
    rpm -e gnome-shell-extension-xrandr-indicator

  4. #4
    Join Date
    May 2011
    Location
    Derbyshire, United Kingdom
    Posts
    56

    Default Re: GNOME 3 Fails to Work After Update - HELP Appreciated

    Hi guys,

    Thanks very much for the replies. I've tried reinstalling the gnome-shell as per your earlier thread sunscape. This still hasn't solved the problem, I can now long in but the shell just hangs after it loads.

    I never had the xrandr extension installed until the update installed it automatically, I now have none of the extensions installed and the shell just hangs after I login.

  5. #5
    Join Date
    May 2011
    Location
    Derbyshire, United Kingdom
    Posts
    56

    Unhappy Re: GNOME 3 Fails to Work After Update - HELP Appreciated

    Once again, please excuse one's negativity.

    I have tried numerous things in order to get this working again. I have gone the file system in order to delete any and all remains of extensions. Uninstalled gnome-shell, rebooted, reinstalled gnome-shell and still the shell just hangs and responds to absolutely nothing.

    Is there anything else that could be stopping the shell from working properly, the rest of the system seem to be in working order as I am running fallback mode fine.

    Please let me know if there is anything I have missed or any output I could give to help as this seems quite unusual that an update would leave my desktop of choice unusable.

  6. #6

    Default Re: GNOME 3 Fails to Work After Update - HELP Appreciated

    Try to delete the directory ~/.config/dconf to get back the default gnome-shell desktop at next login.

  7. #7
    Join Date
    May 2011
    Location
    Derbyshire, United Kingdom
    Posts
    56

    Default Re: GNOME 3 Fails to Work After Update - HELP Appreciated

    Thanks for the help please try again, however this has still given me the same result, I am becoming increrasingly annoyed with this.

    Perhaps Malcolm can help

  8. #8

    Default Re: GNOME 3 Fails to Work After Update - HELP Appreciated

    Quote Originally Posted by DawthLasu View Post
    Thanks for the help please try again, however this has still given me the same result, I am becoming increrasingly annoyed with this.

    Perhaps Malcolm can help
    Do you have 3D acceleration enabled?GNOME 3 needs 3D acceleration. As far as I know.
    Last edited by Leonardo12; 12-May-2011 at 07:30. Reason: I missed something.

  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,796
    Blog Entries
    15

    Default Re: GNOME 3 Fails to Work After Update - HELP Appreciated

    Hi
    If you run system settings -> graphics -> Forced Fallback Mode to 'ON' does it get better? If so it's possibly a graphics card issue, what graphics are you running?

    The other option is to create a test user and login, does the test user have the same issues?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  10. #10

    Default Re: GNOME 3 Fails to Work After Update - HELP Appreciated

    or use the following commands to switch between gnome-shell and gnome-fallback:
    Code:
    gsettings set org.gnome.desktop.session session-name gnome
    gsettings set org.gnome.desktop.session session-name gnome-fallback
    and check if you have hardware acceleration:

    Code:
    glxinfo | grep 'direct rendering'
    If you don't, gnome3 will switch to fallback mode.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •