Results 1 to 2 of 2

Thread: Strange behaviours after every reboot

  1. #1
    Join Date
    May 2011
    Location
    Paris & New York
    Posts
    5

    Default Strange behaviours after every reboot

    Hi,

    I am a complete newbie on OpenSuse and on OpenSuse forums. I hope I open the thread in the correct section.

    I have just installed OpenSuse 11.4 with XFCE environment on my Acer Aspire 5738Z.

    Everytime I boot, I experience the following "strange" behaviours:

    1 - I need to reconfigure manually the "capture device" with Alsamixer to change it from "micro" to "internal micro". Even though I restore a taylored asound file with alsactl, as I used to do when I used Ubuntu, every time I restart my computer, the capture is on "micro" again.

    2 - In the panel, I need to remove the Thunderbird launcher. I remove it everytime I log in on Suse, but it comes back after every reboot.

    3 - Skype and Pidgin start automatically, even though they no longer are in my list of apps to start automatically after log in. (They once were, but then two instances of each tried to start at the same time).

    Besides, I have another problem with the action button, the one that enables to shut down, restart, hibernate, etc. When I click on it, I will immediately be logged off.
    I include the problem in this thread, since it may be related to my "session" issues.

    I have to admit my first days with openSuse are quite a challenge. Any help will be more than welcome

  2. #2
    Join Date
    Jun 2011
    Location
    france
    Posts
    18

    Default Re: Strange behaviours after every reboot

    I can help you with the first one. this seems to be caused by lxde, and you are on the right track...
    what I did was:
    as root 'chmod a+x /usr/sbin/alsactl' then anyone can use it,
    then I added a file in the lxde startup directory to restore the alsa settings

    derek@linux-yzgj:~> cat .config/autostart/alsa.desktop
    [Desktop Entry]
    Encoding=UTF-8
    Version=0.9.4
    Type=Application
    Name=alsa
    Comment=
    Exec=/usr/sbin/alsactl restore
    StartupNotify=false
    Terminal=false
    Hidden=false

    if you use the -f option on alsactl you can reset alsa with a local file, otherwise it defaults to /etc/asound.state

    for numbers 2 and 3 try 'grep -ir "thunderbird" .*' the dot before the * is important otherwise it misses all those config files

    derek

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •