Results 1 to 4 of 4

Thread: No internet access after upgrade

  1. #1

    Default No internet access after upgrade

    I just did a large patch on my opensuse11.3 system (upgrade of all installed packages), and whilst my network interface works, I cannot get past my router onto the internet.

    I can connect to other computers on my network (here at home), I have an IP address via dhcp from my router, but I cannot get internet access, either from thunderbird, firefox, or simply by 'ping bbc.co.uk'.
    Clearly the computer was connected to the internet just fine minutes before since I did the large patch!
    Also, my other computers CAN still connect to the internet.

    Any ideas as to what the problem is and how i can debug it? It is just too coincidental I have upgraded everything and now somethings amiss!

    If it's relevant, my router is a netgear WGR614v9.

    A few things I've tried...

    Code:
    linuxthinkpad:/var/log # /sbin/route
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    192.168.1.0     *               255.255.255.0   U     0      0        0 eth1
    link-local      *               255.255.0.0     U     0      0        0 eth1
    loopback        *               255.0.0.0       U     0      0        0 lo
    
    linuxthinkpad:/var/log # ifconfig
    eth0      Link encap:Ethernet  HWaddr 00:16:36:0B:A1:11  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
              Interrupt:16 
    
    eth1      Link encap:Ethernet  HWaddr 00:13:CE:A4:F2:60  
              inet addr:192.168.1.14  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: fe80::213:ceff:fea4:f260/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:181573 errors:0 dropped:0 overruns:0 frame:0
              TX packets:125158 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:189408193 (180.6 Mb)  TX bytes:16888096 (16.1 Mb)
              Interrupt:21 Base address:0x4000 Memory:c0002000-c0002fff 
    
    irda0     Link encap:IrLAP  HWaddr f4:87:e9:48  
              UP RUNNING NOARP  MTU:2048  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:8 
              RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:202 errors:0 dropped:0 overruns:0 frame:0
              TX packets:202 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:17456 (17.0 Kb)  TX bytes:17456 (17.0 Kb)
    
    pan0      Link encap:Ethernet  HWaddr F6:5A:A8:B5:7E:4D  
              inet6 addr: fe80::f45a:a8ff:feb5:7e4d/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:0 (0.0 b)  TX bytes:468 (468.0 b)
    
    linuxthinkpad:/var/log # cat /etc/resolv.conf 
    ### /etc/resolv.conf file autogenerated by netconfig!
    #
    # Before you change this file manually, consider to define the
    # static DNS configuration using the following variables in the
    # /etc/sysconfig/network/config file:
    #     NETCONFIG_DNS_STATIC_SEARCHLIST
    #     NETCONFIG_DNS_STATIC_SERVERS
    #     NETCONFIG_DNS_FORWARDER
    # or disable DNS configuration updates via netconfig by setting:
    #     NETCONFIG_DNS_POLICY=''
    #
    # See also the netconfig(8) manual page and other documentation.
    #
    # Note: Manual change of this file disables netconfig too, but
    # may get lost when this file contains comments or empty lines
    # only, the netconfig settings are same with settings in this
    # file and in case of a "netconfig update -f" call.
    #
    ### Please remove (at least) this line when you modify the file!
    search ourhome
    nameserver 192.168.1.1
    
    linuxthinkpad:/var/log # uname -a
    Linux linuxthinkpad 2.6.34.8-0.2-default #1 SMP 2011-04-06 18:11:26 +0200 i686 i686 i386 GNU/Linux
    I notice from ifconfig this that there's a new "pan0" device which looks like an ipv6 interface - is that a likely contender?

    Thanks in advance

  2. #2

    Default Re: No internet access after upgrade

    I disabled ipv6, rebooted, and it has made no difference, so it's not that!

  3. #3
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: No internet access after upgrade

    On 05/11/2011 05:36 PM, jonb62 wrote:

    > linuxthinkpad:/var/log # /sbin/route
    > Kernel IP routing table
    > Destination Gateway Genmask Flags Metric Ref Use Iface
    > 192.168.1.0 * 255.255.255.0 U 0 0 0 eth1
    > link-local * 255.255.0.0 U 0 0 0 eth1
    > loopback * 255.0.0.0 U 0 0 0 lo


    The problem is here. What routing rule would be used to get to the outside
    world? The first one only gets to 192.168.1.X. You need a rule like

    Code:
    0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 eth1
    The command you need to enter is

    sudo /sbin/route add default gw 192.168.1.1


  4. #4

    Default Re: No internet access after upgrade

    Quote Originally Posted by lwfinger View Post
    On 05/11/2011 05:36 PM, jonb62 wrote:

    > linuxthinkpad:/var/log # /sbin/route
    > Kernel IP routing table
    > Destination Gateway Genmask Flags Metric Ref Use Iface
    > 192.168.1.0 * 255.255.255.0 U 0 0 0 eth1
    > link-local * 255.255.0.0 U 0 0 0 eth1
    > loopback * 255.0.0.0 U 0 0 0 lo


    The problem is here. What routing rule would be used to get to the outside
    world? The first one only gets to 192.168.1.X. You need a rule like

    Code:
    0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 eth1
    The command you need to enter is

    sudo /sbin/route add default gw 192.168.1.1
    Thanks - that works.
    Clearly this is new to me, and I haven't had to ever do this before (I've been using opensuse for many generations), so my question is:
    Why has this happened?
    It must have been something that occurred during the patch process - I certainly haven't fiddled with anything to do with this ;-)

    Thanks again

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •