Results 1 to 8 of 8

Thread: can not run Kate in gnome

  1. #1

    Default can not run Kate in gnome

    Dear all,
    Kate run well in gnome several weeks ago but know it dose not. I click the Kate icon in the application panel but can not see any response. Any suggestion? Thanks.

  2. #2
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    2,919

    Default Απ: can not run Kate in gnome

    Try to run it in terminal
    Code:
    Kate
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1070 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  3. #3

    Default Re: Απ: can not run Kate in gnome

    it does not work. Here is the output in terminal.
    Code:
    kate: symbol lookup error: /usr/lib64/libnepomukutils.so.4: undefined symbol: _ZNK19QAbstractProxyModel8itemDataERK11QModelIndex
    any more suggestion?

  4. #4

    Default Re: Απ: can not run Kate in gnome

    Dear all,

    Kate does not run well in gnome on my PC (openSUSE 11.4).

    kate: symbol lookup error: /usr/lib64/libnepomukutils.so.4: undefined symbol: _ZNK19QAbstractProxyModel8itemDataERK11QModelIndex

    Any suggestion?

  5. #5
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    2,919

    Default Απ: Re: Απ: can not run Kate in gnome

    Try to install this RPM Search libnepomukutils.so.4
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1070 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  6. #6
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: can not run Kate in gnome

    Code:
    su -
    zypper in libkde4
    but it is strange if that is not installed. Did you break somehow your kde
    libs?

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  7. #7

    Default Re: Απ: Re: Απ: can not run Kate in gnome

    Disable nepomuk in KDE.

  8. #8
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: can not run Kate in gnome

    flyspring wrote:
    > kate: symbol lookup error: /usr/lib64/libnepomukutils.so.4: undefined
    > symbol: _ZNK19QAbstractProxyModel8itemDataERK11QModelIndex

    Ignore my previous post I somehow missed the point. You have the library but
    obviously your kde4 libraries and your kate version are not compatible. One
    way to check that is by
    Code:
    rpm -q kate
    rpm -q libkde4
    Which gives on my machine for example
    kate-4.6.0-4.7.1.x86_64
    libkde4-4.6.0-6.13.1.x86_64
    so both belong to kde 4.6.0, if that first three version numbers are
    different from ech other for the two packages on your machine you may have
    kate and libkde4 from two different repositories and that will lead to such
    problems.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •