Results 1 to 6 of 6

Thread: Why is mysqld running?

  1. #1

    Default Why is mysqld running?

    I noticed that mysqld is always running, and I don't know why. Enabled is set to "no" for mysqld in the system services in yast. I don't recall ever doing anything that would run it. I don't know how to disable from booting and I don't want to kill the process every time I start up. What else would be starting this process? Where can I look to find what is launching it in startup scripts?

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,288

    Default Re: Why is mysqld running?

    mysql (at least a striped down version) is used in the new KDE search /index program. You running KDE?

  3. #3
    Join Date
    Dec 2008
    Location
    GMT-7
    Posts
    382

    Default Re: Why is mysqld running?

    Quote Originally Posted by sp3wn View Post
    I noticed that mysqld is always running, and I don't know why. Enabled is set to "no" for mysqld in the system services in yast. I don't recall ever doing anything that would run it. I don't know how to disable from booting and I don't want to kill the process every time I start up. What else would be starting this process? Where can I look to find what is launching it in startup scripts?
    mysql is (like it or hate it) part of KDEPIM, especially akonadi and the already mentioned search engine. If you are willing to risk breaking KDE, you can try turning it off or switching to a different server type - there is an "Akonadi Configuration" application (search in the KDE menu). I would not recommend messing with Akonadi - it's a little buggy.
    Desk: AMD Phenom II X4 945 8GB RAM Radeon HD 3300 Arch Linux Xfce 4.8
    Lap: Intel 2.13GHz Core i3 M330 8GB RAM nVidia GeForce 310M Arch Linux KDE 4.7.3

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,680
    Blog Entries
    3

    Default Re: Why is mysqld running?

    If you are using anything that requires akonadi, then you need mysqld.

    As far as I can tell, I am not using anything that requires akonadi. But akonadi starts anyway. So I edited "/home/rickert/.config/akonadi/akonadiserverrc" and changed the "StartServer" setting to "false". As a result, mysqld is no longer starting, and akonadi is going away after noticing that mysqld is not running. I have not seen any bad effects. But then, as I said, I am not using anything that needs it (I am not using kmail or its calendar function).
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Why is mysqld running?

    On 2011-05-11 02:06, sp3wn wrote:
    >
    > I noticed that mysqld is always running, and I don't know why. Enabled
    > is set to "no" for mysqld in the system services in yast. I don't recall
    > ever doing anything that would run it. I don't know how to disable from
    > booting and I don't want to kill the process every time I start up.
    > What else would be starting this process? Where can I look to find what
    > is launching it in startup scripts?


    I suggest you find out what databases are stored inside :-)

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  6. #6

    Default Re: Why is mysqld running?

    Quote Originally Posted by twelveeighty View Post
    mysql is (like it or hate it) part of KDEPIM, especially akonadi and the already mentioned search engine. If you are willing to risk breaking KDE, you can try turning it off or switching to a different server type - there is an "Akonadi Configuration" application (search in the KDE menu). I would not recommend messing with Akonadi - it's a little buggy.
    I don't know why I never replied to this, but IIRC it was because Akonadi is running with KDE. I don't remember exactly what Akonadi is; I'm sure it's easy to look up.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •