Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Is this normal?

  1. #1
    Join Date
    May 2011
    Location
    USA
    Posts
    5

    Default Is this normal?

    After deleting my Ubuntu partition and using the free space to create a partition for openSUSE with 4GB swap, I installed the OS. The install ran smoothly and it even automatically set up a boot loader for my windows partition.

    I logged in to the KDE Desktop. I updated through the Software Updates application, and it prompted me to reboot. When I clicked restart my screen went blank but my computer stayed on without restarting. This lasted over an hour before I decided to force a shut down by holding my CPU's power button down.

    OpenSUSE starts up fine, but after I select the OS from the boot loader the screen goes black twice while loading the KDE desktop. I'm quite new to openSUSE and have never had this problem before with Ubuntu, so I'm just curious if this is all normal? If it isn't, any suggestions on how to fix the solution would be greatly appreciated.

    I also shut down the computer last night, and it didn't hang at all, so that's good at least.

    Thank you.

    EDIT: If it helps, I installed openSUSE via the Live KDE method, on a bootable usb.

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,739
    Blog Entries
    3

    Default Re: Is this normal?

    I think the first reboot during install is often done with "kernelexec" or something of the sort. The kernel is reloaded without a full boot.

    When I installed on my desktop, it hung at that point. I had to power off and reboot. However, once that was done, the normal rebooting has worked fine (I reboot to Windows twice a week, to update virus table ).

    On an older laptop, the initial reboot worked just fine. However, since then I must remember to shutdown rather than reboot, for a reboot always fails.

    I believe this has to do with the hardware and BIOS support for power settings.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3

    Default Re: Is this normal?

    The first thing to try in black screen situations is to boot with the option 'nomodeset'. Depending on your graphic card (nvidia or ATI), you can later install the proprietary driver.

  4. #4
    Join Date
    May 2011
    Location
    USA
    Posts
    5

    Default Re: Is this normal?

    Quote Originally Posted by please_try_again View Post
    The first thing to try in black screen situations is to boot with the option 'nomodeset'. Depending on your graphic card (nvidia or ATI), you can later install the proprietary driver.
    Alright, I'll try that. My computer will still not restart, but shuts down fine. I'm kind of baffled on how to fix that.

    @nrickert - Thanks for the suggestions!

  5. #5

    Default Re: Is this normal?

    Try to boot in runlevel 3 by appending '3' (without quotes) to the boot options. Do you get a console where you can login? If so, type the following command and post the output here:
    Code:
    hwinfo --gfxcard | grep -i -e model -e driver

  6. #6
    Join Date
    May 2011
    Location
    USA
    Posts
    5

    Default Re: Is this normal?

    Quote Originally Posted by please_try_again View Post
    Try to boot in runlevel 3 by appending '3' (without quotes) to the boot options. Do you get a console where you can login? If so, type the following command and post the output here:
    Code:
    hwinfo --gfxcard | grep -i -e model -e driver
    Yep, I got a console where I was prompted to log in. After doing so I ran:
    Code:
    hwinfo --gfxcard | grep -i -e model -e driver
    However, no output was given. The console just echoed the command. It didn't give me any errors with the syntax, though.

    Maybe I'm doing something wrong? I've had the luxury of Ubuntu spoon feeding me (the user) throughout my usage of it. Thanks again for the help.

    EDIT: After trying your suggestion of booting with nomodeset, it seemed to remove the problem of my screen losing the VGA Signal on and off during KDE's start up. That's a start I suppose?

  7. #7
    Join Date
    May 2011
    Location
    USA
    Posts
    5

    Default Re: Is this normal?

    OpenSUSE's default boot option is set to VGA = 0x31a in the bootloader as well, if that helps.

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Is this normal?

    And your graphics device is???
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,760

    Default Re: Is this normal?

    Did you log on as root?

  10. #10

    Default Re: Is this normal?

    That one should work:

    Code:
    /usr/sbin/hwinfo --gfxcard | grep -i -e model -e driver
    and if it doesn't:

    Code:
    /sbin/lspci | grep -i vga

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •