Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Blank login screen

  1. #1

    Default Blank login screen

    Hello all,

    I have installed openSUSE 11.4 on my notebook (HP Pavilion DV5-2040br) with success, but after restart I got a blank login screen (nothing to see).
    If I turn off login policy, and put my user to login automatically, everything goes fine. The screen blink some times but KDE starts.
    If I turn it on again, the login screen does not appear... But I know that login screen is there because if I type my user name and password KDE loads up and the screen appears again (with loading bar, after login).
    Could you help me with this issue? It seems to be something related to framebuffer turning off and Intel driver turning on... Maybe login screen is loaded on framebuffer and I can't see that... I'm really lost on this...

    Thanks.

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,761

    Default Re: Blank login screen

    Tried failsafe boot? Sounds like a video problem. What video card/chip do you have?

  3. #3
    Join Date
    Jul 2009
    Location
    Montreal, Québec
    Posts
    833

    Default Re : Re: Blank login screen

    Hi,

    What is your graphic card ? At GRUB login, do as you see in this picture (pass the nomodeset parameter) : File:Nomodeset-example.jpg - openSUSE

  4. #4

    Default Re: Blank login screen

    My video card is described as "Integrated HD Intel graphics".
    If I try to boot using "Fail safe" mode everything goes fine... But 3D acceleration does not work.

  5. #5
    Join Date
    Jul 2009
    Location
    Montreal, Québec
    Posts
    833

    Default Re : Re: Blank login screen

    Did you try booting as in the link I refer to you earlier?

  6. #6

    Default Re: Blank login screen

    When I pass nomodeset as kernel parameter I could not load 3D acceleration.

  7. #7
    Join Date
    Jul 2009
    Location
    Montreal, Québec
    Posts
    833

    Default Re : Re: Blank login screen

    That is normal. So I presume you log in normally in KDE with the nomodeset parameter ?

    Can you give us the output of this command please :

    Code:
     hwinfo --gfxcard | grep -i -e model -e driver

  8. #8

    Default Re: Re : Re: Blank login screen

    Hello All,

    Sorry for my delay... I was out for a while...
    Follow the result for "hwinfo --gfxcard | grep -i -e model -e driver":

    Model: "Intel Arrandale Integrated Graphics Controller"
    Driver: "i915"
    Driver Modules: "drm"
    Driver Info #0:
    Driver Status: i915 is active
    Driver Activation Cmd: "modprobe i915"

    As I told before, after driver loads everything appears fine, but I need to use login without authentication. By this way KDE loads driver and shows me desktop! Before that, from GRUB selection until KDE loads my screen is blank.

  9. #9

    Default Re: Blank login screen

    Could someone help this good soul lost in the dark (really dark, because my login screen still blank )... I'm wondering if could be something related to KMS changes... I know nothing about KMS! Or maybe related to some forgot module on initrd image...

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,569
    Blog Entries
    38

    Default Re: Blank login screen

    Quote Originally Posted by rgrillo View Post
    Could someone help this good soul lost in the dark (really dark, because my login screen still blank )... I'm wondering if could be something related to KMS changes... I know nothing about KMS! Or maybe related to some forgot module on initrd image...
    The Intel Arrandale i915 has caused a number of openSUSE users some pain.

    I recommend you install the application Midnight Commander (mc) such that you can get a text editor when in a text mode by typing 'mc' (no quotes). That way if you get stranded in a text mode because of an edit we have had you do, you can remove the edit and recover.

    Now after installing 'mc', change the /etc/X11/xorg.conf.d/50-device.conf file to:
    Code:
    Section "Device"
      Identifier "Default Device"
    
      #Driver "radeon"
      Driver "intel"
    
      ## Required magic for radeon/radeonhd drivers; output name
      ## (here: "DVI-0") can be figured out via 'xrandr -q'
      #Option "monitor-DVI-0" "Default Monitor"
    
    EndSection
    and save the change, and reboot, using the boot code 'nomodeset' in this case.

    My guess is it will fail to load, and you will need to boot to failsafe (or press '3' as a boot code) to boot to a text mode.

    In which case, try the Intellegacy driver (an old Intel driver) by changing the /etc/X11/xorg.conf.d/50-device.conf file to:
    Code:
    Section "Device"
      Identifier "Default Device"
    
      #Driver "radeon"
      Driver "intellegacy"
    
      ## Required magic for radeon/radeonhd drivers; output name
      ## (here: "DVI-0") can be figured out via 'xrandr -q'
      #Option "monitor-DVI-0" "Default Monitor"
    
    EndSection
    Reboot and text. Try with and without nomodeset in this case.

    Note in a text mode you can reboot with root permissions with the command:
    Code:
    shutdown -r now
    and you can halt the pc with the command:
    Code:
    shutdown -h now
    Note we are all unpaid volunteers/enthusiasts here. We have different day jobs (with nothing to do with Linux) that pays for our food and rent. We are like you in that we also can not immediately reply. So please have patience if we don't reply within a day or so.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •