Results 1 to 7 of 7

Thread: Novell iprint client on openSUSE fails

  1. #1

    Default Novell iprint client on openSUSE fails

    I'm quite new to openSUSE. Trying to install the Novell iprint client but got the following error message:

    rpm -Uvh novell-iprint-xclient-sh-6.500.20081007-1.i586.rpm
    error: Failed dependencies:
    libglitz.so.1 is needed by novell-iprint-xclient-sh-6.500.20081007-1.i586
    libpng12.so.0 is needed by novell-iprint-xclient-sh-6.500.20081007-1.i586

    My system specifications are as follows:

    lsb_release -a
    LSB Version: n/a
    Distributor ID: SUSE LINUX
    Description: openSUSE 11.4 (i586)
    Release: 11.4
    Codename: Celadon

    Thanks in advance

  2. #2

    Default Re: Novell iprint client on openSUSE fails

    Quote Originally Posted by luridao View Post
    I'm quite new to openSUSE. Trying to install the Novell iprint client but got the following error message:

    rpm -Uvh novell-iprint-xclient-sh-6.500.20081007-1.i586.rpm
    error: Failed dependencies:
    libglitz.so.1 is needed by novell-iprint-xclient-sh-6.500.20081007-1.i586
    libpng12.so.0 is needed by novell-iprint-xclient-sh-6.500.20081007-1.i586

    [...]
    libpng12 can be found in package libpng12-0. Try a search in Yast or as root do
    Code:
    # zypper in libpng12-0
    libglitz seems to be part of package ruby-rcairo, which is not in the main repos. It can be found in the KDE:Extra repo. You can easily add it with the repository management in Yast (it is one of the community repos).

  3. #3

    Default Re: Novell iprint client on openSUSE fails

    It seems that libpng12-0 is already installed:

    sudo zypper in libpng12-0
    Retrieving repository 'PK_TMP_DIR' metadata [done]
    Loading repository data...
    Reading installed packages...
    'libpng12-0' is already installed.
    No update candidate for 'libpng12-0-1.2.44-7.1.i586'. The highest available version is already installed.
    Resolving package dependencies...

    Nothing to do.

    As I said I'm quite new to openSUSE. How can I add "ruby-rcairo" to the main repos. and so on?

    Thanks in advance

  4. #4

    Default Re: Novell iprint client on openSUSE fails

    it does not work to add the KDE:Extra repo on my system. Maybe it is because I have the GNOME environment.

    Best,
    LRC

  5. #5

    Default Re: Novell iprint client on openSUSE fails

    Quote Originally Posted by luridao View Post
    it does not work to add the KDE:Extra repo on my system. Maybe it is because I have the GNOME environment.

    Best,
    LRC
    Have you tried to add it with Yast ? You should be able to add any repo, regardless of which software you have installed.

    To me, it seems that iprint depends on a different package name for libpng12. Because it's already installed but iprint still complains about it.
    I have installed the libpng12-0 package and found libpng12.so.0 in /usr/lib64.

    Regarding the KDE:Extra repo.

    In a terminal window as root try
    Code:
    # zypper ar -f http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_11.4/ KDE_Extra
    # zypper in ruby-rcairo
    Anyway, if all of the above fails, you should probably ask an iprint expert on how to install it on openSUSE.

  6. #6

    Default Re: Novell iprint client on openSUSE fails

    after doing what you said and checking that the repos. is really installed the system complains
    about:

    rpm -Uhv novell-iprint-xclient-sl-6.500.20081007-1.i586.rpm
    error: Failed dependencies:
    libglitz.so.1 is needed by novell-iprint-xclient-sl-6.500.20081007-1.i586

    has the glitz package ot a new name? (see below)

    sudo zypper install glitz
    Loading repository data...
    Reading installed packages...
    'glitz' not found in package names. Trying capabilities.
    No provider of 'glitz' found.
    Resolving package dependencies...

    Nothing to do.

    Best

  7. #7

    Default Re: Novell iprint client on openSUSE fails

    Quote Originally Posted by luridao View Post
    after doing what you said and checking that the repos. is really installed the system complains
    about:

    rpm -Uhv novell-iprint-xclient-sl-6.500.20081007-1.i586.rpm
    error: Failed dependencies:
    libglitz.so.1 is needed by novell-iprint-xclient-sl-6.500.20081007-1.i586

    has the glitz package ot a new name? (see below)
    As I said, libglitz is part of ruby-rcairo, it is not a standalone package.
    If you have ruby-rcairo installed, have you searched for libglitz.so.1 ?

    Is the iprint rpm for openSUSE 11.4, a previous version or even for a different distro ?

    Good news is that iprint does not complain about libpng anymore ;-).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •