Hallo,

ich benutze folgendes, um jeweils aktuell in Tumbleweed enthaltenen Pakete zu installieren:

zypper dup --from Tumbleweed --from "packman tumbleweed"

Es ist mir bekannt, daß es mit Tumbleweed gelegentlich zu Konflikten im Zusammenhang mit Patches aus dem Update-Repository kommen kann, die in der Regel leicht zu beheben sind.

Das aber die Paketverwaltung auf die Idee kommt, das komplette KDE auf einer 64bit-Maschine durch i586 zu ersetzen kann ja wohl nicht im Sinne des Erfinders sein, oder?

Sollte es nicht so sein, daß Pakete nur dann in Tumbleweed auftauchen, wenn das Repository damit wieder in sich konsistent ist?

Das scheint mir im Folgenden nicht der Fall zu sein:

elektra:/home/ml # zypper dup --from Tumbleweed --from "packman tumbleweed"

Daten des Repositorys laden ...
Installierte Pakete lesen ...
Distributionsaktualisierung berechnen ...
102 Probleme:
Problem: bluedevil-1.0.4-31.1.x86_64 benötigt kdebase4-runtime >= 4.6.2, was aber nicht angeboten werden kann
Problem: kipi-plugins-1.9.0-107.1.x86_64 benötigt libkdcraw.so.9()(64bit), was aber nicht angeboten werden kann
Problem: kipi-plugins-acquireimage-1.9.0-107.1.x86_64 benötigt libkdeui.so.5()(64bit), was aber nicht angeboten werden kann
Problem: vlc-qt-1.1.9-1.pm.2.4.x86_64 benötigt libQtCore.so.4()(64bit), was aber nicht angeboten werden kann
Problem: Problem mit installiertem Paket akregator-4.4.11.1-1.1.x86_64
Problem: Problem mit installiertem Paket ark-4.6.2-1.3.x86_64
Problem: Problem mit installiertem Paket digikam-1.9.0-71.3.x86_64
Problem: Problem mit installiertem Paket dolphin-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket gwenview-4.6.2-1.2.x86_64
Problem: Problem mit installiertem Paket kaffeine-1.2.2-52.1.x86_64
Problem: Problem mit installiertem Paket kcalc-4.6.2-1.3.x86_64
Problem: Problem mit installiertem Paket kcharselect-4.6.2-1.3.x86_64
Problem: Problem mit installiertem Paket kcolorchooser-4.6.2-1.2.x86_64
Problem: Problem mit installiertem Paket kde4-filesystem-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket kde4-kgreeter-plugins-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket kdeartwork4-screensaver-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket kdebase4-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket kdebase4-libkonq-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket kdebase4-nsplugin-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket kdebase4-runtime-xine-4.6.2-1.2.x86_64
Problem: Problem mit installiertem Paket kdebase4-session-4.6.2-51.1.x86_64
Problem: Problem mit installiertem Paket kdebase4-workspace-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket kdebase4-workspace-ksysguardd-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket kdebase4-workspace-liboxygenstyle-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket kdegames4-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket kdegraphics4-4.6.2-1.2.x86_64
Problem: Problem mit installiertem Paket kdelibs4-4.6.2-1.2.x86_64
Problem: Problem mit installiertem Paket kdelibs4-core-4.6.2-1.2.x86_64
Problem: Problem mit installiertem Paket kdemultimedia4-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket kdenetwork4-filesharing-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket kdepasswd-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket kdepim4-4.4.11.1-1.1.x86_64
Problem: Problem mit installiertem Paket kdepim4-runtime-4.4.11.1-1.2.x86_64
Problem: Problem mit installiertem Paket kdepim4-wizards-4.4.11.1-1.1.x86_64
Problem: Problem mit installiertem Paket kdepimlibs4-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket kdialog-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket kdm-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket kdnssd-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket keditbookmarks-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket kfind-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket kgamma-4.6.2-1.2.x86_64
Problem: Problem mit installiertem Paket kget-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket kgpg-4.6.2-1.3.x86_64
Problem: Problem mit installiertem Paket kio_audiocd-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket kio_kamera-4.6.2-1.2.x86_64
Problem: Problem mit installiertem Paket kmag-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket kmahjongg-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket kmines-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket kmix-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket kmousetool-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket knotes-4.4.11.1-1.1.x86_64
Problem: Problem mit installiertem Paket kompare-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket konqueror-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket konqueror-plugins-4.6.1-25.1.x86_64
Problem: Problem mit installiertem Paket konsole-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket kontact-4.4.11.1-1.1.x86_64
Problem: Problem mit installiertem Paket kopete-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket korganizer-4.4.11.1-1.1.x86_64
Problem: Problem mit installiertem Paket kpat-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket krdc-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket kreversi-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket krfb-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket kruler-4.6.2-1.2.x86_64
Problem: Problem mit installiertem Paket kscd-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket ksnapshot-4.6.2-1.2.x86_64
Problem: Problem mit installiertem Paket ksudoku-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket kwalletmanager-4.6.2-1.3.x86_64
Problem: Problem mit installiertem Paket kwin-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket kwrite-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket libQtWebKit4-4.7.2-8.1.x86_64
Problem: Problem mit installiertem Paket libakonadi4-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket libakonadiprotocolinternals1-1.5.2-89.1.x86_64
Problem: Problem mit installiertem Paket libdbusmenu-qt2-0.6.6-6.2.x86_64
Problem: Problem mit installiertem Paket libepub0-0.2.1-21.1.x86_64
Problem: Problem mit installiertem Paket libkcddb4-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket libkcompactdisc4-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket libkdecore4-4.6.2-1.2.x86_64
Problem: Problem mit installiertem Paket libkdegames4-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket libkdepim4-4.4.11.1-1.1.x86_64
Problem: Problem mit installiertem Paket libkdepimlibs4-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket libkexiv2-9-4.6.2-1.2.x86_64
Problem: Problem mit installiertem Paket libkipi8-4.6.2-1.2.x86_64
Problem: Problem mit installiertem Paket libkonq5-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket libksane0-4.6.2-1.2.x86_64
Problem: Problem mit installiertem Paket libksuseinstall1-4.6.2-1.2.x86_64
Problem: Problem mit installiertem Paket libqca2-2.0.2-14.1.x86_64
Problem: Problem mit installiertem Paket libqjson0-0.7.1-9.1.x86_64
Problem: Problem mit installiertem Paket libqt4-qt3support-4.7.2-8.1.x86_64
Problem: Problem mit installiertem Paket libqt4-sql-4.7.2-8.1.x86_64
Problem: Problem mit installiertem Paket libqt4-sql-sqlite-4.7.2-8.1.x86_64
Problem: libkde4-4.6.2-1.2.x86_64 benötigt libqt4-x11 >= 4.7.2, was aber nicht angeboten werden kann
Problem: Problem mit installiertem Paket marble-4.6.2-1.3.x86_64
Problem: Problem mit installiertem Paket okular-4.6.2-1.2.x86_64
Problem: Problem mit installiertem Paket plasma-addons-marble-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket python-kde4-4.6.2-1.3.x86_64
Problem: Problem mit installiertem Paket python-kdebase4-4.6.2-1.1.x86_64
Problem: Problem mit installiertem Paket python-qt4-4.8.4-4.1.x86_64
Problem: Problem mit installiertem Paket python-sip-4.12.2-7.1.x86_64
Problem: Problem mit installiertem Paket qt4-qtscript-0.1.0-13.1.x86_64
Problem: Problem mit installiertem Paket sweeper-4.6.2-1.3.x86_64
Problem: Problem mit installiertem Paket procps-3.2.8-26.4.x86_64
Problem: marble-4.6.2-1.3.x86_64 benötigt marble-data = 4.6.2, was aber nicht angeboten werden kann

Problem: bluedevil-1.0.4-31.1.x86_64 benötigt kdebase4-runtime >= 4.6.2, was aber nicht angeboten werden kann
Gelöschte Anbieter: kdebase4-runtime-4.6.2-1.2.x86_64
Nicht installierbare Anbieter: kdebase4-runtime-4.6.3-1.1.i586[Tumbleweed]
Lösung 1: Folgende Aktionen werden ausgeführt:
Deinstallation von bluedevil-1.0.4-31.1.x86_64
Deinstallation von bluedevil-lang-1.0.4-31.1.noarch
Deinstallation von kdebase4-runtime-4.6.2-1.2.x86_64
Deinstallation von synaptiks-0.4.0-9.2.x86_64
Deinstallation von skanlite-0.7.kde4.5.0-3.1.x86_64
Deinstallation von plasmoid-quickaccess-0.8.1-9.2.x86_64
Deinstallation von mozilla-kde4-integration-0.6.3-3.1.x86_64
Deinstallation von kwebkitpart-1.1.0-3.2.x86_64
Deinstallation von kvkbd-0.6-9.1.x86_64
Deinstallation von ktorrent-4.1.0-1.3.1.x86_64
Deinstallation von ksshaskpass-0.5.3-2.1.x86_64
Deinstallation von kradio-4.0.2-3.3.x86_64
Deinstallation von kpackagekit-0.6.3.3-6.11.1.x86_64
Deinstallation von konversation-1.3.1-7.10.1.x86_64
Deinstallation von kio_sysinfo-11.4-33.40.1.x86_64
Deinstallation von kdebase4-runtime-branding-openSUSE-11.4-33.40.1.x86_64
Deinstallation von amarok-2.4.0-8.11.3.x86_64
Deinstallation von NetworkManager-kde4-0.9.svn1192577-7.2.x86_64
Deinstallation von ktorrent-lang-4.1.0-1.3.1.noarch
Deinstallation von kio_sysinfo-branding-openSUSE-11.4-33.40.1.x86_64
Deinstallation von k3b-lang-2.0.2-8.pm.8.8.noarch
Deinstallation von patterns-openSUSE-kde4_basis-11.4-6.9.1.x86_64
Deinstallation von kdebase4-workspace-branding-openSUSE-11.4-33.40.1.x86_64
Deinstallation von kdebase4-openSUSE-11.4-33.40.1.x86_64
Deinstallation von NetworkManager-kde4-libs-0.9.svn1192577-7.2.x86_64
Deinstallation von patterns-openSUSE-kde4_imaging-11.4-6.9.1.x86_64
Deinstallation von patterns-openSUSE-kde4-11.4-6.9.1.x86_64
Deinstallation von NetworkManager-openvpn-kde4-0.9.svn1192577-7.2.x86_64
Deinstallation von NetworkManager-pptp-kde4-0.9.svn1192577-7.2.x86_64
Deinstallation von NetworkManager-vpnc-kde4-0.9.svn1192577-7.2.x86_64
Lösung 2: veraltetes kdebase4-runtime-4.6.2-1.2.x86_64 behalten
Lösung 3: bluedevil auflösen durch das Ignorieren einiger Abhängigkeiten

Wählen Sie aus den obigen Lösungen mittels Nummer oder Sie (u)eberspringen, (w)iederholen oder (b)rechen ab. [1/2/3/u/w/b] (b):