Results 1 to 9 of 9

Thread: Disable KDE4 Theme in LibreOffice

  1. #1
    Join Date
    Sep 2009
    Location
    Athens, Greece
    Posts
    70

    Default Disable KDE4 Theme in LibreOffice

    Does anyone know how (if possible) to prevent LibreOffice from using the KDE theme the rest of the apps are using? I like my KDE theme but it's a bit on the dark side. It's fine for Dolphin and KMail and stuff but it is not very suitable for LibreOffice. I would like to use LO with it's default colors, if possible.

    Any ideas?

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,439

    Default Re: Disable KDE4 Theme in LibreOffice

    Tools>Options>General>Use LibreOffice dialogs

  3. #3
    Join Date
    Sep 2009
    Location
    Athens, Greece
    Posts
    70

    Default Απ: Re: Disable KDE4 Theme in LibreOffice

    Quote Originally Posted by john_hudson View Post
    Tools>Options>General>Use LibreOffice dialogs
    Thanks for the quick answer. However, I was referring to the color theme the whole of LibreOffice is using (the toolbar colors, the button backgrounds etc...). The dialog box colors I don't mind, since I chose my KDE theme because it is easier on the eyes. Unfortunately, this means that I cannot tell when a button is pressed or not in Libreoffce.

  4. #4
    Join Date
    Feb 2010
    Location
    Upstate New York, USA
    Posts
    480

    Default Re: Απ: Re: Disable KDE4 Theme in LibreOffice

    Quote Originally Posted by saverios View Post
    Thanks for the quick answer. However, I was referring to the color theme the whole of LibreOffice is using (the toolbar colors, the button backgrounds etc...). The dialog box colors I don't mind, since I chose my KDE theme because it is easier on the eyes. Unfortunately, this means that I cannot tell when a button is pressed or not in Libreoffce.
    The following link solved this in OpenOffice, and seems to work with LO:

    How to force OpenOffice to use GTK theme under KDE?
    Lap: Gateway NV79, i5-430, 4GB, 2 x 500GB HD, Intel GMA HD
    openSUSE Leap 15.0 x64 + 42.3 x64, KDE 5.15.3, Ubuntu 16.04 LTS, Windows 7

    Test:: openSUSE 15.0, KDE Plasma, Windows/XP/SP3 guest.

  5. #5
    Join Date
    Sep 2009
    Location
    Athens, Greece
    Posts
    70

    Default Απ: Re: Απ: Re: Disable KDE4 Theme in LibreOffice

    Quote Originally Posted by SeanMc98 View Post
    The following link solved this in OpenOffice, and seems to work with LO:

    How to force OpenOffice to use GTK theme under KDE?
    I used this solution as well with OpenSUSE 11.3 and OpenOffice 3.3, but it doesn't seen to work with 11.4 and LibreOffice 3.3.2. The environment variable OOO_FORCE_DESKTOP=gnome is set but nothing changes. Maybe the guys at LibreOffice changed the name of the variable the program searches for? Any other ideas? SeanMc98, have you actually seen this work with LibreOffice as well?

    Thanks anyway.

  6. #6

    Default Re: Disable KDE4 Theme in LibreOffice

    After uninstalling the kde related LibO packages, do the following as root (this is for 64 bits systems):

    mv /usr/lib64/libreoffice/basis-link/program/libvclplug_kde4lx.so /usr/lib64/libreoffice/basis-link/program/libvclplug_kde4lx.so.old

    mv /usr/lib64/libreoffice/basis-link/program/libvclplug_kdelx.so /usr/lib64/libreoffice/basis-link/program/libvclplug_kdelx.so.old

    (of course, you can just "rm" if you are bold enough... )
    On 3.4 this will not be necessary, though: kde4 integration is taking good shape on latest development releases.

  7. #7
    Join Date
    Sep 2009
    Location
    Athens, Greece
    Posts
    70

    Default Απ: Re: Disable KDE4 Theme in LibreOffice

    Quote Originally Posted by RGBsuse View Post
    After uninstalling the kde related LibO packages, do the following as root (this is for 64 bits systems):

    mv /usr/lib64/libreoffice/basis-link/program/libvclplug_kde4lx.so /usr/lib64/libreoffice/basis-link/program/libvclplug_kde4lx.so.old

    mv /usr/lib64/libreoffice/basis-link/program/libvclplug_kdelx.so /usr/lib64/libreoffice/basis-link/program/libvclplug_kdelx.so.old

    (of course, you can just "rm" if you are bold enough... )
    On 3.4 this will not be necessary, though: kde4 integration is taking good shape on latest development releases.
    Thanks for the suggestion, RGBsuse. Unfortunately, it didn't work. I made sure no LibreOffice KDE packages were installed, checked that the files were renamed successfully, yet the program still uses my KDE theme for toolbar and button coloring. Perhaps there are other steps involved? Did this work for your system?

    Sav

  8. #8

    Default Re: Disable KDE4 Theme in LibreOffice

    The renamed libraries are the only kde plug-ins used by LibO: if you remove them, LibO will use the gtk plugin. But if you use a theme that apply to both, qt and gtk apps (like qtcurve) kde color scheme will be applied.

  9. #9
    Join Date
    Sep 2009
    Location
    Athens, Greece
    Posts
    70

    Default Απ: Re: Disable KDE4 Theme in LibreOffice

    Quote Originally Posted by RGBsuse View Post
    The renamed libraries are the only kde plug-ins used by LibO: if you remove them, LibO will use the gtk plugin. But if you use a theme that apply to both, qt and gtk apps (like qtcurve) kde color scheme will be applied.
    Thanks for the help, RGBsuse. Renaming the libraries didn't do anything for me, but your suggestion concerning the GTK theme pointed me in the right direction. I installed a few additional GTK themes and finally found one (Oxygen-Molecule) that was close to the default scheme used by LibreOffice. Now only the tooltips have strange colors but I don't mind that much.


    Thanks again for the help!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •