Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: How to disable alt-enter=maximize?

  1. #1
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default How to disable alt-enter=maximize?

    Hi,

    In 11.4 (both new or upgraded), under gnome, when I type [Alt][Enter] I get
    maximize window. If I do the same on gnome-terminal, it does nothing - so
    it must be a "feature" of xterm, which 11.2 did not have. Indeed, it is not
    listed on the desktop shortcuts.

    How do I disable it?

    It interferes with Midnight-Commander, alt-enter is used to copy filename
    to the command line.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  2. #2

    Default Re: How to disable alt-enter=maximize?

    I guess the easiest would be to use gconf-editor and look under /apps/metacity/window_keybindings. There you can disable 'maximize'. Otherwise you can do it on the command line using gconftool-2 - if we're talking about Gnome2 (?).

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: How to disable alt-enter=maximize?

    On 2011-05-09 04:06, please try again wrote:
    >
    > I guess the easiest would be to use gconf-editor and look under
    > /apps/metacity/window_keybindings. There you can disable 'maximize'.
    > Otherwise you can do it on the command line using gconftool-2 - if we're
    > talking about Gnome2 (?).


    That's what I said, that it is not there. No application under gnome
    maximizes on alt-enter. None, except xterm.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  4. #4

    Default Re: How to disable alt-enter=maximize?

    OK, I see. Yes, you're right. Only xterm does that (unlike any other terminal program) and it doesn't do it just under Gnome (I just checked under icewm). It looks like an xterm key binding. I don't know if it can be disabled through X resources or terminfo, but there would be the place to look. It's a nice feature though, IMHO.

  5. #5

    Default Re: How to disable alt-enter=maximize?

    xterm (255) didn't do it under 11.3, nor in Mandriva (257). But xterm in openSUSE 11.4 (268) or ArchLinux (269) now does. I would say this shortcut is implemented by default in the latest xterm versions.

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,627
    Blog Entries
    3

    Default Re: How to disable alt-enter=maximize?

    If I do "ALT-enter" in an xterm under KDE, it just beeps at me and does nothing.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  7. #7

    Default Re: How to disable alt-enter=maximize?

    Code:
    xterm -xrm "XTerm.fullscreen: never"
    or set this resource in your ~/.Xresources.

  8. #8
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: How to disable alt-enter=maximize?

    please try again wrote:

    >
    > xterm (255) didn't do it under 11.3, nor in Mandriva (257). But xterm in
    > openSUSE 11.4 (268) or ArchLinux (269) now does. I would say this
    > shortcut is implemented by default in the latest xterm versions.
    >

    I found some google result for debian (without a feedback in it if it works)
    for the Xresources which should disable it (disclaimer: I did not test it
    and do not know if it is debian specific)
    Code:
    XTerm*fullscreen: never
    XTerm.omitTranslation: fullscreen
    It is definitely a xterm feature not a DE feature, there is a lot of
    discussion and bug entries about that xterm [ALT][ENTER] fullscreen feature
    not working in the past.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  9. #9
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: How to disable alt-enter=maximize?

    martin_helm wrote:

    > please try again wrote:
    >
    >>
    >> xterm (255) didn't do it under 11.3, nor in Mandriva (257). But xterm in
    >> openSUSE 11.4 (268) or ArchLinux (269) now does. I would say this
    >> shortcut is implemented by default in the latest xterm versions.
    >>

    > I found some google result for debian (without a feedback in it if it
    > works) for the Xresources which should disable it (disclaimer: I did not
    > test it and do not know if it is debian specific)
    >
    Code:
    > XTerm*fullscreen: never
    > XTerm.omitTranslation: fullscreen
    >
    > It is definitely a xterm feature not a DE feature, there is a lot of
    > discussion and bug entries about that xterm [ALT][ENTER] fullscreen
    > feature not working in the past.
    >

    I found a slightly better post
    http://www.mail-archive.com/debian-b...msg884178.html
    where it is said that the above solution works on debian and there is also a
    patch attached for xterm, just in case someone is interseted in looking at
    it.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  10. #10
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: How to disable alt-enter=maximize?

    On 2011-05-09 12:31, martin_helm wrote:
    > I found a slightly better post
    > http://www.mail-archive.com/debian-b...msg884178.html
    > where it is said that the above solution works on debian and there is also a
    > patch attached for xterm, just in case someone is interseted in looking at
    > it.


    The patch is empty:

    Code:
    minas-tirith:~/tmp/xterm_patch # tree
    ..
    `-- usr
    `-- build
    `-- xterm
    `-- xterm-269+
    |-- MANIFEST.diff
    |-- charproc.c.diff
    |-- main.c.diff
    |-- package
    |   |-- debian
    |   |   `-- changelog.diff
    |   `-- xterm.spec.diff
    |-- version.h.diff
    `-- xterm.log.html.diff
    
    6 directories, 7 files
    All the files have 0 bytes, and there is no resources diff.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •