Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Strange sound problem

  1. #1

    Default Strange sound problem

    Posted the following in 64bit without any response so thought I would try here.

    I have just installed 11.4 64bit and duly followed the sticky guide for getting the required multimedia files installed.
    I find I have a problem with playing audio cd's the only program which will play an audio cd is Kaffeine but it does not play properly - it plays a few bars then silence, plays a few bars then silence and I can find no way of getting it to play without interruption. There are no sound problems with Kaffene when using it to play digital tv or dvd films.
    I have tried KsCD, Amarok, Mplayer, SMPlayer, and GNOME MPlayer none of which can I get to play a CD. With Amarok there does not appear to be a setting to play a CD as soon as it is put in the drive it would appear that you have to generate a playlist first, I can show the list of tunes on the CD but that's a far as it goes they will not add to a playlist or play.
    Please can anyone suggest what may be wrong or point me in the direction of a solution?

    If there is any specific information I need to provide please let me know.

    Have just found the player Clementine which apparently is based on Amarok. Although not providing a direct play facility I was able to load the cd to the playlist then play the tunes. This may be a clue to my problems in that I noticed that it had to mount the player first. Is there a setting for auto mounting?

    Ideally I would like to put an audio cd in my player and have it play automatically without me having to do anything. Is this facility available in 11.4 and if so which program do I need to install?


    Thank you in anticipation.

    merkland.

  2. #2

    Default Re: Strange sound problem

    Please has any one got any ideas?
    I have spent hours searching this forum for a solution but can't find anything that works. Only thing I have learnt is that I am not alone as a lot of others have or had the same problem - strangely I don't find it very reassuring!

    merkland.

  3. #3
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: Strange sound problem

    On standard 11.4 + KDE, when I insert an audio CD it is automatically mounted, but not played. KDE's device notifier offers to open it in Amarok or in Kaffeine only, by user selection.

    Amarok 2.4 opens but fails to list the CD and its contents (that worked on 11.3 with Amarok 2.3, where a playlist could be created), i.e. probably a bug with Amarok 2.4 (IIRC).

    Kaffeine opens and automatically plays the CD after short pause, with no breaks in track playback and transport facilities function well.

    SMPlayer > Open > Audio cd, although not listed by the device notifier, had regular breaks after short playback, and so is unusable for audio cd here.

    VLC > Media > Open Disc.. > select audio cd. The CD played without breaks during track playback, and transport facilities functioned well.

    That may give you some idea about where the problem lies.

  4. #4
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: Strange sound problem

    Amarok2 hasn't been very reliable playing audiocds. With the KDE 4.6 version there is also a change from HAL to udev which might be one of the reasons for this last issue. If you look in the Amarok forum you may find something helpful as there are several posts regarding this issue.

    I use the Last_FM scrobbler so for me Audacious was the solution. Kaffeine (KDE3) and Xine does also play audiocds fine on my system, so does Clementine but I haven't been able to have Clementine retrive cddb/tag info, hence scrobbling is useless. Xine and Kaffeine has no scrobbling option as I'm aware of.

    If you find a player you like and which works for you, you might try add it to the list in System Settings > Device Actions. You can try to add Clementine there and see if it loads the tracks automatically then. If you are uncertain to what commands and settings to give Clementine, look at the Amarok entry by clicking the edit button and try copying it.

    Auto mounting is configurable in System Settings > Removable Media
    OpenSuSE 13.1, KDE 4.11.5, 64bit
    Gigabyte 990FXA-UD3, AMD FX8350, MSI GeForce GTX 760, RME HDSP9632, 16GB HyperX Kingston DDR3, Samsung 840-Pro SSD 128GB, WD Desktop Black 1TB, Hitachi Deskstar 7K1000 750GB

  5. #5

    Default Re: Strange sound problem

    Many thanks for the contributions I had more or less given up apart from checking if anything was working properly after any update came in and was installed, no luck so far!

    merkland

  6. #6

    Default Re: Strange sound problem

    Well I am no further forward in fact I have gone backwards, possibly a combination of my trying to get audio cd's to play and the number of various updates that have come in recently.
    The position now is that no program installed on my pc will play an audio cd apart from Kaffein which still plays as I described in my first post. Kaffein excepted the problem seems to be that none of the other programs are able to access the cdrom directly. Dolphin has no problems with reading audio cd's and if I select a tune and click 'open with' then pick any of the programs which cannot play the audio cd the tune is loaded into the playlist and then played but not directly from the cd.
    VLC when asked to play an audio cd gives an error message on screen which says " VLC is unable to open this MRL cdda:///dev/cdrom" this may give some of you more knowledgeable types a clue as to what is wrong.
    I must say that I am absolutely clueless with this command line stuff in a termial, and to old now to learn, give me a GUI where you can actually see things and I can usually manage but If you have to memorise things then my brain gives up! Having said that I can follow instructions when I have them in writing so if there are any outputs from commands in terminal that anyone would like to see just tell me.
    If nobody is able to point me in the right direction as a last resort I will try a new install.

    merkland

  7. #7
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: Strange sound problem

    Kaffeine is still playing as badly as you explained previously? How is your sound when playing mp3/ogg files etc?
    You should be careful not to add too many repositories in your attempt to solve this issue, that might mess things up. If you plan to re-install you should keep that in mind as well, though I suppose you know this. Mixing 'Packman' and 'VLC' repos are know to be messy. For a brief check, you could go into Yast and check your Xine and GStreamer packages to confirm that they are all from Packman, which is the recommended repo on this forum. Just search them out, click on the 'version' tab and scroll down over the different packages. You could also go into the KDE control centre: System Settings > Hardware > Multimedia and change the phonon backend to see if that changes anything (I presume you are using KDE).

    BTW, you could have a go at Audacious, that one works for me.

    Cheers
    OpenSuSE 13.1, KDE 4.11.5, 64bit
    Gigabyte 990FXA-UD3, AMD FX8350, MSI GeForce GTX 760, RME HDSP9632, 16GB HyperX Kingston DDR3, Samsung 840-Pro SSD 128GB, WD Desktop Black 1TB, Hitachi Deskstar 7K1000 750GB

  8. #8

    Default Re: Strange sound problem

    Thanks for your reply.
    I don't have, and never have had, the VLC repository on my PC. The version of VLC i have on my machine was downloaded from the Packman repo, also Xine and Gstreamer are from Packman.
    There is no direct control over which format on an audio cd you try to play in kaffein (that I know of) the only way I can answer your query is by opening the CD in Dolphin first. When asked to play an mp3 file I get the message "Cannot find input plugin for MRL "audiocd:/MP3/Track%2005.mp3?device=/dev/sr0"". Similarly when I try to play an ogg file I get "Cannot find input plugin for MRL "audiocd:/Ogg%20Vorbis/Track%2006.ogg?device=/dev/sr0"". This seems to confirm the error message from VLC in that for some reason /dev/cdrom and /dev/sro are not accessable.
    Dont't know whether this is relevant but when I look in Dolphin at the properties of these two files /dev/cdrom is shown as a Type = block device, Size = 0 B(0), Points to sr1 and /dev/sr0 is shown as Type = block device, Size = 0 B(0). Does the fact that the size is shown as 0 have any bearing on the problem?
    Quote "You could also go into the KDE control centre: System Settings > Hardware > Multimedia and change the phonon backend to see if that changes anything (I presume you are using KDE)."
    I am using KDE. Could you expand on this - when I click on Phonom I get this message come up
    "KDE detected that one or more internal sound devices were removed.
    Do you want KDE to permanently forget about these devices?
    This is the list of devices KDE thinks can be removed:
    Capture: HDA ATI SB (ALC888 Analog)
    Capture: HDA ATI SB (ALC888 Analog) #2
    Output: HDA ATI HDMI (ATI HDMI)
    Output: HDA ATI HDMI, ATI HDMI (HDMI Audio Output)
    Output: HDA ATI SB (ALC888 Analog)
    Output: HDA ATI SB (ALC888 Digital) #1"
    I don't know how this is arrived at because because according to Yast/Hardware/Hardware information I have only two sound systems on my machine which are 'SBx00 Azalia(Intel HDA)' and R700 Audio Device(Radeon HD 4000 Series)
    Not knowing exactly what this means and what problems if any it might cause I have always clicked 'No'
    What do you mean by changing the backend and to what?
    If you can throw some light on all this I will be eternally gratefull.

    merkland

  9. #9
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: Strange sound problem

    There is no direct control over which format on an audio cd you try to play in kaffein (that I know of) the only way I can answer your query is by opening the CD in Dolphin first. When asked to play an mp3 file I get the message "Cannot find input plugin for MRL "audiocd:/MP3/Track%2005.mp3?device=/dev/sr0"". Similarly when I try to play an ogg file I get "Cannot find input plugin for MRL "audiocd:/Ogg%20Vorbis/Track%2006.ogg?device=/dev/sr0""
    What I meant was an audiofile, e.g. some.ogg/mp3 file on your hard-drive, just to confirm that codecs worked alright. But as you can play DVDs I suppose they do.

    Dont't know whether this is relevant but when I look in Dolphin at the properties of these two files /dev/cdrom is shown as a Type = block device, Size = 0 B(0), Points to sr1 and /dev/sr0 is shown as Type = block device, Size = 0 B(0). Does the fact that the size is shown as 0 have any bearing on the problem?
    You shouldn't worry about this: Device file - Wikipedia, the free encyclopedia

    I am using KDE. Could you expand on this - when I click on Phonom I get this message come up
    "KDE detected that one or more internal sound devices were removed.
    Do you want KDE to permanently forget about these devices?
    This is the list of devices KDE thinks can be removed:
    Capture: HDA ATI SB (ALC888 Analog)
    Capture: HDA ATI SB (ALC888 Analog) #2
    Output: HDA ATI HDMI (ATI HDMI)
    Output: HDA ATI HDMI, ATI HDMI (HDMI Audio Output)
    Output: HDA ATI SB (ALC888 Analog)
    Output: HDA ATI SB (ALC888 Digital) #1"
    This has happened to me as well, several times, it happens in connection with updates. Those ports no longer detected has probably been labelled under a new name or something similar. I believe you will find them still being present somehow so just say 'yes' to forget them. You should then go here: System Settings > Hardware > Multimedia > Phonon Here you have two tabs Device Preference and Backend Get yourself an overview of how this work (top on the list - preferred device). In the Backend tab you have the choices I mentioned in my previous post, stick to Xine is my suggestion. The alternatives are: Xine, GStreamer, and VLC (if not present you have to install it). You could post back and explain what settings you have, the device list and the phonon backend.

    If you have several cdrom devices (hardware) you might try this. Go to System Settings > Hardware > Multimedia > Audio CD and click on specify device. Try any of these: /dev/cdrom, /dev/cdrom0, /dev/cdrom1 (one at a time).

    BTW, have you tried Audacious yet? Audacious is a non-KDE app which could get you away from problems related to KDE.

    Cheers
    OpenSuSE 13.1, KDE 4.11.5, 64bit
    Gigabyte 990FXA-UD3, AMD FX8350, MSI GeForce GTX 760, RME HDSP9632, 16GB HyperX Kingston DDR3, Samsung 840-Pro SSD 128GB, WD Desktop Black 1TB, Hitachi Deskstar 7K1000 750GB

  10. #10

    Default Re: Strange sound problem

    Yes I have installed Audacious and after a few hiccups it is working perfectly.
    I note that in preferences it says it is using the ALSA output plug-in, I suppose this may be a clue that phonom is what is causing my problems! I will try your suggestions re the other changes when I have a little more time.
    Thanks again for your help.

    merkland.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •