Results 1 to 3 of 3

Thread: Some fonts not recognized

  1. #1
    Join Date
    Feb 2011
    Location
    127.0.0.1
    Posts
    472

    Default Some fonts not recognized

    OS: OpenSUSE 11.4
    Desktop Environment: KDE

    When I run
    Code:
    fc-list
    my Adobe fonts are displayed. If I do
    Code:
    fc-list | grep "Adobe"
    my fonts are found again. If I look for them in /usr/share/texmf/fonts, they are not missing.

    But when I scroll through LibreOffice I don't see any font of the Adobe family. I did
    Code:
    #fc-cache -fv
    just to be sure (again) they are cached, but to no avail.

    Why is that so?

  2. #2
    Join Date
    Feb 2011
    Location
    127.0.0.1
    Posts
    472

    Default Re: Some fonts not recognized

    I have a partial solution to this (can use the fonts with XeTex, but I still don't know why LibreOffice does not display them). I've asked on a specialized site, and they gave me an answer which worked for me.

    First,

    Code:
    sudo zypper lcdf-typetools
    and then

    Code:
    otfinfo -a /path/to/filename
    You use the name prompted, NOT the one listed in with "fc-list", as there might be some issues of incompatibility when using the package "fontspec".
    Reliable + rider = RiDeR PlUs
    ...if you find this helpful, click on the star below...
    +-+ +-+
    |r| |+|
    +-+ +-+

  3. #3
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,611

    Default Re: Some fonts not recognized

    Most of the Texlive fonts are not recognised by LibreOffice apart from the Opentype fonts in /usr/share/texmf/fonts/opentype/public. LibreOffice normally looks for its fonts in /usr/share/fonts or /usr/share/local/fonts. I am not quite sure why it picks up the Texlive Opentype fonts.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •