Results 1 to 7 of 7

Thread: Trouble Logging in

  1. #1

    Default Trouble Logging in

    Hi,
    I have Open Suse 11.3. I normally use GNOME or KDE sessions. Yesterday I was just thought of trying other Desktop Environments. so I logged out to choose a different session. I tried LXDE and logged back out. After that I found "metacity" in the sessions list and tried it. But no desktop appeared. All I got is black screen a with the mouse pointer/cursor. I waited for quite some time but no desktop, panel, etc loaded or was visible. I could not figure out how to log off so I hit the start button. After reboot the system automatically chose the same session (It always reuses the last used session) and I was in the same sticky situation. I tried starting in Safe mode as well but still I get the same black screen with just the mouse pointer. Can some body please help. Where is the last used session info stored and how do I reset the session to KDE/GNOME.

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Trouble Logging in

    On 05/07/2011 07:06 PM, girishshivakumar wrote:
    >
    > Hi,
    > I have Open Suse 11.3. I normally use GNOME or KDE sessions.
    > Yesterday I was just thought of trying other Desktop Environments. so I
    > logged out to choose a different session. I tried LXDE and logged back
    > out. After that I found "metacity" in the sessions list and tried it.
    > But no desktop appeared. All I got is black screen a with the mouse
    > pointer/cursor. I waited for quite some time but no desktop, panel, etc
    > loaded or was visible. I could not figure out how to log off so I hit
    > the start button. After reboot the system automatically chose the same
    > session (It always reuses the last used session) and I was in the same
    > sticky situation. I tried starting in Safe mode as well but still I get
    > the same black screen with just the mouse pointer. Can some body please
    > help. Where is the last used session info stored and how do I reset the
    > session to KDE/GNOME.
    >
    >


    first turn off auto-login, to do that at the first green screen type 3
    and hit enter, it will then boot to a command line where you log in as
    root, give the root pass (you will not see what you type) then, type and
    enter

    Code:
    yast
    and the command line version of YaST will pop up...in it you navigate
    around with the Tab, arrows, enter or + to go System (on left) >
    /etc/sysconf Editor (on right) select it (with an enter) then go to
    Desktop + to + Display Manager > DISPLAYMANAGER_AUTOLOGIN and set it to
    blank...this should force a login screen.

    once you have disabled auto-login and exited from yast, then (still as
    root) enter

    Code:
    init 5

    and, you should come to a green log in page, where in the lower left
    hand corner you will see a link to "Sessions", click it and select a
    desktop environment (Metacity is a windows manager, not a desktop, as
    you found) then just log in as yourself, and you are off..

    --
    CAVEAT: http://is.gd/bpoMD
    [openSUSE11.3 + KDE4.5.5 + Firefox3.6.17 + Thunderbird3.1.10 via NNTP]
    HACK Everything -> http://www.youtube.com/watch?v=j5b4CCe9pS8&NR=1

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Trouble Logging in

    On 2011-05-07 19:06, girishshivakumar wrote:
    > so I hit
    > the start button


    Instead, hit ctrl-alt-backspace, twice.
    Or ctrl-alt-f1 and log in there.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Trouble Logging in

    On 2011-05-07 20:28, DenverD wrote:
    > (Metacity is a windows manager, not a desktop, as you found)


    It can be used as a desktop as well. At least, could be done in the past,
    IIRC. Very simple.

    I tried in mine, I don't have metacity offered. I have WindoMaker instead,
    but it does not load. Ah, I see, it does load with another user. A simple
    desktop, menu, etc. And it is also a window manager :-)

    Several window managers can be used separately as simple desktops. I don't
    know why metacity doesn't work, perhaps it is not intended as such in oS.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  5. #5

    Default Re: Trouble Logging in

    Thank you all for your help. I tried Denver's solution and it worked. Thanks Denver.

  6. #6

    Default Re: Trouble Logging in

    Hi Carlos,
    I tried both key strokes from GNOME and they took me to the comand line but how do I get back to the session? The only way I could get out of the comand line was to hit the power button (init 0) ot init 6. Strangely init 5 didnt seem to have any effect.

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Trouble Logging in

    On 2011-05-08 20:36, girishshivakumar wrote:
    >
    > Hi Carlos,
    > I tried both key strokes from GNOME and they took me to the
    > comand line but how do I get back to the session?


    ctrl-alt-f7. This is basic knowledge...

    There are 10 virtual consoles, try. Guess what to type to go to each one,
    I'm not telling. :-P

    > The only way I could
    > get out of the comand line was to hit the power button (init 0) ot init
    > 6.


    Sigh. :-(

    > Strangely init 5 didnt seem to have any effect.


    Not at all, you are already on runlevel 5.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •