Results 1 to 10 of 10

Thread: Can't update any more

  1. #1

    Default Can't update any more

    Hello

    I can't update anymore since a few days :

    Download (curl) error for 'http://download.opensuse.org/update/11.2/repodata/6bf430777ed6cb3fda3cad7bb437f49e4038cc4d-susedata.xml.gz':
    Error code: Connection failed
    Error message: Failed to connect to 2a01:e0c:1:1598::1: Network is unreachable

    I read somewhere that I should deactivate IPv6, which I did with no success.

    It seems to happen since I upgraded gnome following this link :
    Archive:GNOME 2.30 - openSUSE

    My Internet connection is of course alive and working.

    Thanks for helping

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Can't update any more

    On 2011-05-07 14:36, biribi44 wrote:
    >
    > Hello
    >
    > I can't update anymore since a few days :


    What program are you using, zypper?

    >
    > Download (curl) error for
    > 'http://download.opensuse.org/update/11.2/repodata/6bf430777ed6cb3fda3cad7bb437f49e4038cc4d-susedata.xml.gz':
    > Error code: Connection failed
    > Error message: Failed to connect to 2a01:e0c:1:1598::1: Network is
    > unreachable


    Try that with a browser.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  3. #3

    Default Re: Can't update any more

    I tried with Firefox and also as root with wget : no problem.

  4. #4
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    1,711

    Default Απ: Re: Can't update any more

    Open your terminal and write this
    Code:
    su
    Code:
    # zypper refresh
    Send the outptu here.
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15.3||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1080 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  5. #5
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Can't update any more

    On 05/07/2011 02:36 PM, biribi44 wrote:
    >
    > Error message: Failed to connect to 2a01:e0c:1:1598::1: Network is
    > unreachable


    to me, that looks like an IPv6 address, and therefore both your machine
    and every ISP, net router, switch between your fingers and that server
    must be capable of routing to it via IPv6, or you can't get there...

    --
    CAVEAT: http://is.gd/bpoMD
    [openSUSE11.3 + KDE4.5.5 + Firefox3.6.17 + Thunderbird3.1.10 via NNTP]
    HACK Everything -> http://www.youtube.com/watch?v=j5b4CCe9pS8&NR=1

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Can't update any more

    On 2011-05-07 17:48, DenverD wrote:
    > On 05/07/2011 02:36 PM, biribi44 wrote:
    >>
    >> Error message: Failed to connect to 2a01:e0c:1:1598::1: Network is
    >> unreachable

    >
    > to me, that looks like an IPv6 address, and therefore both your machine and
    > every ISP, net router, switch between your fingers and that server must be
    > capable of routing to it via IPv6, or you can't get there...


    You are right.

    So, he did not disable IPv6. Now, I wonder why his DNS gives him an IPv6
    address.


    cer@Telcontar:~> host "2a01:e0c:1:1598::1"

    1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.8.9.5.1.1.0.0.0.c.0.e.0.1.0.a.2.ip6.arpa
    domain name pointer ftp.proxad.net.
    cer@Telcontar:~>
    cer@Telcontar:~> host ftp.proxad.net
    ftp.proxad.net has address 212.27.60.27
    ftp.proxad.net has IPv6 address 2a01:e0c:1:1598::1

    cer@Telcontar:~> ping ftp.proxad.net
    PING ftp.proxad.net (212.27.60.27) 56(84) bytes of data.
    64 bytes from ftp.proxad.net (212.27.60.27): icmp_seq=1 ttl=50 time=104 ms
    64 bytes from ftp.proxad.net (212.27.60.27): icmp_seq=2 ttl=50 time=105 ms
    64 bytes from ftp.proxad.net (212.27.60.27): icmp_seq=3 ttl=50 time=106 ms
    ^C
    --- ftp.proxad.net ping statistics ---
    3 packets transmitted, 3 received, 0% packet loss, time 2002ms
    rtt min/avg/max/mdev = 104.904/105.864/106.861/0.883 ms
    cer@Telcontar:~>


    See? In my system, ping chooses to use IPv4, not IPv6. Why? I wonder what
    the same "host" command yields for him.




    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  7. #7

    Default Re: Can't update any more

    Here is what zypper refresh yields :
    georges2:/home/damien # zypper refresh
    Le dpt '11.2 - VideoLan' est jour.
    <snip>
    Recupration des mta-donnes du dpt 'Mises jour pour openSUSE 11.2-0' [|]
    Erreur de tlchargement (curl) pour 'http://download.opensuse.org/update/11.2/repodata/6bf430777ed6cb3fda3cad7bb437f49e4038cc4d-susedata.xml.gz':
    Code erreur: Connection failed
    Message erreur: Failed to connect to 2a01:e0c:1:1598::1: Le rseau n'est pas accessible

    Now host yields :

    host "2a01:e0c:1:1598::1"
    1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.8.9.5.1.1.0.0.0.c.0.e.0.1.0.a.2.ip6.arpa domain name pointer ftp.proxad.net.

    host ftp.proxad.net
    ftp.proxad.net has address 212.27.60.27
    ftp.proxad.net has IPv6 address 2a01:e0c:1:1598::1

  8. #8
    Join Date
    Jun 2008
    Posts
    1,825
    Blog Entries
    1

    Default Re: Can't update any more

    Quote Originally Posted by biribi44 View Post
    Hello

    I can't update anymore since a few days :

    Download (curl) error for 'http://download.opensuse.org/update/11.2/repodata/6bf430777ed6cb3fda3cad7bb437f49e4038cc4d-susedata.xml.gz':
    Error code: Connection failed
    Error message: Failed to connect to 2a01:e0c:1:1598::1: Network is unreachable

    I read somewhere that I should deactivate IPv6, which I did with no success.

    It seems to happen since I upgraded gnome following this link :
    Archive:GNOME 2.30 - openSUSE

    My Internet connection is of course alive and working.

    Thanks for helping
    This address; 2a01:e0c:1:1598::1: is an IPv6 address which equivalent to an IPv4 address of 0.0.0.0.
    When you disable ipv6 you have to reboot for it to take affect. How did you disable IPv6?

  9. #9

    Default Re: Can't update any more

    I used Yast and rebooted the system as it was required

  10. #10
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Can't update any more

    On 2011-05-07 22:36, biribi44 wrote:

    > Erreur de tlchargement (curl) pour
    > 'http://download.opensuse.org/update/11.2/repodata/6bf430777ed6cb3fda3cad7bb437f49e4038cc4d-susedata.xml.gz':
    > Code erreur: Connection failed
    > Message erreur: Failed to connect to 2a01:e0c:1:1598::1: Le rseau
    > n'est pas accessible


    It is using IPv6.

    > host ftp.proxad.net
    > ftp.proxad.net has address 212.27.60.27
    > ftp.proxad.net has IPv6 address 2a01:e0c:1:1598::1


    If you try "ftp.proxad.net" in firefox, does it work? In mine it works. And
    it uses IPv4.

    Mmm, look:

    Code:
    
    > cer@Telcontar:~> wget ftp://ftp.proxad.net/mirrors/ftp.opensuse.org/opensuse/update/11.2/repodata/6bf430777ed6cb3fda3cad7bb437f49e4038cc4d-susedata.xml.gz
    > --2011-05-08 01:23:35--  ftp://ftp.proxad.net/mirrors/ftp.opensuse.org/opensuse/update/11.2/repodata/6bf430777ed6cb3fda3cad7bb437f49e4038cc4d-susedata.xml.gz
    >            => `6bf430777ed6cb3fda3cad7bb437f49e4038cc4d-susedata.xml.gz'
    > Resolving ftp.proxad.net... 212.27.60.27, 2a01:e0c:1:1598::1
    > Connecting to ftp.proxad.net|212.27.60.27|:21... connected.
    > Logging in as anonymous ... Logged in!
    > ==> SYST ... done.    ==> PWD ... done.
    > ==> TYPE I ... done.  ==> CWD /mirrors/ftp.opensuse.org/opensuse/update/11.2/repodata ... done.
    > ==> SIZE 6bf430777ed6cb3fda3cad7bb437f49e4038cc4d-susedata.xml.gz ... 421168
    > ==> PASV ... done.    ==> RETR 6bf430777ed6cb3fda3cad7bb437f49e4038cc4d-susedata.xml.gz ... done.
    > Length: 421168 (411K)
    >
    > 100%[=====================================================================================>] 421.168     99,3K/s   in 4,1s
    >
    > 2011-05-08 01:24:12 (99,3 KB/s) - `6bf430777ed6cb3fda3cad7bb437f49e4038cc4d-susedata.xml.gz' saved [421168]
    >
    > cer@Telcontar:~>
    Now, I would have to try with curl, but it dumps the file to the console.
    Somebody knows the correct command line for curl?

    Ah, found it:

    Code:
    
    > cer@Telcontar:~> curl ftp://ftp.proxad.net/mirrors/ftp.opensuse.org/opensuse/update/11.2/repodata/6bf430777ed6cb3fda3cad7bb437f49e4038cc4d-susedata.xml.gz > p
    >   % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
    >                                  Dload  Upload   Total   Spent    Left  Speed
    > 100  411k  100  411k    0     0  72680      0  0:00:05  0:00:05 --:--:--   97k
    > cer@Telcontar:~>


    Why does it use IPv4 here, and IPv6 for you?
    Is there a configuration change that would tell it to use IPv4 only?




    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •