Results 1 to 5 of 5

Thread: zypper patch reports problem with cron package dependencies

  1. #1

    Default zypper patch reports problem with cron package dependencies

    Hello.
    In the last try to patch system with "zypper patch" command I got a problem
    with package dependencies.
    Code:
    Problem: cron-4.2-9.17.1.x86_64 requires cronie = 1.4.6-, but this requirement cannot be provided
     Solution 1: downgrade of cron-4.2-9.17.1.x86_64 to cron-4.2-9.3.1.x86_64
     Solution 2: do not install patch:cron-4495.noarch
     Solution 3: break cron by ignoring some of its dependencies
    I am a new user of Suse and I am not sure, if option 1 is a good choice...
    Thanks for the tips.

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,681
    Blog Entries
    3

    Default Re: zypper patch reports problem with cron package dependencies

    Personally, I would go with solution 2 (don't install patch).

    There's another thread on this:
    Cron upgrade problem
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  3. #3

    Default Re: zypper patch reports problem with cron package dependencies

    Hello nrickert, thanks for your answer.
    According to what Marcus wrote( in your link), option 1 is at the moment the best solution.
    You're right, I will also not install the patch.
    Marcus Meissner 2011-05-07 07:55:36 UTC
    the release numbers of "cron" got messed up.
    I told the build team already and they will fix it.
    Tschuss

  4. #4

    Default Re: zypper patch reports problem with cron package dependencies

    Mistake: I thought about option 2, of course.

  5. #5

    Default Re: zypper patch reports problem with cron package dependencies

    Have just refreshed my repos.
    The problem does not occur more.
    Regards

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •