Results 1 to 7 of 7

Thread: ethernet devices naming

  1. #1

    Default ethernet devices naming

    I want to use old devices names eth0, eth1 etc. instead of default OpenSuSE (11.1) eth_s0_0 etc.

    There is no firewall, no devices management via NetworkManager, static IP address.

    Is it enough

    1) to edit /etc/udev/rules.d/70-persistent-net.rules
    and insert eth0&eth1 instead of eth_s0_0 & eth_s0_1

    2) To rename /etc/sysconfig/network/ifcfg_eth_s0_0 ( and s0_1) to ifcfg_eth0 and ifcfg_eth1

    and then reboot ?

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,804

    Default Re: ethernet devices naming

    Hm, this may not be the real answer, but just some thoughts I had.

    1) 11.1 is beyond support since the beginning of 2011, thus most people will not be able to check or try out thigs for you on their systems.

    2) I have 11.2 and it uses eth0 as a device name. I tested 11.4 and I can not remember that it did not use eth0 (and I do allways go into YaST to fine tune the configuration). Thus I have no notice of this being an "old device name". This brings me to the question, are you very sure that what you experience has something to do with a new way of device naming?
    Henk van Velden

  3. #3
    Join Date
    Aug 2008
    Location
    Behind the 8 ball
    Posts
    116

    Default Re: ethernet devices naming

    Editing 70-persistent-net.rules and renaming the ifcfg files should work.
    If you want to avoid the reboot you can just remove the kernel modules for the NICs and then reload them.

    Good luck,
    Hiatt

  4. #4
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: ethernet devices naming

    On Sat, 07 May 2011 01:06:02 +0530, hcvv <hcvv@no-mx.forums.opensuse.org>
    wrote:

    >
    > Hm, this may not be the real answer, but just some thoughts I had.
    >
    > 1) 11.1 is beyond support since the beginning of 2011, thus most people
    > will not be able to check or try out thigs for you on their systems.
    >
    > 2) I have 11.2 and it uses eth0 as a device name. I tested 11.4 and I
    > can not remember that it did not use eth0 (and I do allways go into YaST
    > to fine tune the configuration). Thus I have no notice of this being an
    > "old device name". This brings me to the question, are you very sure
    > that what you experience has something to do with a new way of device
    > naming?
    >



    i've seen device names like that in debian. you didn't by chance import
    settings from that, or another, system into openSUSE?


    --
    phani.

  5. #5

    Default Re: ethernet devices naming

    Ehh, but where is here NIC driver ?
    igb ?

    Module Size Used by
    hwmon_vid 3256 0
    w83795 50476 0
    fuse 61088 1
    xfs 545312 1
    loop 17924 0
    dm_mod 73952 0
    i2c_i801 12836 0
    rtc_cmos 13960 0
    sr_mod 16196 0
    rtc_core 22420 1 rtc_cmos
    igb 83388 0
    pcspkr 3064 0
    cdrom 36200 1 sr_mod
    i2c_core 35280 2 w83795,i2c_i801
    button 8328 0
    rtc_lib 3560 1 rtc_core
    floppy 63240 0
    sg 35344 0
    ehci_hcd 55348 0
    uhci_hcd 27928 0
    sd_mod 35064 4
    crc_t10dif 2152 1 sd_mod
    usbcore 198656 3 ehci_hcd,uhci_hcd
    edd 10272 0
    ext3 141912 1
    mbcache 10412 1 ext3
    jbd 68824 1 ext3
    fan 6016 0
    ide_pci_generic 4652 0
    ide_core 118012 1 ide_pci_generic
    ata_generic 6044 0
    ata_piix 21628 3
    libata 183376 2 ata_generic,ata_piix
    scsi_mod 179144 4 sr_mod,sg,sd_mod,libata
    dock 14564 1 libata
    thermal 24232 0
    processor 49904 1 thermal
    thermal_sys 14336 3 fan,thermal,processor
    hwmon 4040 2 w83795,thermal_sys

  6. #6

    Default Re: ethernet devices naming

    Code:
    hwinfo --netcard | grep -i -e driver

  7. #7

    Default Re: ethernet devices naming

    Thanks !

    It's really igb :-)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •