Results 1 to 8 of 8

Thread: Cron upgrade problem

  1. #1
    Join Date
    Dec 2010
    Location
    Southern California
    Posts
    123

    Default Cron upgrade problem

    I am getting this error on a recent cron upgrade.

    cron-4.2-9.17.1.x86_64 requires cronie = 1.4.6-, but this requirement cannot be provided

    Could someone provide a solution or insight on this please.

    Thanks!
    Glasairmell
    ----------
    Better is the enemy of good!

  2. #2

    Default Re: Cron upgrade problem

    You should do a zypper refresh first. The current version of cronie is 1.4.7-, which is the one cron uses on my computer.

  3. #3

    Default Re: Cron upgrade problem

    I have the exactly same problem today.

    Nothing changed after "zypper refresh".

    It seems the latest cron and conie conflicts.

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,754
    Blog Entries
    3

    Default Re: Cron upgrade problem

    I am seeing the same error on two systems. One of those is 64 bit and the other is 32 bit.

    I unchecked the cron update, to allow the other updates to proceed. I am left with the cron update still waiting to be applied.

    Quote Originally Posted by please_try_again View Post
    You should do a zypper refresh first. The current version of cronie is 1.4.7-, which is the one cron uses on my computer.
    I tried "zypper refresh". It reported that all repos were up to date (or something like that). The problem remains.

    It's my impression that PackageKit does a refresh anyway, so it is not surprising that the explicit refresh didn't help.

    When I go into software management in Yast, it tells me that my cronie version is "1.4.6-7.17.1 (1.4.7-1.3.1)". If I tell Yast to update to 1.4.7-1.3.1, it reports an unresolvable conflict (cron version requires 1.4.6-).

    It looks to me as if there is something wrong with that cronie update.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  5. #5
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,452

    Default Re: Cron upgrade problem

    I went into YaST>Online update and it offered me a solution based on an earlier version of cronie.

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Cron upgrade problem

    On 2011-05-06 20:06, nrickert wrote:
    > When I go into software management in Yast, it tells me that my cronie
    > version is "1.4.6-7.17.1 (1.4.7-1.3.1)". If I tell Yast to update to
    > 1.4.7-1.3.1, it reports an unresolvable conflict (cron version requires
    > 1.4.6-).


    Report bug in bugzilla.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,754
    Blog Entries
    3

    Default Re: Cron upgrade problem

    Quote Originally Posted by robin_listas View Post
    Report bug in bugzilla.
    A comment added to the original bug report, with a request that it be reopened.

    https://bugzilla.novell.com/show_bug.cgi?id=690166
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  8. #8
    Join Date
    Jun 2009
    Location
    Pennsylvania, USA
    Posts
    233

    Default Re: Cron upgrade problem

    Same error here - looking at the package that causes the conflict (cron-4.2-19.7.1), it seems to be a placeholder for the changeover from Vixie cron to cronie, only containing a couple of doc files.

    Are these systems clean, fresh installs of 11.4, or upgrades? Mine was upgraded 11.4M5/6 - 11.4RC1 - 11.4.

    I may try uninstalling the placeholder, and trying the online update again.

    EDIT: Never mind - the dependencies all specify cron, not cronie. Guess we get to wait for it to get sorted out.
    Last edited by GeoBaltz; 06-May-2011 at 16:55. Reason: Tried removing placeholder, no joy.
    Use the Source, Luke

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •