Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: yast user/group management

  1. #1
    Join Date
    Jun 2008
    Location
    Rome, Italy
    Posts
    248

    Default yast user/group management

    hi all. On os11.4 i'm having this problem. I have to change details of the users of the system, but when i open yast2 / user management, it reads in the settings, groups and so on, but, when it shuold open the settings window, the applet closes suddenly and returns to the yast control centre. So no further editing is possible/allowed. Any idea? Thanks for reading

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: yast user/group management

    On 05/06/2011 06:06 PM, bcrisciotti wrote:
    >
    > hi all. On os11.4 i'm having this problem. I have to change details of
    > the users of the system, but when i open yast2 / user management, it
    > reads in the settings, groups and so on, but, when it shuold open the
    > settings window, the applet closes suddenly and returns to the yast
    > control centre. So no further editing is possible/allowed. Any idea?
    > Thanks for reading


    when you click to start YaST, does it ask for your root password?

    --
    CAVEAT: http://is.gd/bpoMD
    [openSUSE11.3 + KDE4.5.5 + Firefox3.6.17 + Thunderbird3.1.10 via NNTP]
    HACK Everything -> http://www.youtube.com/watch?v=j5b4CCe9pS8&NR=1

  3. #3
    Join Date
    Jun 2008
    Location
    Rome, Italy
    Posts
    248

    Default Re: yast user/group management

    Hi, thank you for your interesting. Yes, yast asks for password as usual. Everything works fine, exept the user/group management. simply this module closes after reading in the necessary informations, making impossible to change/add users. On another tread i've read that the reason could be a corrupted yast mail module. It seems strange, but i'm going to check this. If successfull i'll post again to help others in the same situation.

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,704
    Blog Entries
    1

    Default Re: yast user/group management

    Does the ncurses (text mode) interface behave the same way? (Try 'yast' from a root terminal).

  5. #5
    Join Date
    Jun 2008
    Location
    Rome, Italy
    Posts
    248

    Default Re: yast user/group management

    yes, the same...

  6. #6
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: yast user/group management

    On 05/07/2011 11:36 AM, bcrisciotti wrote:
    >
    > Everything works fine, exept the user/group management. simply
    > this module closes after reading in the necessary informations, making
    > impossible to change/add users.


    wild guess (may be a waste of time):

    open YaST, go Software Management, search for 'yast', in the resulting
    list right click on and then mark the following for "Update" and click
    the "Accept" button at the bottom..

    Code:
    yast2-users
    then try again...if that does not help, show us the output of this:

    Code:
    ls -hal /etc/pas*
    ls -hal /etc/gro*
    ls -hal /etc/sha*
    and, tell us if you have change any AppArmor settings, or maybe made any
    changes to the settings in YaST > Security and Users > Local Security or
    Firewall.....and, if you did make adjustments in those, what happens to
    YaST's User Group Management if you undo what you did?

    and, one word of caution: the security area of YaST is not a place to
    experiment without reading the directions and having a workable recovery
    plan--because it *is* possible to lock the world and even yourself (as
    root) out of a linux box.

    --
    CAVEAT: http://is.gd/bpoMD
    [openSUSE11.3 + KDE4.5.5 + Firefox3.6.17 + Thunderbird3.1.10 via NNTP]
    HACK Everything -> http://www.youtube.com/watch?v=j5b4CCe9pS8&NR=1

  7. #7
    Join Date
    Jun 2008
    Location
    Rome, Italy
    Posts
    248

    Default Re: yast user/group management

    Well! I solved the problem following what i did read on another forum (i don't remember wich one). I installed yast2-mail and voila': now yast2-users works!
    Thanks all for your help

  8. #8
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: yast user/group management

    On 05/07/2011 04:06 PM, bcrisciotti wrote:
    >
    > I installed yast2-mail and voila': now yast2-users works!


    amazing!
    what happened to your original yast2-mail?

    --
    CAVEAT: http://is.gd/bpoMD
    [openSUSE11.3 + KDE4.5.5 + Firefox3.6.17 + Thunderbird3.1.10 via NNTP]
    HACK Everything -> http://www.youtube.com/watch?v=j5b4CCe9pS8&NR=1

  9. #9
    Join Date
    Jun 2008
    Location
    Rome, Italy
    Posts
    248

    Default Re: yast user/group management

    so this is the story. Actually i was having that problem in an appliance built by me in susestudio. This is not the first i build but it is the first time i encounter this issue. It happens that if yast2-users is selected for installation, yast2-mail is not automatically added. Since i use the official oss repo, i suspect that the package yast2-users has broken dependencies. I will investigate on this.

  10. #10
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,704
    Blog Entries
    1

    Default Re: yast user/group management

    Good work fixing this bcrisciotti. (I've never encountered this issue on any forum before before). Thanks for the update.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •