Results 1 to 3 of 3

Thread: WHy does my SuSE-Kernel ignores my framebuffer disable via vga=0 ?

  1. #1

    Default WHy does my SuSE-Kernel ignores my framebuffer disable via vga=0 ?

    Hi,

    Kernel parameter vga=0 or vga=normal does not work as expected - First it works as expected text mode resolution is 80x25, but after some seconds the kernel, or the initramdisk does switch resolution of console again! I hate to say but it looks like OpenSuSe (again) thinks it is more clever than the user ...

    Since rmmod radeon in runlevel 3 says "ERROR: Module radeon is in use", I do think that somehow SuSe ignores my vga=0 ... Is it the kernel or the ramdisk, I do not know where to search, since the parameter vga=0 is accepted and used in the beginning - it switch again after "doing fast boot" or 1-2 lines later...

    Any ideas on this? Its Opensuse 11.4

    Code:
    linux-wjf9:~ # uname -a
    Linux linux-wjf9.site 2.6.37.6-0.5-default #1 SMP 2011-04-25 21:48:33 +0200 i686 i686 i386 GNU/Linux

  2. #2

    Default Re: WHy does my SuSE-Kernel ignores my framebuffer disable via vga=0 ?

    You need to disable KMS by adding 'nomodeset' to the kernel boot parameters if you want a text mode resolution in console.

  3. #3

    Default Re: WHy does my SuSE-Kernel ignores my framebuffer disable via vga=0 ?

    Thanks that helps!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •