Results 1 to 7 of 7

Thread: Failed to initialize the second NVIDIA GPU in openSUSE 11.4

  1. #1

    Unhappy Failed to initialize the second NVIDIA GPU in openSUSE 11.4

    I have 2 NVIDIA card intalled - GT 240 and Geforce 9500.
    After updating by repo kernel to ver 2.6.37.6-0.5.1 and Nvidia driver by to ver 270.41.06 X server cant start

    Part of X server log
    347.737] (EE) NVIDIA(GPU-1): Failed to initialize the NVIDIA GPU at PCI:2:0:0. Please
    [ 347.737] (EE) NVIDIA(GPU-1): check your system's kernel log for additional error
    [ 347.737] (EE) NVIDIA(GPU-1): messages and refer to Chapter 8: Common Problems in the
    [ 347.737] (EE) NVIDIA(GPU-1): README for additional information.
    [ 347.737] (EE) NVIDIA(GPU-1): Failed to initialize the NVIDIA graphics device!
    [ 347.737]
    Backtrace:
    [ 347.737] 0: X (xorg_backtrace+0x37) [0x80ee5f7]
    [ 347.737] 1: X (0x8048000+0x5cbea) [0x80a4bea]
    [ 347.737] 2: (vdso) (__kernel_rt_sigreturn+0x0) [0xffffe40c]
    [ 347.737] 3: /usr/lib/xorg/modules/updates/drivers/nvidia_drv.so (0xb50a7000+0x4144e8) [0xb54bb4e8]
    [ 347.737] Segmentation fault at address (nil)
    [ 347.737]
    Fatal server error:
    [ 347.737] Caught signal 11 (Segmentation fault). Server aborting
    [ 347.737]


    dmesg | grep nv , vmap

    [ 0.000000] BIOS-e820: 00000000bbf8e000 - 00000000bbfe0000 (ACPI NVS)
    [ 11.066714] nvidia: module license 'NVIDIA' taints kernel.
    [ 11.883284] NVRM: loading NVIDIA UNIX x86 Kernel Module 270.41.06 Mon Apr 18 14:54:25 PDT 2011
    [ 113.916852] NVRM: loading NVIDIA UNIX x86 Kernel Module 270.41.06 Mon Apr 18 14:54:25 PDT 2011
    [ 118.008769] NVRM: RmInitAdapter failed! (0x26:0xffffffff:1050)
    [ 118.008894] NVRM: rm_init_adapter(1) failed
    [ 118.200853] NVRM: RmInitAdapter failed! (0x26:0xffffffff:1050)
    [ 118.006562] vmap allocation for size 16781312 failed: use vmalloc=<size> to increase size.
    [ 118.198734] vmap allocation for size 16781312 failed: use vmalloc=<size> to increase size.
    [ 186.022892] vmap allocation for size 16781312 failed: use vmalloc=<size> to increase size.
    [ 282.985323] vmap allocation for size 16781312 failed: use vmalloc=<size> to increase size.

    [ 118.200864] NVRM: rm_init_adapter(1) failed
    [ 186.025243] NVRM: RmInitAdapter failed! (0x26:0xffffffff:1050)
    [ 186.025253] NVRM: rm_init_adapter(1) failed
    [ 282.986762] NVRM: RmInitAdapter failed! (0x26:0xffffffff:1050)
    [ 282.986771] NVRM: rm_init_adapter(1) failed



    So for now only dismounting one of cards gives working X server.

  2. #2

    Default Re: Failed to initialize the second NVIDIA GPU in openSUSE 11.4

    did you make a separate entry in xorg.conf for each of the cards ?
    for device0 and 1



  3. #3

    Unhappy Re: Failed to initialize the second NVIDIA GPU in openSUSE 11.4

    yes there is separate entries in xorg.conf for each card
    i even tried to remove all entries about second card from xorg.conf
    and even tried to delete xorg.conf to try autodetect
    result was always the same

    ps
    if there is a need I can post my xorg.conf

  4. #4

    Default Re: Failed to initialize the second NVIDIA GPU in openSUSE 11.4

    Now i reinstalled all the system (not recovered but REINSTALLED)
    and problem is the SAME
    and now i am assured for 99% that it is a bug in kernel (i tried pae, default desktop 2.6.37.6-0.5.1)
    and nvidia .run ( 270.41.06 , 270.41.03, 260.19.44)

    260.19.44 boots but second gpu sill dosn't detects

    I tested me hardware in other OS type and it works!!!

    Do anybody have the same problem ???

    Or any idea about fixing ....

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Failed to initialize the second NVIDIA GPU in openSUSE 11.4


  6. #6

    Unhappy Re: Failed to initialize the second NVIDIA GPU in openSUSE 11.4

    I belive that it is not a problem in xorg but driver & kernel

    even if xorg.conf is blank problem is still present

  7. #7

    Angry Re: Failed to initialize the second NVIDIA GPU in openSUSE 11.4

    Now I got the solution but I DONT LIKE IT

    Official from Nvidia
    If you are seeing severe stability problems and you are using a Linux 2.6 SMP kernel on a system with multiple processors (or processor cores) in combination with more than one GPU, please search the output of `dmesg` for the presence of the message below after the system has just been started:

    PCI: Using MMCONFIG


    If this message is present, please boot the system with the pci=nommconf kernel parameter and check if the stability problems continue to reproduce.

    If your system is equipped with a dual-core processor, booting with the idle=poll and/or maxcpus=1 kernel parameters may improve reliability with some Linux kernels.

    Similarly, forcing the clock source to HPET by booting with the clocksource=hpet kernel parameter has been reported to help on some systems. In order for this to work, you may need to enable HPET in your SBIOS and kernel configuration.



    SO now I got half of my CPU
    because in my case only using pci=nommconf maxcpus=1 kernel parameters helps

    WE NEED NEW PATCHED KERNEL !!!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •